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Getting Started 

Introduction to spatialNET 
spatialNET is a core component of SPATIALinfo’s software solutions portfolio that manages physical 
network inventories for communications service providers. An end-to-end design, engineering, and 
inventory- management application, spatialNET makes network data available to enhance business 
practices across the organization to systems designed for ERP, finance, project management, billing, 
provisioning, order management, and an array of other critical business functions.  

With spatialNET, you can design fiber, coaxial, and twisted-pair communications networks in a familiar 
CAD design environment. But unlike other CAD-based systems, rather than saving data in files spatialNET 
manages modeled data in SPATIALinfo’s robust, spatially enabled information model that includes detailed 
information for every design element.  

spatialNET supports a full range of business practices in the telecommunications provider’s organization 
and includes functions for : 

• Planning 

• Design 

• Construction 

• Operations 

• Maintenance 

• Management 

spatialNET – and all of SPATIALinfo’s software products – use industry-standard software platforms to 
bring a functional workspace to users, system implementers, and IT administrators, employing technologies 
including: 

AutoCAD – The industry leading CAD platform provides powerful yet familiar tools for drafters, 
designers, and engineers. In spatialNET, AutoCAD provides CAD-based representations of data, for 
both graphical visualization and editing. 
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Oracle – The robust relational database with spatial data management capabilities that extends data 
across the organization to enhance business practices in sales, marketing, operations, field 
maintenance, customer service, planning, and operations support, and others. 

Python – The well-known source scripting language extends spatialNET for customized applications 
that meet specific company needs. 

Google Maps/Google Earth – Highly used and easily recognized mapping tools provide a convenient 
backdrop and an accessible environment for validating and studying real-world locations of network 
assets and their surroundings.  

Because spatialNET stores all equipment and attribute data stored in a relational database, all the network 
information is presented as a completely seamless map, unlike systems that store data in files. As a result,  
network maps show none of the breaks between the edges of drawings or “tiles” that are common in 
traditional file-based systems. In spatialNET, you can zoom in or out to any level to view and edit selected 
entities or areas in the CAD window or view and edit the detailed attributes of any entity in a browser or 
dialog box, or both. 

spatialNET manages and models fiber-optic, coaxial, and twisted-pair copper networks, including: 

• Cable and equipment specifications 

• Location and details of network facilities 

• Location, configuration, and connectivity of outside plant cables and equipment 

• Physical splicing of individual fibers or pairs, and groups of fibers or pairs 

• Usage and status management of end-to-end network paths 

• Logical circuits and their relation to physical plant 

• Inside Plant, including fully integrated connectivity between inside-plant sites and outside-plant 
equipment 

AutoCAD and spatialNET 
spatialNET uses AutoCAD both to display viewable database objects and to provide an interface for 
designing, placing, and editing graphical characteristics of defined network objects. spatialNET allows you 
to interact with objects displayed in AutoCAD, depending on the type of object. The types of objects 
include both spatialNET entities and CAD-scraped entities. 

spatialNET Objects 
spatialNET entities represent objects managed by the spatialNET data model. Their primary distinctions are 
include: 

• They have properties (or attributes) defined in spatialNET. The input and validation of these 
attributes is managed by spatialNET’s application functionality, and their values are stored in the 
database tables and columns defined by the spatialNET object model. 

• They satisfy specific rules and constraints, including such as valid network connectivity and 
configuration. 

• Their CAD representation is managed by spatialNET, which generally does not create or update 
spatialNET entities using AutoCAD commands. spatialNET commands are controlled through 
spatialNET menus or toolbars. 
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• They are defined by their data and relationships, unlike CAD entities, which are defined by their 
geometry and appearance. Consequently, many of the operations performed on CAD entities may 
not be appropriate for spatialNET entities, nor do they provide processing or rule-checking that 
ensure the validity of spatialNET entities. 

To make it easy to differentiate spatialNET entities from ordinary CAD objects, spatialNET displays a 
special kind of grip called a manipulator that appears when an entity is selected in the AutoCAD window.  

CAD Objects 
spatialNET manages entities required to model a communications network while allowing you to continue 
to use many normal AutoCAD objects as you design. Objects managed in AutoCAD but not modeled in 
spatialNET are referred to as “CAD-scrape” objects, which reside in the spatialNET database rather than in 
DWG files. The only difference between an CAD-scraped object and an object stored in a DWG file is that 
the handle of the CAD-scraped object’s is not preserved in the spatialNET database. This difference only 
affects developers writing programs in one of AutoCAD’s extensibility languages. 

The AutoCAD object types listed below are supported by CAD-scrape. 

• Lightweight Polylines (2D and 3D polylines are not  supported) 

• Lines 

• Arcs 

• Splines 

• Circles 

• Text 

• MText 

• Block References (including attributes. See Note 4, below) 

• Hatches (inside-plant views only) 

The primary ways in which spatialNET distinguishes CAD-scraped entities from AutoCAD entities include: 

• Unlike spatialNET entities, which are automatically saved to the database whenever a change is 
made, CAD-scraped entities are not saved until you run the AutoCAD Save command.  

• The system saves any Extended Entity Data (EED or XDATA) attached to an AutoCAD object and 
re-attaches it when that object is rendered back into AutoCAD.  

• In Autodesk Map, the system will not save any Map Object Data attached to an AutoCAD object.   

• When CAD-Scraping blocks, spatialNET does not store the block definition in the database. The 
block definition must either be stored on disk in a DWG file in the current AutoCAD Support Files 
path, or be included in the view’s template. If no block definition is found, spatialNET displays the 
following symbol in its place: 
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While spatialNET entities are used to model complex network data, you can still create many kinds of 
AutoCAD objects using simple AutoCAD commands, and spatialNET saves them in the database. When an 
area is queried from the database and rendered into AutoCAD, CAD-scraped entities will be included as if a 
DWG file containing that area had been opened.   

To interact with CAD-scraped entities, use regular AutoCAD commands.  

The following table contains a summary of the differences in spatialNET’s handling of spatialNET and CAD-
scraped entities. 

Operation spatialNET Entity CAD-scraped Entity 

Create new object Run function from appropriate spatialNET menu Use AutoCAD commands to create 
object 

Edit existing object Run spatialNET Edit function Use AutoCAD commands 

Delete object Use the spatialNET Delete function Use AutoCAD ERASE, or the Delete 
key 

Move, rotate, etc. Use spatialNET manipulators Use AutoCAD grips, and commands 

Undo 
Use spatialNET Undo Note: If you use 
spatialNET Undo, all CAD changes in the last 
save operation will be rolled back. 

Use AutoCAD Undo, or Ctrl-Z 

Save No action required. spatialNET entities are 
immediately saved whenever they are changed. 

AutoCAD Save command (this will 
automatically save to the database) 

Opening a CAD File 

To import a CAD-scraped file: 

1. Run the AutoCAD File > Open command as you normally would to open a drawing file. 

2. spatialNET analyzes the drawing and displays a dialog box prompting you to choose how you would 
like the drawing to be treated.  There are two versions of this dialog box, depending on whether the 
DWG file was: 

• Saved from a spatialNET session, or 

• Created outside of the spatialNET environment. 

The two forms of the dialog box are shown below. 

Dialog displayed when opened drawing file was created outside spatialNET: 
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Dialog displayed when opened drawing file was created from a spatialNET session: 

 
The fields are as follows: 

• Open Drawing as: Specify whether to open the drawing as a spatialNET view, or as a Native 
Drawing. 

• If opened as a spatialNET view, it will be possible to query in objects from the database, or to 
import the contents of the drawing into the database by running the AutoCAD Save 
function.  Select this option if you wish to do this.  Any objects in a DWG derived from a 
spatialNET view will be reconnected to the database. 

• If opened as a Native Drawing, spatialNET will ignore the drawing and you will be able to work 
with it as a normal DWG file.  Running AutoCAD Save will save the DWG file to disk as normal, 
but will not import any data into the database. 

• View Type to use: Specifies how spatialNET will store the CAD data in the database. The options 
and their meanings are: 

• SPATIALFM_ALL: Seamless outside plant view with no association to a logical document. 

• SPATIALFM_DOC_VIEW: Outside plant view associated with a document drawing.  This allows 
you to retain the logical associations between CAD objects and the original DWGs they came 
from.  All seamless view capabilities remain available.  You must have a Current Drawing 
selected in this case. 

• ISP_FLOORPLAN: Inside plant floorplan view (you must have a Current Building selected in 
this case). 
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• ISP_SCHEMATIC: Inside plant connectivity schematic (you must have a Current Building 
selected in this case). 

• Current Building: Select the building for Inside Plant views 

• Current Drawing: Select the logical drawing for document-based OSP views. 

• Reconcile edits to spatialNET entities: If checked, spatialNET will synchronize data in the 
database with data in the DWG file. 

3. Click Continue.  The drawing open process is now complete, and spatialNET will interpret it depending 
on the choices selected above (either as a database-linked view of a specified type, or as a native 
drawing). 

Importing and updating CAD objects using CAD-scrape 
spatialNET provides many techniques for importing CAD graphics into the spatialNET database. All require 
that the active window in the AutoCAD session be a spatialNET view, and not a native drawing. In the latter 
case, spatialNET ignores the window to allow AutoCAD files not related to the spatialNET application to be 
worked with as normal. 

If the active window is a spatialNET view, running the AutoCAD Save function will automatically begin the 
Scrape process.  Once scraped into the database, the CAD objects will be rendered back into spatialNET 
views, subject to the scale and content filtering rules set up in the CAD Layer Filter. 

Any of the following techniques may be used to populate the active view window with the CAD objects to 
be scraped. 

• Open a DWG file as a spatialNET view (see Opening a CAD File on page 339) 

• Use any of the AutoCAD drawing commands to create new objects directly in the active view. 

• Use the AutoCAD INSERT command to insert a DWG file directly into the active view (be sure to 
EXPLODE the drawing or it will be scraped as a block reference). 

• Cut and paste objects from another drawing directly into the active view window. 

spatialNET performs the following actions during the CAD Scrape, depending on the origin and current 
status of the CAD object being processed:  

  Existing CAD-scrape Entity 
Rendered from the database 

Native CAD Entity being scraped 
into the database for the first time 

Create New Object No processing.  (This would create 
duplicates of entities already in the 
database.) 

Entities written into the database. 

Change Object  
  

Object updated in the database using 
spatialNET JMS job management (long 
transaction) control.  
  

N/A 

Delete Object Object deleted from the database 
using spatialNET JMS job management 
(long transaction) control.  

N/A 
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The CAD recognition processing progress bar displays the progress of the scrape procedure as the drawing 
is progressively scraped into spatialNET.  

 
The CAD-scrape process can be a lengthy process depending upon depends on the complexity of the 
drawing being imported. 
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Window Layout 

 

The network details in the display window are created directly from the spatial database. spatialNET does 
not require DWG files to produce or maintain map views. You use a combination of commands available 
from the menus, spatialNET toolbars, and drag-and-drop functionality to interact with spatialNET. 

Menus 
All commands relating to the usage of spatialNET are located on the spatialNET menus, illustrated below. 
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The Fiber, Copper, ISP, and RF menus are also shown below. 

             

Fiber menu                               Copper menu                            ISP menu                             RF menu 

Toolbars 
The spatialNET toolbars are shown below.  

Add ISP 
 

Construction 
 

Copper 
 

Delete 
 

Detail Drawings 
 

Fiber 
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General 
 

Landbase 
 

MDU Drawings 
 

Network 
 

Rack Elevation 
 

RF 
 

Strand 
 

Trace 
 

Trench 
 

View 
 

  

Command Line 
Use the AutoCAD command line at the bottom of the screen to view information about what is happening 
and what should be done next.  

 

If you are in the midst of an operation and unsure what to do next, check the command line to see if 
AutoCAD is prompting you to enter something. 

To force a command through in spatialNET, type ZZ in the command line.   

Templates and Layers 

Blocks 
spatialNET keeps a library of CAD graphics that are referenced in the Data Dictionary for each object type. 

1. Select Tools > Options from the menu. 
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2. Click the plus sign [+] next to the Support File Search Path folder. Each folder that contains blocks 
should be added here. 

3. Click Add and navigate to the folder. 

 
If there are missing symbol, the graphics will not appear on the map, and a circle with "missing symbol" will 
appear. 
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Templates 
Every object represented graphically is assigned to a layer in AutoCAD (this applies to both CAD-scraped 
and Modeled entities). The CAD layers typically define such properties as color, line type, etc. However, 
when spatialNET scrapes a CAD object into the database, it only saves the name of the layer on which the 
object is drawn, and not the properties associated with the layer. 

In spatialNET, the definitions of the layers and their properties are stored in a CAD template file which is 
loaded whenever spatialNET opens a new drawing window. 

Select a template as follows: 

1. Select spatialNET > View > Settings from the menu or click the View Settings button on the View 
toolbar, as shown below. 

 
The View Settings dialog box opens, allowing you to view types of drawings, change templates, and 
change what you see for a view.   

 

2. Click the Edit button on the View Templates option to display a list of template files. 
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3. Click the Browse  button to browse for template files.  

4. Check that the spatialfm_all.dwt template is selected (select it by navigating to the directory containing 
the file, highlighting it, and clicking the Open button in the Select Template dialog box).  

5. Click Done in the View Templates dialog box. 

The template files configured for each view type are saved against your user profile. If you log on as a 
different user, you may see a different template. If the template is absent, or the wrong template is used, all 
CAD objects most likely will be displayed in black and white. 

Layers 
There are multiple ways to turn layers on and off.  

To use the View Settings menu: 

1. Ensure only Show RF Network is selected. 

2. Click Refresh. Only RF Networks show. 

3. Select several of your own, and click Refresh. 

 

Layers and Specific Areas 
To change a specific area in a spatialNET view.   

1.  Select the Select Area check box in the View Settings dialog box. 
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2. Select all the check boxes in the layer selection area to show all types of entities in your map view. 

3. Click Refresh in the View Settings dialog box or from the View Toolbar. 

4. Click once on the spatialNET view. Holding down the left mouse button, drag the cursor to the left and 
up. A rectangle is created, selecting everything within the rectangle. 

Only the view in the rectangle is changed, showing all layers.   

  

Using the AutoCAD Layer toolbar 

 

After you have determined the layer an object is on, you can turn the layer on and off from the toolbar by 
clicking on the light bulb icon. 

Shortcuts 

Creating Shortcut Keys 

1. Select Tools > Customize >  Interface from the menu. 

The Customize User Interface Editor dialog box opens. 

2. In the Customize pane, click the plus sign (+) next to Keyboard Shortcuts to expand its node. 
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3. Click the plus sign (+) next to Shortcut Keys to expand its node. 

 

4. From the All Commands Only list, select SPATIALNET Commands. 

 

5. In the bottom pane, drag the command you want to create a shortcut for to the Shortcut Keys node in 
the pane above. 

 
The Properties pane opens, and the properties for the shortcut key are displayed. 

6. In the Access section, click Key(s), and then click the Browse  button to open the Shortcut Keys 
dialog box. 
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7. Enter the desired key combination for the shortcut key as per the limits outlined below* and click OK. 

* Key Assignment Rules 

Hold down the modifier key Ctrl, with a combination of Shift and Alt if desired, and press a letter, number, 
function, or virtual key such as F1 or Insert. Valid modifier and key combinations include the following: 

• Function (Fn) keys containing no modifiers 

• Number Pad (NUMPADn) keys containing no modifiers 

• Ctrl+[letter], Ctrl+[number], Ctrl+[function], Ctrl+[virtual key] 

• Ctrl+Alt+[letter], Ctrl+Alt+[number], Ctrl+Alt+[function], Ctrl+Alt+[virtual key] 

• Ctrl+Shift+[letter], Ctrl+Shift+[number], Ctrl+Shift+[function], Ctrl+Shift+[virtual key] 

• Ctrl+Shift+Alt+[letter], Ctrl+Shift+Alt+[number], Ctrl+Shift+Alt+[function], 
Ctrl+Shift+Alt+[virtual key] 

Supported Virtual Keys: Escape, Insert, Delete, Home, End, Page Up, Page Down, Left Arrow, Right 
Arrow, Up Arrow, and Down Arrow. 

Grips and Manipulators 
To differentiate spatialNET entities from ordinary CAD objects, spatialNET displays a special kind of grip 
called a manipulator when an entity is selected in the AutoCAD window. 

spatialNET manipulators allow you to move, rotate, and perform other operations on objects in a way that 
ensures that the integrity of the underlying data model is always maintained.  spatialNET manipulators look 
different from AutoCAD grips and there are several of them, each with a specific function as shown below: 

 

When you select an object in AutoCAD and one or more manipulators appear, rather than AutoCAD grips, 
you can be sure you have selected a spatialNET entity. 

Using AutoCAD Grips instead of spatialNET Manipulators 
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You can use the normal AutoCAD grips rather than manipulators to edit the geometry of spatialNET 
entities. This allows you to use AutoCAD drafting functions to edit the geometry of modeled entities; 
however, it also disables the ability to select modeled entities from the map and run spatialNET functions 
associated with them. Native Grips are useful when: 

• The geometry editing you need to perform is not supported by spatialNET manipulators (e.g., the 
AutoCAD Stretch command), or is more easily done using AutoCAD functions. 

• You wish to edit many objects at once (e.g., move all objects within an area 120 feet to the north). 

To use normal AutoCAD grips instead of spatialNET manipulators: 

1. Click the Current Selection  button on the General toolbar. This opens the spatialNET Current 
Selection dialog box. 

2. From the Selection Display field, select the Native Grips option. 

 
The differences between Native Grips and Manipulators modes are described below: 

  Native Grips Mode Manipulators Mode 

Grip Display Normal AutoCAD Grips. spatialNET Manipulators. 

Selection 
Behavior 

Additive (selecting one or more objects adds them to the 
current selection set). 

Depends on whether Single or Multiple 
selection mode is enabled. 

Drafting 
Operations 

Normal AutoCAD drafting operations available for all 
objects. 

Manipulators for modeled entities. 

Snap Modes All AutoCAD snap modes work All AutoCAD snap modes work except 
for ORTHO. 

Save Changes Modeled entities saved to database immediately. CAD-scraped entities only saved when 
the AutoCAD Save function is run. 

spatialNET 
Functions 

Most spatialNET functions are not available for any 
entities. It is not possible to select a modeled entity, display 
its details, edit its properties, etc. 

spatialNET functions spatialNET 
functions are available for modeled 
entities. 

When AutoCAD grips are on: 

• spatialNET manipulators no longer appear, and are replaced by AutoCAD grips. 

• All normal AutoCAD drafting functions will work. 

• All of AutoCAD snap modes with work. 
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• Changes made using the AutoCAD editor will be immediately saved to the database, even for 
spatialNET modeled entities, but will still require the use of the Save button for CAD scraped 
entities. 

• No spatialNET functions are available in native edit mode; e.g., it is not possible to select a modeled 
entity, display its details, or edit its properties. 

Note: If the spatialNET Manipulators option is selected, AutoCAD author modes will NOT work. 

Selecting Objects 
The currently selected entity (also sometimes referred to as the current entity, the current selection, or the 
selected entity) is the spatialNET entity you have selected using one of the methods described below. The 
selected entity then becomes the subject of any spatialNET commands that you may run (Display details, 
Edit, Delete, Splice, etc.) or may supply the container for adding a new piece of equipment. 

Selecting a Single Object 
If the selection mode set in the Current Selection dialog is set to Single, there can only be one currently 
selected spatialNET entity at any one time. If it is set to Multiple, many objects can be selected, but not all 
commands accept multiple selections. 

spatialNET includes several methods for available for selecting spatialNET entities. Two include: 

• Clicking a spatialNET entity in the AutoCAD window will select it. 

• Clicking the Select button in any dialog box will select the entity highlighted in that dialog box. 

When creating a new entity, there is usually an option to Auto-select it as soon as it has been created. 

Selecting Multiple Objects 
If the selection mode set in the Current Selection dialog is set to Single, there can only be one currently 
selected spatialNET entity at any one time. If it is set to Multiple, many objects can be selected, but not all 
commands accept multiple selections. 

To change from single to multiple select, click the Single Arrow   button on the General toolbar. 

 

The icon changes into a Two Arrow  button. You can click on multiple spatialNET objects and 
manipulate them as a group. 

 

Searching for Objects 

Introduction 
spatialNET provides a number of ways to query the database for specific classes of entities (like fiber, term 
panels, nodes, etc.). The results of a query can be used to generate map views or modify entities. 
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There are four basic query types available: 

• Listing Entities returns all instances of a given class of entity present within the database. 

• Finding Entities finds specific entities of a given class by setting simple, predefined conditions on 
the query. 

• Counting Entities returns the total number of entities of a given class within the selected 
boundary. 

• Building Queries runs queries with complex user-created conditions, including spatial qualifiers. 

If more advanced query and reporting functions are required, use a third-party reporting tool capable of 
connecting to the relational database. 

Finding Entities 
To return a list of entities within a certain class matching specified conditions: 

1. Run the menu command Fiber > Find > Find by Matching and select one of the entity types from the 
submenu. 

 
 

The Find By Matching panel appears. Each column has a query field above it that can be modified 
depending on your search terms. 

2. Changing the operator that runs on text entered in the query field can be done by clicking the white 
symbol button. The available options are: 

• x don’t care:any text in the query field will be ignored. 

• = equal: results returned will exactly match text in the query field. 

• % like: results returned will be similar to text in the query field. 

• s sounds like: results returned will be phonetically similar to text in the query field. 

• n null, nil, empty: only empty values will be returned. 

3. If the Auto-query box is selected, spatialNET automatically runs queries as text is entered into a query 
field. Otherwise, the Query button must be clicked in order to initiate a search. If there are too many 
results returned you can force spatialNET to display the results by clicking the Retrieve button. 

Double-clicking on an entity will display its Details Panel. Actions can be performed on selected 
entities with the buttons at the bottom of the Find By Matching panel.  



RELEASE 5.9  SPATIALNET USER MANUAL 

©SPATIALINFO PTY LIMITED, ALL RIGHTS RESERVED   

Listing Entities 
To list all entities of a particular class currently in the database: 

1. From the Fiber menu, select List, then select one of the entity types from the submenu. 

 
A list panel appears showing the results of the query. 

2. Use the buttons on the right of the list panel to perform actions on the displayed entities. 

3. Save a copy of the generated list by clicking the Save CSV… button. 

Building Queries 
If simple queries are not adequate to find the information you are looking for, it is possible to construct 
more complicated queries using the spatialNET Locator tool. 

 
To run the Locator: 

1. Select any of the following menu commands (any of them will start the Locator): 

Fiber > Count > Query Builder… 

Copper > Count > Query Builder… 

  spatialNET > Count > Query Builder… 

The Locator panel appears. 

2. Delete any entries currently in the Query Conditions by selecting them and clicking the Delete 
button. 
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3. To begin creating a new query, select an Entity Class on which to base the query by clicking on the 
control marked Entity Class to add to query in Figure 301, and picking a class from the list that 
appears. 

4. To add query conditions, select an attribute, comparison operator, and value in the bottom three fields 
and click the Add button. 

Notes: 

• If the like comparison is chosen, then the % character will be treated as a wildcard which stands for 
an unlimited string of characters. For example, H%SE will match HSE, HOSE and HOUSE. 

• If the enclosed by comparison operator is chosen, the qualified attribute must be a spatial 
attribute and the value window should be blank. At the time the query is executed, a polygonal 
entity must be selected and will provide the boundary condition for the query. 

• Step 4 above, which describes adding query conditions, can be repeated as many times as required 
to establish the qualifying conditions of the query. 

• To count the number of rows returned by the query, click the Count button. 

• To list the rows returned by the query, click the Query button. 

Using the Count Feature 
The Count feature allows you to count entities of a certain type within a selected boundary. 

The Count option is available in both the spatialNET menu and in the individual object menus (Fiber, 
Copper, RF, and ISP). 

1. Select a boundary on the map. 

2. Select one of the Count options. 

There are no parameters to select. This feature only provides a count of the object type. 

Controlling Object Visibility 

View Settings Menu 
Select spatialNET > View > Settings from the menu. 
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Tasks you can perform from this dialog box include: 

• Setting the template files for the map. 

• Turning layers of spatialNET entities on and off. 

• Coloring objects by entity status 

• Color by cable usage 

• Set the Highlight Color 

Refreshing the Screen 
There are multiple ways to refresh the screen. 

Method 1 

Click the Refresh  button on the View toolbar. 

 

Method 2 
In the View Settings dialog box: Click Refresh and the window regenerates. 
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Method 3 
The most powerful method of refreshing, also found in the View Settings dialog box. 

1. Select the Select Area check box. 

2. Select all the check boxes in the layer selection area to show all types of entities in your map view. 

3. Click Refresh in the View Settings dialog box or from the View Toolbar. 

4. Click once on the spatialNET view, press and hold the left mouse button, and drag the cursor to the left 
and up. This action creates a rectangle, selecting everything within the rectangle. 

Filtering CAD Layers 
spatialNET allows you to control the scale at which different types of CAD objects are made visible when a 
view is rendered from the database. By hiding detail not required in wide-scale views, view creation times 
can be dramatically reduced. 

To make all objects visible at all scales: 

1. Select spatialNET > View > CAD Layer Filter from the menu. 

The Layer Controls dialog box opens. 
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2. Select all rows in the layer list, as follows: select the first row, press and hold the Shift key, scroll to the 
last row, and select it. 

3. Click Edit Zoom in the dialog box. 

  

4. Set the Zoom Level to Zoom Level 5 (all the way to the right). 

5. Click Apply and then click Refresh. 

Setting Color By Entity Status 
Selecting the Color by Entity Status check box allows you to display cables in color-coded groups 
according to a selected theme. You can show posted cables in one color and published cabled in another 
color in the same job as well as new additions within the same job. 
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Setting Zoom Level Extents 
The Zoom Levels are set from 1 to 5. When an object type is set to appear at zoom level 1, you will have to be 
zoomed in very close to make that object type appear. When an object is set to appear at zoom level 5, it 
will show up on the birds-eye view of the map. 

 

Note: If you set all objects to appear at zoom level 5, all objects will appear in any map, but your map will 
load very slowly. If there are objects on the map you don’t need to see, either turn those layers off or set the 
zoom level to a low number. 

To specify the screen extent assigned to each zoom level, do the following: 

1. Click the Edit button next to the Zoom Levels option to open the Zoom Levels dialog box.   
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2. Using the arrow bars, change some of the zoom extents for your layers that are turned on in your Map 
View. 

3. Click Done. 

4. Click Refresh. 

Toolbars 

Aerial Support Structure (Strand) Toolbar 

 

Button Name Function 

 

Set Guy Draws a guy support. 

 

Set Strand Draws strand. 

 

Telephone Pole Inserts a telephone pole. 

 

Power Pole Inserts a power pole. 

 

Joint Pole Inserts a joint pole. 

 

Power Transformer 
Pole 

Inserts a Power 
Transformer pole. 

 

Joint Transformer Pole Inserts a Joint Transformer 
pole. 

 

CATV Pole Inserts a CATV pole. 

 

Steel Pole Inserts a Steel Pole. 

 

Anchor Inserts an Anchor. 

 

Draw Strand Older functionality of 
adding strand. 

 

Add Strand Adds strand to the design 
drawing. 
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Construction Toolbar 

 

 

Set Construction Status 

 

Clear Construction Status 

 

Toggle New Status 

 

Highlight No-Length Strand 

 

Auto Attach Equipment 

 

Attach Selected Equipment to Selected Support 
Network 

 

Detach Selected Equipment 

 

Highlight Unattached Cables 

 

Highlight Unattached Equipment 

 

Strand Report 

 

Splice Proximity 

Copper Toolbar 

 

 

Add Copper Cable 

 

Add Copper Splice Case 

 

Add Terminal Block 

 

Add Copper Cross Connect 

 

Add Site 
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Delete Toolbar 

 

 

Delete Selected Entity 

 

Remove Selected Entity 

 

Abandon Selected Entity 

 

Reinstate Selected Entity 

Detail Drawings Toolbar 

 

 

Create Detail Drawing 

 

Follow Feather 

 

Replace Feather with a Card 

 

Place Selected Card in Detail Drawing 

 

Place Deleted Card in Detail Drawing 

 

Display Detail Drawing 
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General Toolbar 
The spatialNET user interface contains a toolbar that provides shortcuts to certain key spatialNET 
commands, and is described in detail below. 

 

Button  Description 

 

Activates the Current Selection dialog box that gives details about which entity is currently selected 
and what the current view type is. A dialog box similar to the following opens: 

 
Fields and controls on this dialog box include: 

Editing mode Select mode to edit 

Selection 
Display 

Select either spatialNET manipulators or AutoCAD grips 

Selection Mode 
– Single 

One entity can be selected 

Selection Mode 
– Multiple 

More than one entity can be selected 

Current Site The current ISP Site. This will is used to locate certain ISP functions within a specified 
site. 

Current Theme Select a theme set up by administrators. 

Active Field Job The current field job if one is selected. 

 

Activates the Details dialog box of the currently selected spatialNET entity. A dialog box similar to the 
following opens: 
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Opens the object browser window displaying a dialog box similar to the following: 

 

 

Opens the Edit dialog box for the selected spatialNET entity, allowing its properties to be modified. 

 

Edits selected annotation. 

 

Deletes the selected spatialNET entity. 

 

Annotates the selected entity. 

 

Partially Annotate Selected Entity button. This creates annotation linking an object to a range of 
pairs/fibers in a cable. 

 

Auto-renumber street addresses. 

 

Clears the current spatialNET selection (does not affect the current AutoCAD selection; see Currently 
selected entity, below). 

 

Changes the current selection mode between Single and Multiple selections. Also indicates current 

selection mode (double-arrow  appears in multi-selection mode). 
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Highlights selected entity. 

 

Clears the current highlight. 

 

Activates the spatialNET Data Dictionary tool, which is only available to users with administrator 
privileges. This is used for debugging purposes only, and the spatialNET administrator may be asked to 
run the Data Dictionary tool by hotline staff when reporting a problem to extract more information 
about a particular problem. 

 

ISP Toolbar 

 

 

Add Site 

 

Add Rack 

 

Add Chassis 

 

Add Card 

 

Add Standalone Equipment 

 

Add Cable 

MDU Drawings Toolbar 

 

 

Add MDU Drawing 

 

Add MDU Drawing 
DMark 

 

Display MDU Drawing 
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Network Toolbar 

 

 

Physical Splice 

 

Logical Joint 

 

Splice View 

 

Manhole Butterfly Diagram 

 

Add Duct X-Section to Manhole Butterfly 
Diagram 

 

Fibers/Ports List 

 

Fiber/Pair Readings 

 

A to Z List 

 

Tail Off Cable 

 

Drop Tool 

 

Rack Elevation Toolbar 

 

 

Rack Elevation View 

 

Rack Elevation Control 
Panel 
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Underground Support Structure (Trench) Toolbar 

 

Button Name Function 

 

Set Joint Trench Creates a Joint Trench 

 

Clear Joint Trench Deletes the Joint trench 

 

B Vault Add a B Vault 

 

D Vault Add a D Vault 

 

RT Vault Add an RT Vault 

 

Drop Pedestal Add a Drop Pedestal 

 

UG Structure with 
Terminal Block Add underground equipment 

 

Draw Trench Older version of adding a trench. 

 

Add Trench Adds a trench to the view 

 

Add Ducts Add ducts to a trench 

 

Add Sub-Ducts Add sub-ducts inside existing ducts 

 

Add a duct cross-section Changes the view of the duct to a 
cross  section. 
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View Toolbar 

 

 

View Save 

 

View Save As 

 

View Manager 

 

View Settings 

 

View Refresh 

 

Toggle Balloon Tooltips 
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Workflow Management 

Job Management 

What is a Job? 
spatialNET provides access to the spatial database through the Job Management System (JMS). Any changes 
made to the network model are grouped under a unit of work known as a job. Database changes made in 
any job are written to a change log belonging to that job, and do not update the master records in the 
database until a process called Post is run. Therefore, whenever you make a change to the database within a 
job, the system actually creates a new "job private" version in the object you are editing. The job-private 
version does not replace the master version in the database until the post function is run. Until this occurs, 
changes made in the job are visible only within that job, and cannot be seen in other jobs, until the Publish 
process is run. This capability is often referred to as Long Transaction Management. 

Jobs must be published or posted by the spatialNET administrator before work done in a job is visible to 
other users. Post will complete the job in the JMS workflow, all edits will become visible to other users, and 
further edits will not be accepted as part of that job. Publishing the job does not overwrite the master 
records, but instead lets the most recent changes be viewed by other users. Only the original user can 
modify the entities touched in a published job. 

The steps in the job workflow are as follows: 

1. Create a job. The job appears in the Job Selection dialog box the next time you start spatialNET. 

2. Select the job and click Open to work on the job. The status of the job changes to Open. 

3. Once the changes are completed and confirmed, the spatialNET administrator or supervisor posts the 
job to make it part of the as-built or master record set. spatialNET replaces the current master records 
with the versions corresponding to the changes made in the job being posted. After a job is posted, it is 
closed and no further work can be performed on it. 

Job States 
There are three job status values: 

• Private: The changes are visible only to the user who made them. This is used for initial design phases 
of a project. 
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• Published: The changes are visible to all users in the database (see Publishing a Job). 

• Posted: The changes are written permanently to the database and are visible to all (see Posting a Job). 

To view the details of the job you are currently in, select spatialNET > Administration from the menu and 
select Details of Current Job. 

 

The top line in this window provides the status of the current job. In this example, the job is Open. If the 
job has been published or is queued for publishing or posting, the status would be listed here, also. 

Creating a Job 
When you first log in to spatialNET, the Job Selection window opens and you must create a job. 

1. On the Job Selection window, click New. 

 

2. Complete the following fields: 

• Number: Does not have to be a number, but usually refers to a Project Number or Work Order. 

• Description: Enter a description of the work to be done in this job. 

• Job Type: Select from the list. Plant Update tracks the history of the job and is recommended for 
network changes. If you wish to create your own Job Types, see What Are the Different Job Types?. 

• RF Design Profile: You must select a Design Profile to be able to draft RF network entities. If you 
do not have an RF Design Profile, see your system administrator. 
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• Oracle Spatial Reference ID: the reference grid for your map area on the globe. It is usually set as 
a default for the database, but you may have to select it if your map covers more than one zone. See 
your system administrator for help selecting the correct reference ID. 

 

3. Click Add. 

Pessimistic Locking 
When different jobs contend for the same resources, or make changes to the same records, conflicts can 
occur, which can prevent all the jobs involved from successfully being published or posted. To prevent this 
from happening, a session can set Pessimistic Locking. 

Pessimistic locking ensures that only a single job can have a change pending on any given database entity. If 
another job tries to change an entity that already has changes pending in another job, a lock prevents those 
changes from being made. In this situation, an error message is displayed indicating that the entity is 
locked, and indicates the user and job owning the lock. 

 

Pessimistic Locking is automatically enabled  for all users on all jobs. It can be switched to Optimistic 
Locking per job if the user has sufficient rights. 
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Optimistic Locking 
Optimistic locking can be set on a job-by-job basis. It allows an entity to be modified in more than one job. 
This is helpful when trying out multiple new designs in an area. The conflicts will be allowed, but you still 
cannot publish or post your work while the conflict exists. All other jobs that have the conflict have to 
restore the changed entities back to their original state or be cancelled. 

To switch from pessimistic to optimistic locking, you must belong to a security group that has this right. 

Verifying a Job 
Before publishing, posting, or cancelling a job, it is important to check the job for potential conflicts with 
any other existing jobs within spatialNET. You can use the Verify function within the spatialNET Job 
Administration Tool to assist with this. 

1. Launch Job Administrator and log in. 

2. Click Find Job. 

 
3. Select the job and click Verify. 
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4. Select Publish, Post, or Cancel, as appropriate. 

Note: When you verify a Post, Job Administrator will first verity the Publish status and then the Post. 

spatialNET opens a message box telling you whether the operation selected can complete successfully. 

5. Click OK. 

 
You can now proceed with publishing, posting, or cancelling. 

Publishing a Job 
Important Note: Before publishing, posting, or cancelling a job, it is important to check the job for 
potential conflicts with any other existing jobs within spatialNET. You can use the Verify function within 
the spatialNET Job Administration Tool to assist with this. 

As changes are made within a job, they are held in a private change log belonging to the job, and are not 
visible within other jobs. It is possible to make the current versions in the job-private change log visible to 
all other users of the system by running a function called Publish. Unlike Post (see Posting a Job), this 
leaves the job active and allows further changes to be made to the job, or the job to be cancelled. 

Publishing is a useful tool in the design process. Once a design is completed and is ready to be reviewed or 
sent to construction, the job can be published or queued for publishing after business hours. This task is 
usually managed by an administrator or manager. Publishing data does not alter the original database 
record. It only changes the visibility status as viewable for others. 

Note: The change versions that are not current at the time publish is run will be made globally visible. Any 
changes made after publish is run remain private to the job until publish is run again or the job is posted. 
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Once changes have been posted, you can use the Color By Entity Status  feature to have those changes 
appear in a highlighted color so as not to be confused with posted data. 

There are two methods for publishing a job. You must have sufficient rights to complete this task. 

Method 1: Publishing with spatialNET 

1. Open the Current Selection dialog box. 

 
2. Select Admin > Publish Job or Admin > Queue for Publish from the menu. 

Note: If you do not see these options, see your spatialNET administrator. 

Method 2: Publishing with Job Administrator 

1. Ensure the job to be published is closed in spatialNET. 

2. Open Job Administrator and log in. 

3. Click Find Job. 

 
The Find Job window opens. 

4. Search for the job using the search parameters at the top of the window. Refer to Finding a Job 
Belonging to Another User for instructions. 

5. Click once to select the job and click Publish. 
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6. Select either Publish or Queue for Publish. 

• If you chose Publish, the task completes immediately. All other users must close and reopen 
spatialNET to see the new changes. 

• If you chose Queue for Publish, the job goes into the Batch Queue. The job will not publish until 
the next scheduled run of the Batch Queue. See also Setting Up the Batch Queue. 

Note: If a job is queued for publishing, you can use the Undo Last function to remove it from the 
queued status. 

Posting a Job 
Important Note: Before publishing, posting, or cancelling a job, it is important to check the job for 
potential conflicts with any other existing jobs within spatialNET. You can use the Verify function within 
the spatialNET Job Administration Tool to assist with this. 

As changes are made within a job, they do not update the master records in the database, but are written to 
a change log associated with the job. This allows the "asbuilt" network to be managed in the system in 
parallel to designs or plans for future network without the two interfering with one another. When a job is 
completed and the network has been constructed, the job-private changes must be written to the master 
records in the database, which also makes them publicly visible throughout the system. This is achieved by 
running the Post function. 

Note: Once a job is posted, the change log is deleted and the job is closed for further changes. It should not 
be opened again for editing. 

There are two methods for posting a job: 

• Batch post 

• Immediate post 

Important Note: Posting can be a system-intensive process and it is recommended to post jobs after hours. 

Jobs can be posted from spatialNET or from the Job Administrator tool. If you are using Job Administrator, 
be sure to close the job to be posted in spatialNET before proceeding. If the job is still open in spatialNET 
when posting, the job status will not update properly and a user can still make changes to the posted job. 
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Method 1: Posting within spatialNET 

1. Open the Current Selection dialog box. 

 
2. Select either Post Job or Queue for Post. If you do not have these options, talk to your spatialNET 

administrator. 

• If you chose Post Job, the task will complete immediately. spatialNET will close once the job has 
posted and a new job must be created to continue working. All other users should close and reopen 
spatialNET to see the new changes. 

• If you chose Queue for Post, the job goes into the Batch Queue. The job will not post until the next 
scheduled run of the Batch Queue. See also Setting Up the Batch Queue. 

Method 2: Posting Using Job Administrator 

1. Verify the job to be posted is closed in spatialNET. 
2. Open Job Administrator and log in. 
3. Click Find Job. 

 
The Find Job window opens. 

4. Search for the job using the search parameters at the top of the window. Refer to Finding a Job 
Belonging to Another User for instructions. 

5. Click once to select the job and click Post. 
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6. Select either Post or Queue for Post. 

• If you chose Post, the task completes immediately. All other users must close and reopen 
spatialNET to see the new changes. 

• If you chose Queue for Post, the job goes to the Batch Queue. The job will not publish until the 
next scheduled run of the Batch Queue. See also Setting Up the Batch Queue. 

Note: If a job is queued for posting, you can use the Undo Last function to remove it from the queued 
status. 

Cancelling a Job 
Important Note: Before publishing, posting, or cancelling a job, it is important to check the job for 
potential conflicts with any other existing jobs within spatialNET. You can use the Verify function within 
the spatialNET Job Administration Tool to assist with this. 

Occasionally the Undo function within spatialNET is not sufficient to clean up a job. If a project has been 
discarded, you may need to cancel a job to release the lock on all the objects touched within the job. 

There are two methods for cancelling a job. 

Method 1: Cancel within spatialNET 

1. Open the Current Selection dialog box. 

2. Select Admin > Cancel Job from the menu. 
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The job is cancelled immediately and spatialNET will close. You must reopen spatialNET and begin a 
new job. Notice also that there is no Queue for Cancel option from spatialNET. You must use Job 
Administrator to queue to job to cancel. 

Method 2: Cancel from Job Administrator 

1. Ensure the job to be cancelled is closed in spatialNET. 

2. Open Job Administrator and log in. 

3. Click Find Job. 

 
The Find Job window opens. 

4. Search for the job using the search parameters at the top of the window. Refer to Finding a Job 
Belonging to Another User for instructions. 

5. Click once to select the job and click Cancel. 
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6. Select either Cancel or Queue for Cancel. 

• If you chose Cancel, the task completes immediately. All other users must close and reopen 
spatialNET to see the new changes. 

• If you chose Queue for Cancel, the job goes to the Batch Queue. The job will not publish until the 
next scheduled run of the Batch Queue. See also Setting Up the Batch Queue. 

Note: If a job is queued for cancelling, use the Undo Last function to remove it from the queued status. 

Undoing a Job Change 
The Undo command reverses spatialNET changes that have been made in the current job, including those 
made in other sessions. However, it is important to remember that the command operates only in the 
context of the current job. As such, it will not reverse the changes made in any other job. 

There are two different types of undo: AutoCAD and spatialNET Undo. You should be familiar with the 
AutoCAD undo if you are already a user of AutoCAD. This functionality will not change. Most changes you 
will make to CAD objects can be rolled back using the AutoCAD Undo function. 

To run spatialNET Undo, select spatialNET > spatialNET Undo from the menu. 
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Note: The text following Undo on the menu refers to the current action. 

The JMS Progress dialog box opens while the change is being reversed. The undo operation can be aborted 
by clicking Cancel while the dialog box is open. 

WARNING: spatialNET Undo may reverse a change that may not have been the last change you made 
because it was an AutoCAD change. Ensure your intent matches the command you selected. 

As part of the Job Management System (JMS), the spatialNET Undo command is provided as a means of 
restoring the database to the state prior to making the most recent change in the current job. When this 
function is run, all changes associated with the last action you performed will be rolled back. 

Notes: 

• The spatialNET Undo operation should not be confused with the AutoCAD Undo command. AutoCAD 
Undo only applies to changes to CAD entities made since the last Save in the current session. spatialNET 
Undo rolls back the database to its state prior to the most recent spatialNET operation, EVEN IF THIS 
OCCURRED IN PREVIOUS SESSIONS. 

• The spatialNET Undo operation always ensures that all changes associated with the operation being 
rolled back are consistently removed. Even if complex operations are being undone, (e.g., splicing ranges 
with upstream and downstream ripples), the transaction manager always updates all affected records in 
a single operation, or none of them if the Undo operation fails before it can be completed in its entirety. 
For example, if the session terminates or loses database connectivity before the Undo is completed, the 
entire Undo will be cancelled and no records will be affected. 

• Any changes made using standard AutoCAD editing tools cannot be undone using the spatialNET Undo 
command. Running spatialNET Undo after saving CAD-scrape changes to the database will roll-back all 
CAD changes included in the last Save. Conversely, any changes made using spatialNET commands 
cannot be undone using the AutoCAD Undo function. 

• On some occasions you may need to use the Undo function multiple times to back out one change. For 
instance, if you place a fiber with no start or end points, spatialNET will place slice cases on either end of 
the cable. This consists of three separate job transactions which will have to be undone separately. 

WARNING: There is no spatialNET Redo operation. If you undo a spatialNET action, the system will not 
remember it.  

Job Types 
Job Types can be used to track the history of a job and all the entities it touches. When you first create a job 
upon logging into spatialNET, you can choose from multiple job types.  

The three default job types that come with an installation of spatialNET include:  

• Plant Update  

• Records Correction 

• Untracked Plant Update 

The Plant Update job type has the Track History option set to Yes, so all entities touched in the job will be 
recorded and can be reviewed later. 
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The Records Correction and Untracked Plant Update job types do not have a history associated to 
them. You can also set a job type to be the default when you are creating a new job. It is a good practice to 
set any job that modifies the network set to Track History. 

 
Select spatialNET > Dictionaries > Other Definitions > Job Definitions to open the Job Definitions 
window. 

 
Some groups prefer to create more specific job types, such as RF Plant update, Fiber Update, Fiber Splicing, 
and others. 

Creating a New Job Type 
To create a new job type: 

1. On the Job Definitions window, click Add (see What Are the Different Job Types?). 

 

2. Complete the following fields: 
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• Available: If the type is available, it means the item can be selected when creating new instances of 

this type. If it is not available, new instances of this type CANNOT be created. 

• Job Type: Enter the type of job being created,e.g., Records Correction or Plant Update. 

• Description: Enter detailed description of the job type being created. 

• Track History: Select Yes or No from the list. 

• Layer for Private Boundary: This is the CAD layer on which the job boundary will be displayed if 
job is in the private state. 

• Layer for Published Boundary: This is the CAD layer on which the job boundary will be displayed 
if job is in the published state. 

• Layer for Posted Boundary: This is the CAD layer on which the job boundary will be displayed if 
job is in the posted state. 

3. When finished, click Add. 

Editing a Job Type 
To edit an existing job type: 

1. On the Job Definitions window, select a job type you wish to edit and click Edit (see What Are the 
Different Job Types?). 

 

2. Complete the following fields: 
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• Available: If the type is available, it means the item can be selected when creating new instances of 

this type. If it is not available, new instances of this type CANNOT be created. 

• Job Type: Enter the type of job being created, e.g., Records Correction or Plant Update. 

• Description: Enter detailed description of the job type being created. 

• Track History: Select Yes or No from the list. 

• Layer for Private Boundary: This is the CAD layer on which the job boundary will be displayed if 
job is in the private state. 

• Layer for Published Boundary: This is the CAD layer on which the job boundary will be displayed 
if job is in the published state. 

• Layer for Posted Boundary: This is the CAD layer on which the job boundary will be displayed if 
job is in the posted state. 

3. When finished, click Apply. 

Deleting a Job Type 
To delete an existing job type, on the Job Definitions window, select the job type you wish to delete and 
click Delete (see What Are the Different Job Types?). 

 

Note: If a job type is in use, it cannot be deleted. Instead, modify the Definition Status to Obsolete rather 
than Available (see Editing a Job Type). 
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Job Administration 

Using Job Administrator 
The spatialNET JMS Administration Tool (Job Administrator) allows you to perform the following tasks: 

• Manage users 

• Manage security groups 

• Find jobs (regardless of owner) 

• Create, publish, post, and cancel jobs 

• Manage field jobs 

• Set up the batch queue 

• Delete removed entities 

Job Administrator does not allow access to the map or the dictionaries for map entities. 

Usually, access to Job Administrator is limited to users with admin rights to spatialNET. While many of the 
functions available in Job Administrator are also available in spatialNET, Job Administrator can be very 
handy for a supervisor to manage the workload and queue. 

Logging Into Job Administrator 

To open Job Administrator: 

1. Double-click the icon on your desktop. 

 

2. On the Login window: 

a. Enter your administrative username and password. 

b. Select the database you wish to connect to. 

c. Click Logon. 
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 Creating a Job for Another User 

1. Open Job Administrator and log in. 

2. Click Find Job. 

 
The Find Job window opens. 

3. Click New. 

 
The Job Creation window opens. The job first must be created and assigned to your user name, but can 
then be reassigned to another user. 

4. Complete the following fields: 

• Number: This does not have to be a number, but usually refers to a Project Number or Work Order. 

• Description: Enter a description of the work to be done in this job. 

• Job Type: Select from the list. Plant Update tracks the history of the job and is recommended for 
network changes. If you wish to create your own Job Types, see What Are the Different Job Types?. 

• RF Design Profile: You must select a Design Profile to be able to draft RF network entities. If you 
do not have an RF Design Profile, see your system administrator. 

• Oracle Spatial Reference ID: This is the reference grid for your map area on the globe. This is 
usually set as a default for the database, but you may have to choose if your map covers more than 
one zone. See your system administrator for help choosing this. 
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5. Click Add. 

Once the job is created, use the Find Job function and change the job owner. See Finding a Job 
Belonging to Another User and Changing the Job Owner. 

Finding a Job Belonging to Another User 

1. Open Job Administrator and log in. 

2. Click Find Job. 

 
The Find Job window opens. 

3. Narrow down the results using the search parameters at the top of the window. Certain fields are 
especially useful to search with: 

• Job Status: Use this field  to search for jobs in Design, Published, Posted, Cancelled or other status 
values. Ensure the button to the left of this search field is set to =. 

• Job Owner: Use this field to find a job belonging to a specific spatialNET user. Combine this with 
Job Status to search for all open jobs belonging to a specific person. 

• Number: Use this field when jobs are named by project number or work order. Instead of the = 
symbol, use the % symbol to narrow down your search even if the full number is not known. 
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4. Once you locate a specific job, you can Verify, Publish, Post, Cancel, or change the owner of a job. 

Changing the Job Details 
Once a job is created, the details of the job can still be edited. For instance, you may wish to change the Job 
Number or owner of the job. You can also change the RF Design Profile assigned to the job. 

1. From spatialNET, select spatialNET > Administration > Details of Current Job. 

 

2. Click Edit to edit details of the job. The Job Modification window opens. 
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3. Change Job Number, Description, Job Type, or RF Design Profile, as needed. 

4. Click Apply. The information in the Job Details window changes to reflect the modification applied. 

5. Note: The SRID cannot be modified while the job is open. 

Changing the Job Owner 
This task can be completed in Job Administrator or in spatialNET. 

Method 1: Change Job Owner in spatialNET 

Option 1: Change the job owner for a job open in spatialNET (you must have sufficient rights) 

1. Select spatialNET > Administration > Details of Current Job. The Job Details window opens. 

2. The Job Details window shows the Owning User. Click Edit to change the job owner. 

 
The Job Modification window opens. 

3. Select the new Job Owner from the list. You can choose from all active spatialNET accounts. 
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4. Click Apply and then Close. 

Option 2: Change Ownership of a Job Owned by Another User 

If an employee is out of the office but work still must continue on that job, you can reassign the job to 
another user. 

1. Select spatialNET > Administration > List Users. 

2. Click once to select the user who currently owns the job and click Details. 

 
The User Details window opens. 

3. In the Jobs section, click once to select the job you wish to modify. 

 

4. Click Edit. The Job Modification window opens. 

5. Select the new Job Owner from the list. 
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The new owner will see the job in the Job Selection list the next time they open spatialNET. 

Method 2: Change Job Owner Using Job Administrator 

1. Ensure the job is not currently in use in spatialNET. 

2. Open Job Administrator and log in. 

3. Click Find Job. 

 
The Find Job window opens. 

4. Search for the job using the search parameters at the top of the window. Refer to Finding a Job 
Belonging to Another User for instructions. 

5. Click once to select the job and click Edit. 

 

6. Select the Job Owner from the list. 
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7. Click Apply and then Close. 

The new owner will see the job in the Job Selection list the next time they open spatialNET. 

  

Changing the RF Design Profile 
There are two methods for modifying the RF Design Profile. You can use this method even if you have not 
yet assigned an RF Design Profile to a job. 

Method 1: User Details 

1. Open spatialNET and the job you wish to modify. 

2. Select spatialNET > Administration > Details of Current Job from the menu. 

3. On the Job Details window, click Edit. 

 

4. Select the RF Design Profile from the list. 

 

5. Click Apply and then Close. 
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Method 2: Change Profile 

1. Open spatialNET and the job you wish to modify. 

2. Select spatialNET > Administration > Change Profile of Current Job. 

3. Select a new RF Design Profile from the list. 

 

4. Click Apply and then Close. 

Setting Up the Batch Queue 
Pick a computer that will be dedicated to running the Batch Queue. It must be a full installation of 
spatialNET and it is recommended that you have the JMS Administration Tool and the Batch Queue icons 
on your desktop. It is also recommended that you create a queue that is only used for running the Batch 
Queue and will not have jobs associated to it. 

Set up the Batch Queue as follows: 

1. Open Job Administrator and log in. 

2. Click Batch Queue. 

 
The All Batch Queues window opens. 

3. Click New to create a new queue. 
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4. Complete the following fields: 

 
• Description: Enter a short name. 

• Start Time: Enter a time based in minutes. For example, 8:00pm is 20 hours after midnight. 
Multiply 20 times 60 minutes to get 1200 minutes. 

• End Time: Enter a time based in minutes. For example, 6:30am is 6.5 hours after midnight. Multiply 
6.5 times 60 minutes to get 390 minutes. 

5. Click Add and then Close. 

With the start and end times established, you must configure the Batch Queue to run on the 
designated computer. 

6. Right-click the icon for the Batch Queue on your desktop and select Properties. 

 

7. Copy the entire contents of the Target field and place it into Notepad to edit it. 
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The text you will edit is as follows: 

 

8. The first portion in double-quotes is the path to the installation of spatialNET on this PC. Ensure this 
path is correct and edit as necessary. 

9. The second portion to edit is the INI file, which determines which database to run the Batch Queue on. 
Change this file name to the *.ini file for the database in the dbms folder. 

10. The third portion to edit is the text batch$queue Batch. Change the final word to the name of the 
Batch Queue you created in the previous steps above. In our example, the Batch Queue was named 
simply "Batch", so it refers to the "Batch" Batch Queue. 

11. Once you have edited the three portions of the text, copy this text and paste it back into the Target 
field of the Batch Queue properties window (see step 6). 

12. Click Apply and then OK. 

13. You can now launch the Batch Queue application – double-click the icon (see step 5). 

The Batch Queue Running dialog box opens. 
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This dialog box will stay open at all times on the desktop, even when the queue is not running. You can 
see how many jobs are in the queue in the Entries Currently in Queue field. 

Changing the Start and End Time of a Batch Queue 

1. Open Job Administrator and log in. 

2. Click Batch Queue. 

 
 

The All Batch Queues window opens. 

3. Click once to select the batch queue in the list and click Control. 

 

4. Change the Start and/or End Time values as follows: 

• Start Time: Enter a time based in minutes. For example, 8:00pm is 20 hours after midnight. 
Multiply 20 times 60 minutes to get 1200 minutes. 

• End Time: Enter a time based in minutes. For example, 6:30am is 6.5 hours after midnight. Multiply 
6.5 times 60 minutes to get 390 minutes. 

5. Click Apply and then Close. 
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Field Jobs and Redlines 

Creating a Field Job 
Field jobs help manage redlining and markups in spatialNET and spatialWEB. Markups can be made and 
reviewed in both applications, which allows engineers and technicians to share information about network 
maps. 

To create a field job: 

From the spatialNET menu, choose > Field Jobs > Add Field Job. The Field Job Creation dialog box opens, 
and you can fill in the details. 
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Reviewing a Field Job 
After creating a field job in spatialNET, the field job must be opened to add markups such as redlines and 
circuit tags. Field jobs that are submitted from spatialWEB also need to be opened for edits and review. 

Note: When a field job is modified, the change appears immediately, and cannot be undone using the 
spatialNET menu undo option. 

To open a field job after it has been created in spatialNET or spatialWEB:  

1. From the spatialNET menu, chooe Field Jobs > Find Field Jobs. The Find Field Job dialog box opens. 

The columns are populated based on the attributes added in the dictionary. 

2. Double-click on a job to see its details. 

 
To view a created Field Job in the Map View: 

1. In the Find Fields dialog box, select Display. 

2. Select Map View. The markups appear in the spatialNET view. 

Assigning and Opening Field Jobs 
To assign a field job from the Find Field Job screen:  

1. Click the Edit button,  

2. Click Change State, then choose Assign. 

The following lists the states for field jobs: 

Name Description 
Assign Allows technicians to identify filed jobs assigned to them. The assign state is optional;newly created 

field jobs can move directly to the In Progress state by selecting the Open button. 

Open Makes the field job current 

Submit Notes all work is completed and is ready for review 

Review Moves the field job into a review state 
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Name Description 
Accept Reviewer has accepted the suggested changes 

Reject Allows technicians to view field jobs re-assigned to them for changes 

Complete Closes the field job. All markups have been reviewed and accepted 

Cancel Cancels the field job 

To open a field job from the Find Field Job screen: 

1.  Click the Edit button.  

2. Choose Change State, then choose Open. The Open Field screen opens. 

Assigning a User to a Field Job 
Select the Field job in the Find Field Job panel. 

1. Select Edit > Edit. 

2. Select the user from the drop-down menu for spatialNET (or enter the user for spatialWEB), then click 
Apply. 

 

Editing Field Job Status 
To make edits a field job type name, or add additional comments: 

1. Select the field job in the Find Field Job panel 
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2. Select Edit > Edit. The Field Job Modification dialog box opens. Make the appropriate changes and click 
Apply. 

 

Creating Redlines 
The following are instructions for redlines in map views. Go to spatialNET > View > Settings > Show 
Redlines to ensure redlines display in the map view. 

To create redlines in a field job in spatialNET: 

1. Select the field job in the Find Field Job panel. 

2. Select Edit->Activate. The Field Job status is now In-Progress and redlines and markups can be added. 

3. Go to spatialNET->Add->Redline. Select the redline style. 

A dialog box opens  stating the field Job and the option to select the redline style type from the drop-
down menu: 

 

4. Select Add. Depending on the type of redline, different dialog boxes open to complete the redline. 

After completing, the redlines are viewable in spatialNET. The date and time when the redlines were made 
display on the Detail and Browser panel.  

  



RELEASE 5.9  SPATIALNET USER MANUAL 

©SPATIALINFO PTY LIMITED, ALL RIGHTS RESERVED   

Viewing Redlining, markups and circuit tags 
 To view redlines added in spatialWEB or spatialNET: 

1.  Select the field job in the Find Field Job panel. 

2. Select Display-> Details. 

3. Select Redline in the left pane to display the Redline details. 

Viewing Splice Markups 
Splice markups can be added in spatialWEB.  See Field Job reports. 

Viewing circuit tags 
To view circuit tags added in spatialWEB: 

1. Select the field job In the Find Field Job panel. 

2. Select Display->Details. 

3. Select Circuit tags in the left-hand pane. A list of all circuit tags in the field job displays, including the 
date and time the circuit tag was made. 

 Submitting a field job 
After all edits are completed, the field job needs to be submitted for review. 

1. Select the Field Job within the Find Field Job panel. 

2. Select Edit > Change State > Submit. 

3. Add comments and click the Apply button. 

Viewing Redlining, markups and circuit tags 
To view redlines added in spatialWEB or spatialNET: 

1. Select the field job in the Find Field Job panel. 

2. Select Display-> Details. 

3. Select Redline in the left pane to display the Redline details. 

Viewing Splice Markups 
Splice markups can be added in spatialWEB. See Field Job reports. 
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Viewing circuit tags 
To view circuit tags added in spatialWEB: 

1. Select the field job In the Find Field Job panel. 

2. Select Display->Details. 

3. Select Circuit tags in the left-hand pane. A list of all circuit tags in the field job displays, including the 
date and time the circuit tag was made. 

Submitting a field job 
After all edits are completed, the field job needs to be submitted for review. 

1. Select the Field Job within the Find Field Job panel. 

2. Select Edit > Change State > Submit. 

3. Add comments and click the Apply button. 

Review states 
  
Placing a field job in review allows an administrator to accept or reject the submitted changes. Accepting a 
field job allows it to move to completion: 

1. Select the field job in the Find Field Job pane. 

2. Select Edit > Edit. 

3. From the Field Job States menu, select Accept. 

Rejecting a field Job 
Moving the field job to this state allows technicians to see the field jobs that are assigned to them that were 
not approved. 

To move a job to a rejected state: 

1. Select the Field Job.  Ensure the field job has been submitted. If not, submit the field job. 

2. Select Edit->Edit. 

3. The Field Job Modification dialog box opens. 

4. Select Reject from the drop-down menu. 

Cancelling a Field Job 
To cancel or delete a field job: 
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1. Select the field job in the Find Field Job panel. 

2. Select Edit->Change State->Cancel. 

Linking JMS jobs with a Field Job 
In the Find Field Job panel, select the field job. 

1. Select Edit->Link the Current Net job. 

2. Select Display->Details. 

3. Select Associated NET Jobs, and a list of the associated JMS jobs displays. 

Creating Field Job Reports     
 The Field Job report lists all redline activity in a field job. To open a Field Job report: 

1. Select the field job in the Find Field Job panel. 

2. Select Display->Field Job Report. A dialog box opens with the name of the report. Changing the 
extension changes the type. 

3. Select OK. 

 
The Field Job Report opens. listing all splice markups in the field job. 

Defining Field Job Types in the Dictionary 
To define a Field job in the dictionary: 

1. Go to spatialNET > Dictionaries > Other Definitions > Field Job Definitions 
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2. Select Add. The Add Field Job Definition dialog box opens. Enter the following information: 

 

Name Definition 

Definition status Select Available to use as a definition 

Field Job Type Enter a name for a type of field job markups. Ex: Circuit Provisioning 

Description Describe the type of field job 
Job Mode Audit mode- Use for markups for an entire splice case, not fiber specific 

Planning, Design Mode- Use for markups to splice cases lock specific fibers and 
reserve circuit tags 

Default tag type for this job Select a circuit tag type for circuit tag markups 
Note: Circuit tag types are populated by the circuit tag dictionary. See 
Defining Circuit tags for more information. 

spatialWEB icon Enter a name of a spatialWEB icon in a png format. 
  

3. Select Add. 

Adding Attributes Associated with a Field Job 
Attributes or descriptions can be associated with a field job. A list of default attributes is included, with the 
ability to also add specific attributes. 

1. Select the Attribute button. The Attribute Mapping dialog box opens. Select Add. 

 
The Add Attribute Mapping dialog box opens. 
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2. Enter the following: 

Name Description 
Dictionary Name States the name of dictionary for added attribute 

Type States the type of field job, Audit or Planning and Design. See  Defining Field 
Jobs in the Dictionary for more information 

spatialNET Attribute Select type of attribute from drop-down menu. 

Attribute tag Name of the actual tag that is defined in the block drawing. 

Content Allow an empty field or define if it must have a value. 

Attribute rotation Select an Attribute rotation type from the drop-down menu. See  Attribute 
rotation below. 

Default value Set this for attribute mapping- Examples of attribute mapping maybe 
numbers, or a state, depending on use of the attribute mapping. 

3.   Select Add when complete. 
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Navigation 

You can use the following options to move around a map: 

• Find function 

• Zooming 

• Panning  

• Retrieve a saved view 

Zooming 
The easiest way to zoom in is to use the scroll ball (or wheel) located between the left and right mouse 
buttons. Roll the scroll ball forward to zoom in and roll it backward to zoom out. When you zoom out, the 
edges of the map may be blank because that area has not been generated yet. Use the Refresh function to 
bring in missing map areas or missing objects from the map. If you do not see the objects you expect, check 
the Zoom Levels set in the View Settings menu. 

Panning 
To move the map area in any direction, use the scroll bars on the side of the window. 

A second method is to use the scroll ball (or wheel) located between the left and right mouse buttons. Press 
and hold the scroll ball and drag the map in the direction you wish. Be careful not to use the left mouse 
button, as this will create a selection window. 

Saving a View 
A Saved View functions as a bookmark or shortcut to a specific area in the database. Once you have created 
a saved view, you can instantly navigate back to that area by restoring the view.   

1. Select spatialNET > View > Save View from the menu. 
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2. Complete the fields on the Save View As dialog box. Be sure to select the check box next to Startup 
view for the current job if you want this map area to appear every time you log into this job. 

3. Click Save. 

Note: You can save multiple views but only one can be the startup view. Use the View Manager to see all 
the views created. 

Retrieving a Saved View 
To retrieve a saved view: 

1. Select spatialNET > View > View Manager from the menu. 

2. Select the view you wish to restore from the list of saved views and click Open.   

 
This automatically zooms to the view window to the extent you saved, and will refresh the contents of 
the view by re-querying from the database. 

Selecting the startup view for current job check box sets the saved view as the default startup view, so that 
every time this job is opened it will automatically zoom to this location. 

Note: Saved views can also be deleted from this menu. 
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Support Structures 

Landbase Toolbar 

 

Button Name Function 

 

Add Building and 
Address 

Add a residential, commercial, or MDU 
to your map. 

 

Edit Multiple 
Addresses 

Edit the attributes of multiple 
addresses. 

 

Aligns Multiple 
Addresses 

Align Multiple Addresses to a Street 
Centerline. 

 

Geocode Building Displays the building geocoding tool. 

 

Add Place Add a place to the map. 

 

Add Linear Feature Add a linear feature to the map (not a 
road or boundary). 

 

Add Boundary Add a boundary to an area. 

 

Add Parcel Add a parcel or lot to a map. 

 

Migrate Parcels Converts parcels to addresses. 

 

Add Centerline Add a centerline to a road. 

 

Find Address Advanced address find. 
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Find Centerline Advanced road find. 

Buildings and Addresses 
Service addresses are typically used to represent residential service addresses for both single and multiple 
dwelling units, and for small businesses. Larger sites, for example, a major office complex or large 
institution, are usually modeled using spatialNET’s inside plant tools. This is because providing service to 
these sites normally involves the deployment of devices of various kinds, rather than just the installation of 
a drop line. 

As with all other data types managed by the system, address types are configured in the Address Definitions 
table, under the spatialNET > Dictionaries > Landbase Definitions > Building Definitions. You can 
use the Add Building and Address button to add single residential addresses, commercial buildings, and 
MDUs. You will need to have both Residential and Commercial units defined in the dictionaries. 

 Building Dictionaries 

 

 Unit Definitions 
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Adding a Commercial Address 
To add addresses to the system: 

1. From the spatialNET menu, choose > Add > Landbase > Address or click on the Add Building and 

Addresses  button on the Landbase toolbar. 

 
A dialog box similar to the one below opens.  

2. Complete the fields using the values as shown. 

 

3. Fill in the details as appropriate. Make sure that the Create Commercial Units box has a check mark. 

4. Click on the Edit button next to Addressing Information field at the bottom of the dialog box. 
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5. Complete the address fields for the house. 

6. Click on the Done button. 

Note: A second option is to click once on the centerline before you create the address. If the centerline 
is selected, the address information will automatically populate in the Addressing Information fields. 

7. Click twice on the map to place the address. 

Adding A Residential Address 
To add addresses to the system: 

1. From the spatialNET menu, choose > Add > Landbase > Address or click on the Add Building and 

Addresses  button on the Landbase toolbar. 

 
A dialog box similar to the one below opens.  

2. Complete the values as shown. 
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3. Fill in the details as appropriate. Make sure that the Create Non-Commercial Units box has a check 
mark. 

4. Click on the Edit button next to Addressing Information field at the bottom of the dialog box. 
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5.  Enter the address information, then click the Done button. 

Note: A second option is to click once on the centerline before you create the address. If the centerline 
is selected, the address information will automatically populate in the Addressing Information fields. 

6. Click twice on the map to place the address. 

Adding a Mixed Use MDU 
To add a mixed use MDU to the system: 

1. From the spatialNET menu, choose > Add > Landbase > Address or click on the Add Building and 

Addresses  button on the Landbase toolbar. 

 
A dialog box similar to the one below opens. 

2. Complete the fields as shown. 
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3. Complete the details as appropriate. 

4. Make sure that both the Create Commercial Units box and the Create Non-Commercial Units box 
have check marks. If the check boxes are cleared, no house count will be created. 

5. Click on the Edit button next to Addressing Information field at the bottom of the dialog box.  

6. In the Residential Unit Number field, enter the starting apartment number. 

7. In Residential Units to Create field, enter the total number of apartments in the building. 

8. The Residential Unit Number Increment field can be used to create a sequence of apartment 
numbers. In the above example, apartments 1-10 will be created. The Residential Address Count is 
changed to 10. 

9. In the Commercial Unit Number field, enter the starting unit number. 

10. In the Commercial Units to Create field, enter the total number of units in the building. 

11. The Commercial Unit Number Increment field an be used to create a sequence of unit numbers. In 
the above example, units 200-400 will be created. The Commercial Address Count is changed to 3. 

12. Click on the Edit button next to Addressing Information field at the bottom of the dialog box. 
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13. Complete the address for the house. 

14. Click on the Done button. 

Note: A second option is to click once on the centerline before you create the address. If the centerline 
is selected, the address information will automatically populate in the Addressing Information fields. 

15. Click twice on the map to place the address. 

Adding a Commercial MDU 
To add a Commercial MDU to the system: 

1. From the spatialNET menu, choose > Add > Landbase > Address or click on the Add Building and 

Addresses  button on the Landbase toolbar. 

 
A dialog box similar to the one below opens   

2. Complete the fields as shown in the dialog box below. 
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3. Complete the details as appropriate.  

4. Make sure that the Create Commercial Units box has a check mark. If the check box is cleared, no 
house count will be created. 

5. Click on the Edit button next to Addressing Information field at the bottom of the dialog box. 

6. In the Commercial Unit Number field, enter the starting unit number. 

7. In the Commercial Units to Create field, enter the total number of units in the building. 

8. You can use the Commercial Unit Number Increment field to create a sequence of unit numbers. In 
the above example, units 100-500 will be created. The Commercial Address Count is changed to 5. 

9. Click on the Edit button next to Addressing Information field at the bottom of the screen. 
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10. Complete the address for the house. 

11. Click Done. 

Note: A second option is to click once on the centerline before you create the address. If the centerline 
is selected, the address information will automatically populate in the Addressing Information fields. 

12. Click twice on the map to place the address. 

Adding a Residential MDU 
To add a Residential MDU to the system: 

1. From the spatialNET menu, choose > Add > Landbase > Address or click on the Add Building and 

Addresses  button on the Landbase toolbar. 

 
A dialog box similar to the one below opens. 
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2. Complete the values as shown. 

 

3. Complete the details as appropriate.  

4. Make sure that the Create Non-Commercial Units box has a check mark. If the check box is cleared, 
no house count will be created. 

5. In the Residential Unit Number field, enter the starting unit number. 

6. In the Residential Units to Create field, enter the total number of apartments in the building. 

7. You can use the Residential Unit Number Increment field to create a sequence of apartment 
numbers. In the above example, apartments 1-20 will be created. The Residential Address Count is 
changed to 20. 

8. Click on the Edit button next to Addressing Information field at the bottom of the dialog box. 
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9. Complete the address for the house. 

10. Click on the Done button. 

Note: A second option is to click once on the centerline before you create the address. If the centerline 
is selected, the address information will automatically populate in the Addressing Information fields. 

11. Click twice on the map to place the address. 

Adding Multiple Addresses 
To add addresses to the system: 

1. Select spatialNET > Add > Landbase > Address from the menu or click on the Add Building and 

Addresses  button on the Landbase toolbar. 

 
A dialog box similar to the one below opens.   

2. Complete the fields as shown. 
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Note: In the field Next Street Number you can enter the number to increment for the next street address. 
In this example, once the address 2 is placed, the Street Number will increment to 4. You can keep clicking 
on the map to continue placing addresses. 

If you want to start with the highest street number and wish to place the addresses in reverse order, enter a 
negative number in the Next Street Number field (e.g., -2). 

Associating Addresses to Taps or Poles 
You can assign addresses to their designated support structures or to the tap directly. 

Assigning Addresses to a Tap 

1. Select the tap by clicking on it. 

2. Once the tap is selected, click on the Drop Tool   button on the Network toolbar. 

 

3. Click once on each address on the map you wish to associate to this particular tap. 
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4. Select an Assigned Spigot State from the list. 

5. Select the Drop Cable Type from the list. 

6. Watch the House Counts fields carefully. If the tap already has a house count associated to it, set the 
House Count to No Change. If you have not associated any house count yet, change this to Auto 
Increment so that the chosen houses will set the correct house count. 

7. Click on the Apply button.  

8. Select the next tap on the map and continue associating addresses. 

Assigning Addresses to a Pole or Vault 

1. Select the pole or vault you wish to assign addresses to. 

2. Once the pole or vault is selected, click on the Drop Tool  button on the Network toolbar. 

 

3. Click once on each address on the map you wish to associate to this particular pole or vault. 

 

4. Click each address on the map to assign it to the pole. 

5. Select the Drop Type and enter a drop length. 

6. Watch the House Counts fields carefully. If your tap already has a house count associated to it, you 
should set the House Count to No Change. If you have not associated any house count yet, change 
this to Auto Increment. That way, the chosen houses will set the correct house count. 

7. Click on the Apply button. 

8. You can then select the next pole or vault on the map and continue associating addresses. 



RELEASE 5.9  SPATIALNET USER MANUAL 

©SPATIALINFO PTY LIMITED, ALL RIGHTS RESERVED   

Changing the Angle of Address Placement 
When placing multiple addresses you may wish to change the angle of the address label to match the street 
angle. 

1. Click on the AutoCAD map area once to transfer the input focus, and then click once at the location of 
an address you wish to change the angle of. 

2. Click on the green circle of the manipulator and rotate the address to be 90º to the road edge (drag the 
rotation manipulator onto the road-edge and select 90º to … in the pop-up). The system will remember 
the rotation of this address, and places all subsequent addresses at this rotation. 

3. Add a sequence of new addresses to the map, just by clicking at the location of each one. Note that the 
address number will automatically increment by the value specified in the Next Street Number Add 
(Subtract) field (enter a negative number if you wish the street numbers to decrement). The addresses 
will follow the angle of rotation that you just set on the previous address. 

4. When you wish to switch it back, modify the angle of the address where the angle should change again. 

5. Continue placing addresses and they will follow the new default angle. 

 
  

Editing Multiple Addresses 
spatialNET provides the ability to edit multiple fields on multiple addresses, making it easy and efficient to 
correct or update many service address records with a single operation. The Multi-Address Edit dialog box 
also includes functions for filtering the specific addresses which are to be edited from the initially selected 
set. 

There are two methods that can be used to access the Multiple Address Modification Dialog box: the Select 
Boundary method and the Select Multiple Addresses method.   

Select Boundary Method 

1. Select a boundary on the map by clicking on it. 
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2. Click on the Edit Multiple Addresses  button on the Landbase toolbar, as shown below. 

 
The Multiple Address Modification dialog box should now be open, with all the addresses that are 
enclosed within the boundary. 

 Select Multiple Addresses Method 

1. Check that the multi-select mode is enabled by confirming that the double-arrows are displayed on the 

Toggle Selection Mode  button on the General toolbar, as shown below. If the single arrow is 

displayed, click on the Toggle Selection Mode  button to toggle back to the double arrow. 

 

2. Draw a box around the addresses to select them, as shown below. 
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3. Click on the Edit Multiple Addresses button on the Landbase toolbar, as shown below. 

 

4. The Multiple Address Modification dialog box should now be open. 

 

5. Verify that the correct addresses have been selected from the Control tab. You can also filter the list, if 
necessary. 

6. Click the Addressing tab to select what sections of the address to edit. Select the check boxes for the 
fields you would like to change, and then edit the information. 
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7. Click on the Other tab to open it. This tab lets you change additional attributes such as Service Area 
boundaries. 

 

8. If there are customer attributes, click on the Custom Attributes tab to open it, and edit the attributes. 

9. Click on the Apply button and then click on the Close button to save your changes. 
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Parcels 
In addition to modeling service addresses, spatialNET also includes the ability to model land parcels. In 
many cases, land parcel data along with the associated address information is obtainable from various 
landbase suppliers and can be automatically loaded into the system (the loading process is outside the 
scope of this course). The major advantage this brings is the ability to use parcel information to 

automatically create service address records via spatialNET’s Migrate Parcel  tool on the Landbase 
toolbar. 

Drawing a Parcel 

1. From the spatialNET menu, choose Add > Landbase > Parcel from the menu or click on the Add 

Parcel  button on the Landbase toobar. 

 
The Parcel Creation screen appears.   

 

2. Click the Edit button next to the Parcel Address field. 
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3. Complete the fields, then click the Done button. 

4. Draw a land parcel, making sure that the parcel is at the same location as the street name. 

5. Click to place each vertex of the parcel. If you make a mistake, use the Back button on the Line Capture 
Toolbar. 

6. Repeat the process to create more land parcels, making sure that you update the Street Number field 
for each parcel. 

7. Note: The parcel numbers will be automatically displayed in the center of each parcel if the Show 
Parcel Labels check box is selected in the View Settings Dialog box. 

8. If you select the street centerline before you create the parcel the street, city state details will all be 
filled in automatically in the Parcel Creation window. 
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Creating Addresses from Parcels 
The data in the land parcels can be used to automatically create the service addresses using spatialNET’s 
Migrate Parcels tool. Where land parcel data is available, this tool provides a more efficient means for 
creating service addresses than the manual entry approach used in previously. 

1. Check that the multi-select mode is enabled by confirming that the double-arrows are displayed on the 
Toggle Selection Mode button on the General toolbar, as shown below. If the single arrow is 
displayed, click on the Toggle Selection Mode button to toggle back to the double arrow. 

 

2. Draw a box around the land parcels to select them, as shown below. 

 

3. On the Landbase toolbar, click the Migrate Parcel  button. 

4. If the migration was successful, the Parcel Migration Results message box opens. 
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5. Click Close to close the message box. 

The service addresses will now be visible on the map. 

 
  

Centerlines 
Centerlines are used to represent the center of all roads. Road edges built in CAD have no intelligence and 
cannot be used to help geocode addresses. Instead, centerlines are built with address ranges so new 
addresses can be positioned even when the exact lot position is not known.   

To view the centerline dictionaries: From the spatialNET menu, choose Dictionaries > Landbase 
Definitions > Road Definitions. 

Adding Street Centerlines 
To add Street Centerlines: 

1. From the spatialNET menu, choose Add > Landbase > Road, or click the Add Road  button on 
the Landbase toolbar. 

 
This opens the Road Creation dialog box.   

2. Select a Road Type from the list. 

3. Complete the address fields. 
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Note: The address must be split across multiple fields. For instance, N 32 Ave should have N in 
Directional Prefix, 32nd in Street Name and Ave in Street Type. In the Left and Right sections, enter the 
address range for each side of the street. These will help place addresses that have not been geocoded, 
such as imported addresses.   

 

4. Click the Add button to bring up the line capture controls and run a centerline down the middle of the 
road. You can also use the offset feature to draft the line along a CAD road edge. 

 

5. When finished, click the Done button on the Line Capture Control Toolbar. 
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Editing a Centerline 
Once a centerline has been placed, its shape or properties can be modified. To change the shape of a 
centerline, refer to Linear Edit Modes. 

To change the addresses associated: 

1. Click once on the centerline to select it; then click on the Edit  button . 

 

2. Change the address properties and/or the range of addresses served. 

3. (Optional) Use the Swap Ranges button to change the addresses from left to right. 

Underground Support Structures 
spatialNET provides a configuration dictionary for specifying the types of support structures (Poles, 
Manholes Vaults, etc.) in your system, and the linear support that connects them (strand, trenches, etc.)   

From the spatialNET menu, choose Dictionaries > Support Definitions. This is where the poles are 
defined. 
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Note: The Symbol Width/Radios field determines how much space should be left around the pole itself. 
By setting this to a higher number, such as 5, the strand will come near, but not connect to the pole. 

Only an administrator can set up, alter, or delete a dictionary definition. 

Adding a Trench 
Underground routes containing conduits and/or cables are referred to as trenches. When creating a trench 
using the Add Trench function, pedestals are automatically created with the trench, but we can also create 
underground structures first and then add the trench. In this exercise, we will add trench to existing 
underground structures. 

To create a trench: 

1. Select a vault to make the starting point for the trench, or just start from free space in the map view. 

2. From the spatialNET menu, select Add > Support > Trench, or click the Add Trench  button 
on the Underground Support Structure toolbar. 

 
The Trench Creation dialog box opens. 
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3. Enter the details of the trench you want to draw. 

4. Click twice anywhere in the spatialNET view. This changes your arrow to a cross hair, and opens the 
Line Capture Controls dialog box. 

 

5. Draw the trench. To connect to a vault, right-click on it. You know it is captured when the trench line 
snaps to the center of the vault. 

6. Once the final vault has been captured, click on the Done button on the Line Capture Control toolbar. 

Adding Underground Structures 

To place a pedestal (or any other underground structure): 

1. From the spatialNET menu, select Add > Support > UG Structure, or click the Add Drop Pedestal 
button on the Underground Support Structure toolbar. 

 
The UG Structure Creation dialog box similar to the one shown below opens. 
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2. Select the structure type to be added. 

3. Complete other fields, as required. 

4. Add the House Count for the structure here as well. The Length, Width, and Depth fields auto-
populate if the dictionary entries were completed. 

5. Click on the map location at which each pedestal is to be placed. It will be displayed on the map. 

6. Add the remaining pedestals to complete the design. 

Assigning a Cable to A Duct 
All cable types can be assigned to a specific duct in a trench. To do this, you must have a trench with a duct 
built in. The cable must also be associated to the trench. 

1. Associate the trench using ONE of the following ways: 

• Capture the strand footage as you draft the cable. That will associate the two structures; or 

• Use the Multiple select method and the Construction toolbar. 

 

2. Select the trench and the desired cable. 
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3. Click on the Attach Selected Equipment to Selected Support Structure   button . 

 
A confirmation message box opens when finished. 

4. Once you have the cable and support attached, you can assign the cable to the duct. Make sure you are 
in Single Select mode. 

5. Click once on the trench to select it. 

6. In the Trench Modification dialog box, click on the Ducts button, then select Assign. 
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7. Click once on the cable segment name, and then click on the duct you want to associate it to. 

8. Click on the Save button. 

9. Click on the Apply button and then click on the Close button in the Trench Modification dialog box. 

The duct graphic now appears in bold if a cable is assigned to it. 

Connecting a Trench to a Pole 
A pole must already have a riser attached in order to connect to a trench. 

1. Select a vault as the starting point for your trench. 

2. Click on the Add Trench   button on the Trench toolbar to start a new trench. 

 

3. Select the Type of trench. 
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4. Enter the Length. 

5. Click on the Add button. 

6. Drag the cursor to the pole. 

7. Right-click on the pole. 

 

8. Select the pole from the pop-up menu. The trench is now connected. 

Changing the Vault House Count 

1. Click the vault you wish to edit to select it. 

2. Click on the Edit  button on the General toolbar. 
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3. Change the house count to the desired number. 

4. Click the Apply button and then on the Close button. 

Adding Ducts 
spatialNET has a sophisticated conduit and duct manager, which we will use to add various duct 
configurations to our subdivision. 

Let’s begin by adding four 6” PVC ducts in a 2x2 grid to one of the trenches we created. We shall explore 
how to change the duct configuration shortly. 

To add the bank of ducts: 

1. Select the trench to which the duct bank is to be added. 

2. Click the Add Ducts  button on the Trench Toolbar, as shown below: 

 
The Add Ducts dialog box opens.  

3. Complete the fields as shown below. 

4. Click Add. 
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The system automatically displays an array of ducts matching the specifications in the Add Ducts dialog 
box and place this near to the trench as shown below: 

 
Note: The way the duct forms are displayed depends on the values configured in the Duct Radius 
dictionary for each Duct Size, and for the Grid Size. 

You can also select multiple lengths of trench and add ducts to all the segments at one time. 

Adding Sub-Ducts 
The number of ducts in a bank can be changed by using the Add Sub-Duct tool. Ducts of any size can be 
added to a duct bank, and they can be added as inner-ducts, or sub-ducts, of the existing ducts. 

To add new ducts to a duct bank: 

1. Select the duct bank into which the new ducts are to be placed. 

2. Click the Add Sub-Ducts  button on the Trench toolbar. 

 
The Add Sub-Duct dialog box opens as shown below. 
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3. Select the Add as subduct check box. 

4. Specify the name of each new duct and click on the Add button to add it to the duct bank. 

Adding Subducts 

1. To add ducts as inner ducts, or subducts of the existing ducts, select the Add as subduct check box on 
the Add Another Duct dialog box.  

The duct configuration appears in the right pane of the Add Another Duct dialog box, as shown below. 

2. You can select the outer duct for the new subduct by clicking either on the diagram or on the list of 
ducts. 

 
  

Editing Duct Forms 
Existing duct forms can be edited, both in terms of the number and configuration of the ducts, and the 
information associated with each duct. 

To edit information ducts in a duct bank, such as applying a name for each duct: 
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1. Open the Edit Duct Information dialog box, as follows: 

2. Select the trench and click the Details  button on the General toolbar.   

3. In the Details panel, click Ducts. 

 

Alternative method: 

1. Select the duct bank. 

2. Click the Edit   button on the General toolbar, as shown below. 

 
The Edit Duct Information dialog box opens.  

3. Select each duct in the list in the left pane, and edit its properties in the fields to the right. 

4. To commit the changes to the database, click Save. 
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Ducts and Manipulators 
spatialNET displays manipulators that change the geometry and arrangement of the duct forms.  A 
manipulator is provided for each duct, allowing the ducts to be moved individually. Another manipulator is 
provided which allows the duct bank to be moved and rotated as a whole. 

Use both the individual and bank-wide manipulators to rearrange the layout of the ducts into a 4x1 row, 
similar to that shown below. 

 

Editing Trench Footage 
Linear support structures (trenches and aerial spans) provide a unique way for editing their lengths. When 
a linear support structure is selected in spatialNET, a special red manipulator is placed at the center of the 
line when the linear object is selected. This manipulator can be used to enter or update the length property 
of the linear support object. 

To edit the length of a trench whose length is missing: 

1. Select the trench whose length you wish to edit. 

A red Length manipulator appears. 
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2. Click and drag the manipulator to the side of the trench line where the length annotation should appear.   

3. Click the Add footage to this side of line option on the pop-up menu. 

 
The Trench Modification dialog box opens, and the pointer is automatically placed in the Length field.   

4. Enter the length you wish to assign to the trench segment as shown below. 

 
 

5. Press Enter on the keyboard to accept the footage and commit it to the database. An Annotation 
should be displayed on the side of the line you chose, displaying the footage you entered. 

6. Repeat the above process to specify the lengths of the remaining trench segments. 

Aerial Support Structures 
spatialNET provides a configuration dictionary for specifying the types of support structures (Poles, 
Manholes, Vaults, etc.) in your system, and the linear support that connects them (strand, trenches, etc.).   
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Support Structure Definitions 
From the spatialNET menu, select Dictionaries > Support Definitions. 

 

Note: The Symbol Width/Radios field determines how much space should be left around the pole itself. By 
setting this to a higher number, such as 5, the strand will come near, but not connect to the pole. 

Only an administrator can set up, alter, or delete a dictionary definition. 

Adding Strand 
Strand can be created by itself, and telephone poles will automatically be created as support structure, or 
strand can be created by adding it to an existing structure. 

1. From the spatialNET menu, select Add > Support > Strand, or click the Strand  button on the 
Aerial Structure Support toolbar. 

 

2. Fill in the appropriate details. 

3. After you have entered information into the dialog box, click once on the spatialNET view to get the 
cross hairs to appear. The Line Capture Controls dialog box opens. 

4. If you're drawing from a pole, click on the pole to begin the strand there. Otherwise, you can begin in 
free space. 
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5. A drawing line begins when you drag the mouse. Drag the line to the location of another pole. 

6. Right-click and select the second pole from the menu. 

 

7. Continue adding strand to poles until you've finished, then click Done on the Line Capture Controls 
box. 

Changing the Strand Type 

1. Select the section of strand that you wish to edit by clicking on it. 

2. Open the Strand Details panel by clicking the Details Panel  button on the General toolbar. 

3. Click the Edit button to open the Strand Modification screen. 

4. Select the correct Strand type from the Type list. If you don't see the type of strand you need, talk to 
your spatialNET administrator about getting it added to the dictionary. 

5. Click  Apply and then Close.   

Changing a Strand Length 

1. Select the section of strand that you wish to edit by clicking on it. 

2. Open the Strand Details panel by clicking the Details Panel   button on the General toolbar. 

3. Click the Edit button to open the Strand Modification screen. 

4. Enter the new length in the Length field. 

5. Click on the Apply button and then the Close button. 

Adding Poles 
To add a Joint Pole: 

1. From the spatialNET menu, select Add > Support > Pole from the menu, or click the Joint Pole  
button on the Aerial Support Structure toolbar. 
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The Pole Creation dialog box opens. 

 

2. Enter the details for the pole. 

3. Click Edit next to the General option. The General Attributes dialog box opens 

 

4. Enter the number of feet for the Cable Slack Length. 

5. If this pole will connect to underground structures, enter a length in the Riser Length field. 

6. Click  Done. 
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7. Click Edit next to House. The House Counts dialog box opens. 

 

8. Enter the count of residential services in Residential Count fed from this pole. 

9. Enter the count of commercial services in Commercial count fed from this pole. 

10. Enter the MDU Count, which is the number of multi-dwelling units fed from the pole. 

11. Enter the number of miscellaneous other services fed from this pole in the Misc. Count field. 

12. Click Done. 

13. Click once in the spatialNET view. This changes your arrow to a cross hair. 

14. Click again. A pole is now created.   

Note: If you wish to use preset offsets for placing the poles, see Nodal Placement. 

Adding a Riser to a Pole 
In order to attach underground trenches to poles, you will need to add a riser to the pole. You can do this 
during the initial drafting of the poles or they can be edited later. 

To add a riser to a pole while drafting it: 

1. In the Pole Creation dialog box, click the Edit button next to the General option. 
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2. Enter a Riser Length. 

 

3. Click Done. 
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4. Add the pole. 

To add a riser to an existing pole: 

1. Click once on the pole to select it. 

2. Click the Edit Selected Entity  button . 

 

3. There are two places you can add a riser. You can use the Pole Card button or the Edit button next to 
the General field. 

To use the Pole Card button: 

1. Click Pole Card. 

 

2. Enter the Riser Length. 
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3. Close the window by clicking on the red X in the upper right corner. 

4. Click Apply and then Close in the Pole Modification window. 

To use the Edit button: 

1. Click Edit next to the General field. 

 

2. Enter the Riser Length. 

3. Close the window by clicking the red X in the upper right corner. 

4. Click Apply and then Close in the Pole Modification window. 

Changing the Pole House Count 
There may be times when you need to edit the house count associated to a pole after the pole has been 
drafted. 

1. Select the pole. 

2. Click the Edit Selected Entity  button . 
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3. Click the Edit button next to the House Counts field on the Pole Modification dialog box. 

 

4. Enter the adjusted count and click Done. 

5. In the Pole Modification dialog box, click Apply and then Close. 

Boundaries 
To make it easier to locate and manage areas within the map, a boundary is created around a specific area, 
such as a county, a city, the area serviced by a single hub, etc. You may already have these boundaries in 
your existing landbase and/or network maps. Once it is saved as a boundary in spatialNET, you can easily 
search the database for an area you require and zoom to it directly. 

The differences between a Boundary and a Saved View: 

• A saved view is visible only in the job in which it was created. Other jobs cannot see it, and it disappears 
when the job is posted or cancelled. A boundary, however, is visible to everyone once it is published or 
posted, and persists in the database until it is deleted. 
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• The outline of a saved view is not visible on the map, whereas a boundary is. 

• There is only one type of saved view, but you can configure as many types of boundaries as you wish. 

Boundaries are defined in the Landbase Dictionary. To view your boundary types, select spatialNET > 
Dictionaries > Landbase Definitions and Boundary Definitions from the menu. 

Here is an example of the fields that must be filled out to build a boundary. 

 

Notes: 

Only administrators can set up, alter, or delete dictionary definitions. 

Service Area Type is an important field. There are three levels of service area types. These should be 
assigned when you wish to automatically associate addresses to the boundaries. They are useful for node 
boundaries, buss boundaries and rate centers. 

Service Area Manager 
There are many cases where a geographical boundary is used to delimit a particular characteristic of a 
distribution network. For example, a telephony rate center area denotes the region within which all 
addresses are assigned a specific rate code. Alternatively, it is common practice to draw a boundary 
enclosing the geographical area which is served by a single network distribution point, such as a specific 
Optical Node in an HFC network, or a particular distribution cabinet in an FTTx network. 

When such boundaries are used, it is convenient to assign each address which is located within that 
boundary to the boundary itself. In this way, addresses can be automatically allocated to the correct rate 
center, distribution area, etc. with no input required from the user. 
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This automatic association between addresses and certain boundary types can be made via the use of 
Service Boundaries. A Service Boundary is a normal geographical boundary, with the added feature that any 
address placed within that boundary will be automatically associated to that boundary in the database. 
spatialNET supports up to three different types of service boundaries (e.g., so that an address can 
simultaneously be associated with a telephony rate center, a distribution node boundary, and a dispatch 
area).   

Service boundaries must be configured in the dictionaries. See your spatialNET administrator for help. 

To create a boundary and assign addresses: 

1. Select spatialNET > Add > Landbase > Boundary from the men, or click on the Add Boundary   
button on the Landbase toolbar. 

 
The Boundary Creation dialog box opens. 

2. Enter a name for the boundary. 

3. Select a Type from the list.  

4. Complete the Contact, City, County, and State fields. 

5. Click on the Add button. 

The Line Capture Control dialog box opens. 

 

6. Click twice on the map to transfer the selection to the map window. 

7. With the Vertex Mode cross-hair button selected in the Line Capture control dialog box, click on each 
point at which you wish to place a vertex of the boundary. 

8. Click on the Close button when done. This closes the boundary polygon geometry and completes the 
addition of the new boundary. 

9. Click on the Close button on the Boundary Creation dialog box. This refreshes the Boundary Creation 
dialog box, allowing for a new boundary to be created, if needed. 

10. If the boundary type chosen has a Service Area Type assigned, the following menu opens: 
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Reassigning Addresses to Boundaries 
Addresses are assigned to boundaries when you create a boundary with a Service Area type. Refer to the 
Service Area Manager section to set up a boundary with this feature. 

Once you have a service area boundary, there may be a time when you need to modify the addresses or 
equipment associated to a boundary. For instance, RF networks are frequently split into Node boundaries, 
as well as Trunk or Buss boundaries. Each one of these areas can have the RF equipment and addresses they 
service attached to them using a Service Area Boundary. However, when a node or trunk split occurs, these 
boundaries need to be updated and the addresses and associated equipment need to be re-assigned. 

To update a Boundary with Service Area attached: 

1. Click once on the boundary to select it. 

2. From the spatialNET menu, select List > Service Area Manager. 
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3. You can then choose what to update on the map. 

 

4. Click the List button to get details of the currently assigned objects. 

5. Click the Assign button to update the addresses or RF equipment associated to the boundary. 

  

Editing Boundary Details 

1. To edit a boundary’s properties, do ONE of the following: 

• Click on the boundary, and then click the Edit Selected Entity  button on the General toolbar; 
or 

 

• Select the boundary and click the Details  button. You can also access the Edit button from the 
Details dialog box. 

This action displays the Boundary Modification dialog box.   

2. Edit the properties as required. 

3. Click Apply button. 

Editing a Boundary Shape 
Moving a Vertex 
To change the geometry of a boundary by moving a vertex using spatialNET manipulators: 

1. Click on the manipulator, drag it to the required position, and click again.   
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2. Select Move to location from the pop-up menu. 

The boundary geometry is updated to include the newly updated vertex. 

 

Deleting a Vertex 

1. To change the geometry of a boundary by deleting a single vertex: 

2. Click on the manipulator at the vertex to be deleted, drag it, then click again. 

3. Select Delete vertex from the pop-up menu. The vertex is removed. 

 
To add vertices or bulges to the line, use the Linear Edit Modes. 

Creating a Boundary 

1. From the spatialNET menu, select Add > Landbase > Boundary. 

The Boundary Creation dialog box opens. 

2. Select the Type from the list. 

3. Enter a name for your boundary.   

4. Click Add. 

The Line Capture Controls dialog box opens. 
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5. Click twice on the map to transfer the selection to the map window. 

6. With the Vertex Mode cross-hair button selected in the Line Capture control dialog box, click on each 
point at which you wish to place a vertex of the boundary. 

7. Click Close when done. This closes the boundary polygon geometry and completes the addition of the 
new boundary. 

8. Click Close on the Boundary Creation dialog box. This refreshes the Boundary Creation dialog box, 
allowing for a new boundary to be created, if needed. 

9. If the boundary type chosen has a Service Area Type assigned, the following dialog box opens: 

 

10. This dialog box allows you to assign various devices to the boundary. For instance, a rate center 
boundary might need all addresses associated to it. Select the entity type you wish to associate to the 
boundary and click Assign. 
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Sites 

Sites are facilities that contain network equipment. They can include head ends, central offices, hubs, 
nodes, even certain customer sites, such cell towers for backhaul networks. There are two types of sites: ISP 
(Inside Plant) and OSP (Outside Plant). 

Inside Plant 
ISP sites are capable of modeling inside plant. They can contain floors, racks, chassis, and cards and have 
full schematics drawn for them. They do not have to be fully modeled; they can be set up to contain only a 
term panel which will serve as a splice point for an outside plant fiber cable. It can be upgraded at a later 
date to a fully modeled inside plant site. 

Outside Plant 
OSP sites can only hold a term panel, which will act as a splice location for an outside plant fiber cable. An 
outside plant site cannot be upgraded to become inside plant. These sites will have to be redrafted and 
connected if you decide to capture the inside plant information. 
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Inside Plant 

Overview 

Inside Plant (ISP) Tools 
spatialNET includes a sophisticated set of tools for managing ISP, including: 

• Fully connected model of devices, including connectivity to the outside plant. 

• Floorplan and vertical views for multi-story buildings. 

• Automatic generation of rack elevation diagrams. 

• Semi-automatic production and maintenance of connectivity schematics. 

• Equipment configuration libraries. 

• Modeling of internal equipment states (such as multiplexing, routing and cross-connect tables). 

• Management of logical circuits, from simple WDM wavelengths to hierarchical architectures such as 
SONET and SDH. 

Order of ISP Procedures 
To create a site, add floors and equipment, and connect the equipment, follow these procedures in the 
order given: 

1. Adding an ISP Site 

2. Adding a Floor to an ISP Site 

3. Importing a Floorplan Drawing 

4. Displaying a Floorplan 

5. Adding a Rack to a Floor 

6. Displaying Rack Elevation Views 
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7. Adding a Chassis to a Rack 

8. Adding a Card to a Chassis 

9. Creating a Connectivity Detail Drawing 

10. Placing Equipment into a Detailed Drawing 

11. Connecting Equipment in Detailed Drawings 

12. Multiple Detail Drawings and Feathers 

13. Adding Multi-Fiber Cables Between ISP Racks 

14. Connecting to an Outside Plant 

Inside Plant Views 
spatialNET’s inside plant model can broadly be separated into two groups: 

• Functions associated with Creating and Managing Views of Facilities and ISP Equipment 

• Functions associated with Managing Equipment Location, Configuration, and Connectivity 

View Automation and Persistence 
To understand how spatialNET manages inside plant views, it is useful to describe them in terms of their 
automation and persistence properties. That is: 

• Automation is the extent to which the system can create visual representations of equipment based on 
data in the database, without human assistance. 

• Persistence describes whether a view exists as an on-going database object in its own right, or whether 
it is just transient and ceases to exist as soon as the window in which it is contained is closed. Persistent 
views must be explicitly created and named before any data can be displayed in them. Because they have 
an on-going existence in the database, persistent views can store properties of their own. Transient 
views, on the other hand, are created as required by the system, do not have names, and cannot retain 
properties of their own. 

Note: A view of any type can be permanently retained by saving it to a DWG file using the standard File > 
Save As function. This saves a snapshot of the view that will not be updated as the database changes. 

Automation and persistence properties of the three inside plant view types are summarized below: 

ISP View 
Type 

Automation Persistence 

Floorplan No automation – Objects are manually 
placed and aligned by the user. 

Persistent – A floorplan view is associated 
with each floor of a building and owns all the 
visual objects that appear in the view. Any 
changes to a floorplan view and saved will be 
retained in the database. 

Rack Elevation Full automation – The system generates rack 
elevation views from rack layout records in 
the database. No manual placement is 
required. 

Transient – Rack elevation views are 
generated on the fly from a selected set of 
racks. They are not associated with any 
object, nor saved in the database. 
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Schematic Detail Partial automation – Equipment blocks are 
manually located, but connectivity between 
ports is automatically shown. Any changes 
made by the user to connectivity or 
equipment graphics are retained in the view. 

Persistent – Detail schematic views can be 
created as required, and are associated with a 
specific building. Any changes made to a 
schematic view and saved will be retained in 
the database. 

Inside Plant Toolbars 
Toolbars related to inside plant are: 

•  ISP Toolbar 

 
• Rack Elevation Toolbar 

 
• Detail Drawings Toolbar 

 

How spatialNET Represents ISP Equipment 
spatialNET allows you to manage many aspects of inside plant equipment, including: 

• Where it is located 

• What it is connected to 

• How much space it takes up 

• What ports are present 

• How the equipment is configured 

Inside Plant Equipment Location 
spatialNET requires that you specify a location for each piece of inside plant equipment. This location 
depends on the type of equipment: 

• Floors are contained in buildings 

• Racks are contained on floors 

• Chassis are contained in racks 

• Cards are contained in Chassis 
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Because of the containment hierarchy, when you want to add a new piece of equipment to the database, 
you must make sure the object in which it is contained already exists. If it does not, you must create the 
container object first. To this point, before you can add any equipment inside a building, you must first add 
the building record to the database. Then you must have at least one floor within the building before you 
can add any racks, chassis, or cards. 
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Adding an ISP Site 
To record inside plant, Sites do not have to have a location on a map. You can easily use spatialNET to 
manage sites as “aspatial” entities (that is, objects whose geographical location is not being modeled) and 
never enter a single map into the system. In most cases, you will probably want to integrate inside plant 
management with your outside plant network. 

All inside plant in spatialNET must be contained within a site. Before you can add a new site, you must first 
ensure that the type of the site you wish to add is in the systems Site Dictionary. 

To add a new ISP site: 

1. From the spatialNET menu, select Add > Other > Site from the menu, or click the Add Site  button 
on the Fiber toolbar. 

2. The Site Creation dialog box opens. 

3. Select the Site Type and verify that Capable of modeling inside plant check box is selected. 

4. Complete the all appropriate text fields for your site. 

5. Ensure that the Placement crosshair  icon is selected in the Site Creation dialog box. 

6. Place the site on the map by clicking once to set the input focus back to the drawing window, and once 
more to place the new entity. 

7. After the site is on the drawing window, click the Close button in the Site Creation window. 
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8. Continue to Adding a Floor to an ISP Site. 

Adding a Floor to an ISP Site 
A newly created site is simply the shell of the building without floors. To place equipment into a new site, 
you must follow the ISP containment hierarchy: floors are contained within buildings, racks are contained 
within floors, chassis and cards are contained within racks. See How spatialNET Represents ISP Equipment. 

To add a floor to the site: 

1. Open the Details Window of the site by clicking on the Details  button. 

2. With the Site Details window opens, click Add and then select Add a floor to the selected site. 

The Site Floorplan Creation dialog box opens. 
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3. Complete all the fields and click the Add button. 

The newly created floor is now visible in the Site (ISP) Details panel. 

 

4. Continue to Importing a Floorplan Drawing. 
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Importing a Floorplan Drawing 
While it is not necessary to import a floorplan drawing, if you have one, it is helpful to use the information 
in it to accurately locate inside plant equipment. 

To import a floorplan drawing: 

1. From the menu, select File > Open and navigate to the directory containing the AutoCAD .dwg file 
that you wish to use. 

When the file is opened, spatialNET displays the Open Drawing File panel. 

 

2. Select the appropriate options from the drop-down menus: 

• Open drawing as: spatialNET view 

• View type to use: ISP Floorplan 

• Current Site: Name of Site to place .DWG 

• Current Drawing: Name of Floor to place .DWG 

3.  When all fields are selected, click Continue. 

4. When the graphics are visible in the AutoCAD window, select AutoCAD File > Save from the menu to 
import the graphics into the spatialNET database. 

5. Continue to Displaying a Floorplan. 

Notes: 
• Any AutoCAD object created during the session using the normal AutoCAD drawing commands can be 

CAD-scraped into the spatialNET Database. 

• Any blocks scraped in must be defined either in a DWG file on the AutoCAD Support File path (usual 
method), or in the view template DWT file. CAD-scrape only records block names; it does not read the 
block definition into the database. 
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• Properties of CAD Layers must be defined in the view template DWT file. CAD objects not defined in 
the DWT file will use the default color, line type, and line weight. 

Displaying a Floorplan 

1.  Select the site you wish to view and click the Details of Selected Entity  button. 

2. Within the Details window, highlight the floor you wish to view. 

 

3. Click Display and select Floorplan View. 

4. Continue to Adding a Rack to a Floor. 

Adding a Rack to a Floor 
Once a floor has been added to a site, you can add racks. Two methods are available. 

Method 1 
This method allows you to directly position the rack within the floorplan view that was created. 

1. From the menu, select ISP > List > Site (ISP). This opens a panel listing all sites by name. 

2. Find and click on the row containing the site you wish to work with. 

3. Click Display and select Floorplan. 

4. If more than one floor is contained within the site, the All Site Floorplans window opens. Click on the 
floor you wish to work with and click Select. 
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5. With the floorplan view now visible, select ISP > Add > Rack from the menu or click the Add Rack 

button  on the Add ISP toolbar. 

6. Complete the fields on the Rack Creation panel. 

 
Note: If the Catalog Number of the rack you wish to use is unknown, click Select Rack for a list of all 
available racks within the dictionary. 

7. When all information has been specified within the Rack Creation panel, click once on the drawing 
window to set the input focus and once more on the location of the floorplan drawing where you would 
like to place the rack. 

 
Note: The rack symbol will not be displayed correctly if the directory containing the block file is not on 
AutoCAD’s support path. In this case, a symbol similar to the following will be displayed instead. 

 

8. Continue to Displaying Rack Elevation Views. 
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 Method 2 
This method allows you to add the rack within the Site Details Window (useful when adding racks on 
different floors). 

1. Select the site that you wish to view and click the Details of Selected Entity  button. 

2. Within the Details window, highlight the floor where you wish to place a rack. 

 

3. Click Add and select Add a rack to the selected site floor. 

4. Complete the fields on the Rack Creation Panel. 

 
Note: If the Catalog Number of the rack you wish to use is unknown, click Select Racks for a list of all 
available racks within the dictionary. 

5. When finished, click Add. 

6. Continue to Displaying Rack Elevation Views. 

  



RELEASE 5.9  SPATIALNET USER MANUAL 

©SPATIALINFO PTY LIMITED, ALL RIGHTS RESERVED   

Displaying Rack Elevation Views 

1. Select the site that you wish to view and click the Details of Selected Entity  button. 

2. Within the Details window, highlight the floor of the racks that you wish to view. 

 

3. Click Display and select Rack Elevation View. 

 
Note: To only display a specific rack, highlight that rack within the Sites Details window, click Display, 
and select Rack Elevation View. 

4. Continue to Adding a Chassis to a Rack. 
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Adding a Chassis to a Rack 
Once a Rack is added to a site floor, you can begin adding Chassis. A chassis may be inserted into racks with 
any kind of graphical view present on the screen, or even with no graphical view present at all. The chassis 
data will be associated with the rack in the database in the correct way regardless of what view is currently 
shown. 

Method 1 
This method allows you to add the chassis into a rack while in the Rack Elevation view. 

1. Select the site that you wish to view and click the Details of Selected Entity  button on the 
General toolbar. 

2. Within the Details window, highlight the floor the rack is on. 

3. Click Display and select Rack Elevation View. 

4. Click the relevant rack within the drawing window and select ISP > Add > Chassis from the menu, or 

click the Add Chassis  button on the Add ISP toolbar. 

5. In the resulting Chassis Creation panel, complete the fields and choose the mount point for the chassis. 

 
Note: If the Catalog Number is unknown, click the Select Chassis button to open a list of entries in 
the equipment dictionary that match the class of equipment you are trying to add. 

6. Click the Add button to place the chassis inside the rack. 
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7. Continue to Adding a Card to a Chassis. 

Method 2 
This method allows you to quickly add chassis within the Site Details window. 

1. Select the site to view and click the Details of Selected Entity  button. 

2. Within the Details window, expand the specific Floor and highlight the Rack in which the chassis will 
be placed. 
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3. With the Rack highlighted, click Add > Add a chassis to the highlighted rack. 

4. In the resulting Chassis Creation panel, complete the fields and choose the mount point for the chassis. 

 
Note: If the Catalog Number is unknown, click the Select Chassis button to open a list of entries in 
the equipment dictionary that match the class of equipment you are trying to add. 

5. Click the Add button to place the chassis inside the rack. The chassis is now visible inside the Details 
window. 
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6. Continue to Adding a Card to a Chassis. 

The following must be unique for each chassis in a building: 

• Combination of floor number, aisle number, rack number and mount point number. 

• Name 

These values may be duplicated in different buildings, however. 

Adding a Card to a Chassis 
When a chassis is not considered a patch or termination panel, a card can be placed into it. A card can be 
inserted into a chassis with any type of graphical view present on the screen. The card data will be 
associated with the chassis in the database in the correct way, regardless of the view presently on the 
screen. A card can also be placed inside another card. 

Method 1 
This method allows you to add the card into a chassis while in the Rack Elevation view. 

1. Select the site that you wish to view and click the Details of Selected Entity  button on the 
General toolbar. 

2. Within the Details window, highlight the floor the rack is on. 

3. Click Display and select Rack Elevation View. 

4. Click the relevant chassis within the Rack Elevation drawing window and select ISP > Add > Card from 

the menu, or click the Add Card  button on the Add ISP toolbar. 
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5. In the resulting Card Creation panel, complete the fields and choose the mount point for the chassis. 

 
Note: If the Catalog Number is unknown, click the Select Card button to open a list of entries in the 
equipment dictionary that match the class of equipment you are trying to add. 

6. Click the Add button to add the card to the chassis. 
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7. Place any other necessary cards in the chassis; then click Close. 

Note: The symbols will not display correctly if the directory containing the elevation block files is not on 
AutoCAD's support path, and you may see something like the following: 

 
To remedy the problem, ensure that the blklib\elevation subdirectory of your spatialNET installation 
is included in AutoCAD's support file search path. 

8. Continue to Creating a Connectivity Detail Drawing. 

Method 2 
This method allows you to quickly add a card through the Site Details window. 

1. Select the site that you wish to view and click the Details of Selected Entity  button on the 
General toolbar. 

2. Within the Details window, expand the specific floor and rack; then highlight the chassis where the 
card will be placed. 

 

3. With the chassis highlighted, click Add > Add a card to the highlighted chassis. 

4. In the resulting Card Creation panel, complete the fields and choose the mount point for the chassis. 
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5. Click the Add button to place the card inside the chassis. The card is now visible inside the chassis 
diagram. 

6. Place any other necessary cards in the chassis; then click Close. 

7. Continue to Creating a Connectivity Detail Drawing. 

The following must be unique for each chassis in a building: 

• Combination of floor number, aisle number, rack number and mount point number. 

• Name 

These values may be duplicated in different buildings, however. 

Creating a Connectivity Detail Drawing 
Detail drawings allow you to associate connectivity to equipment. After you add a chassis or card, you must 
record their connectivity. 

Detail views are similar to floorplans in that they exist as persistent objects in the database. Therefore, 
before you can use a detail view, you need to create it in the database similar to MDU drawings By contrast, 
rack elevation views are generated “on the fly” and do not exist in the database. When you close a rack 
elevation window, you must regenerate the elevation view by selecting the same set of racks again. 

One difference between detail and floorplan drawings, however, is that floorplan drawings are associated 
with a unique floor in the building. Detail drawings, on the other hand, are just associated with the site 
itself, and know nothing about floors. This makes it easier to represent connected equipment that exists on 
different floors. 

To create a detail drawing: 

1. Select the site that you wish to add. 

Note: If you have an ISP view open already, your current site will be set to the building containing the 
data in the view. 
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2. Select ISP > Detail Drawings > List Detail Drawing from the drop-down menu, OR click the Create 

Detail Drawing  button on the Detail Drawings toolbar. 

A dialog box with an empty list box should be displayed. 

3. Click Add on the All Detail Drawings list dialog box. 

4. In the resulting Detail Drawing Creation window, complete the appropriate fields. 

 

5. Click Add.  

The new detail drawing visible in the Site Detail drawings category in the Site (ISP) Details panel. 
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6.  To display the detail drawing, click Display > Detail Drawing from the Site Details panel, OR, with 

the site selected, click the Display Detail Drawing  button on the Detail Drawings toolbar. 

Note: When the Detail Drawing is opened for the first time, it will be empty. This is because 
spatialNET takes the approach that connectivity schematics should be more than a diagram of all 
connections that the software can find the network without any context. Rather, Detail Drawings 
should present a form of structured documentation which conveys the underlying design intentions 
and organization of the network in a way that is meaningful to human operators. To achieve this, you 
must tell spatialNET which pieces of equipment are to appear in which detail drawings, and where they 
will be placed within those drawings. spatialNET will then take care of the rest (connectivity, data 
updates, etc.) 

7.  Continue to Placing Equipment into a Detailed Drawing. 

Placing Equipment into a Detailed Drawing 
To place equipment into a schematic view, it is easiest to first select the equipment in another view and 
then place it into the Detail Drawing. Rack elevations are ideal for selecting the needed equipment but any 
view or panel from which the piece of equipment can be selected will work just as well. 

1. Open the appropriate Rack Elevation view that has the equipment you wish to add. 

2. In a separate window, open the Detail drawing contained within the site. 

Note: Select Window > Tile Vertically to display both windows on the screen simultaneously. 
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3. Click on the piece of equipment in the Rack Elevation view that you wish to place into the Detail 
Drawing. 

Note: Placement of Schematic Symbols into Detail Drawings supports Multiple Selection . If you 
select multiple pieces of equipment and continue with these procedures, a schematic representation of 
each selected piece of equipment will be added to the Detail Drawing. 

4. With the equipment selected, click ISP > Detail drawings > Display Selected Card from the drop-

down menu, OR click the Place Selected Card in Detail Drawing  button on the Detail Drawings 
toolbar. 

5. When the Detail Drawing Card Creation panel opens (see next image), click on the Detail Drawing 
window you have open to activate it for input; then click at the location where the selected equipment 
should be placed. 

 

6. When the card is visible in the Detail Drawing window, click Close on the Detail Drawing Card 
Creation window. 
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7. Continue to Connecting to an Outside Plant. 

Notes: Some Tooltips and user interface features refer to this function as placing a "card" into a Detail 
Drawing. The function actually applies to any connectable device, including racks, standalone 
equipment and chassis, as well as cards. 

The symbols will not be displayed correctly if the directory containing the elevation block files is not on 
AutoCAD’s support path. In this case, a symbol similar to the following will be displayed: 

 
To remedy this problem, ensure that the blklib\elevation and blklib\detail subdirectories of 
your spatialNET installation are both included in AutoCAD’s support file search path. 

Connecting to an Outside Plant 
One of the most powerful features of spatialNET is the ability to manage a comprehensive and detailed 
model of both inside and outside plant networks in a single application. To utilize the full power of this 
feature, you must connect an inside plant to an outside plant. This procedure shows only a minimal outside 
plant—just enough to connect together two buildings created in Adding an ISP Site. 

To connect an inside-plant view to an outside-plant view: 

1. Create a map view showing both buildings. Use the Display Map View button to do this. 

2. Ensure both buildings have at least one rack in them. If they do not, you will have to add one before 
you can continue with this step. 

3. Select one of the buildings by clicking on it. 

4. Select Add Fiber Cable from the menu to create a fiber between one building and the other using ONE 
of the following methods: 

• Select OSP > Add > Fiber Cable from the menu; OR 

• Click the Add Cable button on the Fiber Add toolbar. 
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5. Complete the fields of the Fiber Cable Creation dialog box as shown below. 

 

6. Ensure that the Selection arrow  is selected in the Fiber Cable Creation dialog box. 

7. Click Add. You will be prompted to specify which rack the fiber cable you are about to create should be 
connected to, and which splice enclosure within the rack. 

8. If your racks have splice enclosures in them yet, you must create one with the New Splice button. 

9. When creating the new splice, expand the OSP Equipment branch of the rack view and select the 
splice. This will begin the cable creation process. 

 

10. This example excludes any real outside plant routing for this cable; just right-click on one of the 
building, and select it from the displayed pop-up to connect the cable (Hint: if the Cable Creation 
dialog box is overlapping one of the buildings, use the Toggle button on the Line Capture Control 
dialog box to hide it). 
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You need to specify the terminating splice enclosure for the cable in the second building, just as you 
did in the first. 

11. Click Done on the Line Capture Control dialog box to finalize the cable and add it to the database. 

12. The last task in the process is to add a fiber termination box so we can connect the fiber to the ISP 
patch shelf. To do this: 

a. Select the rack containing the end of the OSP fiber we just created above. You may do this by 
bringing up a floorplan view or rack elevation (see Importing a Floorplan Drawing) containing it, 
selecting ISP > List > Racks from the menu, or by any other selection method. 

b. When the rack is selected, open its Details dialog box by clicking on the Details button (if you are 
looking at a list dialog box), or clicking the Details button on the General toolbar. 

c. Find the Splice Enclosure entry under the OSP Equipment – OSP Connectivity branch and select it 
by clicking the Select button on the Details dialog box. 

d. Add a Term Dialog box to the splice enclosure. 

e. With the Splice Enclosure selected, splice the Term Dialog box to the OSP Fiber. 

This completes adding outside plant cable and connecting it physically to a rack. 

Connecting Equipment in Detailed Drawings 
Making connections between devices in the Detail Drawing is very easy once all equipment, including the 
Termination or Patch Panels, has been placed. See Placing Equipment into a Detailed Drawing for 
information on adding equipment. 

If an object is selected in a schematic view, yellow circles are drawn at each connectable port. These circles 
represent spatialNET’s connection manipulators and are used to form new connections when you drag and 
drop them from one port to another. 

To connect equipment: 

1. Ensure the Detail Drawing to be modified is visible and has the input focus. (See Creating a 
Connectivity Detail Drawing for information on displaying Detail Drawings.) 

2. Click on the Transmitter symbol. A connection manipulator (shown as a yellow circle) appears and can 
be grabbed. 

 

3. Click on the connection manipulator (which will turn orange) and drag it near the piece of equipment 
to be connected. When a connection manipulator senses another piece of equipment nearby, it 
activates the manipulators on that equipment’s ports. 
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4. Drag the connection manipulator to the desired port and left-click once to open the New Connections 
menu. 

 

 

5. Left-click again to confirm the connection. 

6. In the ISP Patch Cable Creation panel (which opened when you created the connection), complete 
the appropriate fields about the jumper cable being used and click Add. 

 
The cable shows the connection between the two devices. When you select the cable, green 
manipulators are displayed at each vertex of the connection line, and red manipulators are displayed at 
each segment’s mid-point. The green manipulators move the vertices, while the red manipulators move 
the entire segment orthogonally. These tools let you fine tune the appearance of the schematic.   

7. Continue to Multiple Detail Drawings and Feathers. 

Notes: 
• Any graphical changes you make to the Detail Drawing (move equipment, linework, etc.) are stored in 

the database and are present each time the drawing is viewed in future sessions. 

• Deleting a connection line in a Detail Drawing deletes the connection between the ports and removes 
the cable making the connection from the database. 

• Deleting a piece of equipment from a schematic can either: 

•  Delete the equipment, and all its representations from the database 
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•  

• Or, delete the equipment from the Detail Drawing only. In this case, any connections to the 
equipment are replaced by a "feather" hyperlink symbol. 

 
CAD-scrape may be used in Detail Drawings to add miscellaneous annotation, mark-up, etc. 

Multiple Detail Drawings and Feathers 
It is possible to have multiple Detail Drawings associated with a site. Multiple Detail Drawings are useful 
when you are working with a large facility that contains many different pieces of equipment and 
connections. It is easy to track all equipment within a site by grouping the transmitters in one drawing and 
patch panels in another. 

Placeholders known as "feathers" must be added to the drawings to represent the connection path between 
the pieces of equipment and the next object downstream. 

To add another Detail Drawing: 

1. Select the site to be added; then select ISP > Detail Drawings > Create Detail Drawing from the 

drop-down menu, OR click the Create Detail Drawing  button on the Detail drawings toolbar. 

2. Complete all appropriate fields in the resulting Detail Drawing Creation and click Add. 
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The additional drawing created is now visible under the Site Detail drawings category in the Site 
Details panel. 

 
Note: It is easiest to place feathers and cards between Detail Drawings by first selecting the equipment 
in another view and then placing it into the Detail Drawing. 

With the two views opened, you can proceed to replacing cards and feathers. 

3. Continue to Adding Multi-Fiber Cables Between ISP Racks. 
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Adding Multi-Fiber Cables Between ISP Racks 
spatialNET allows you to place multi-fiber cables, similar to those used in outside plant situations, between 
racks. This is useful in representing pigtails, intra-facility cables, risers, and other fiber sheaths that carry 
multiple fibers from one location in a building to another. 

To place a multi-fiber cable: 

1. Open an ISP floorplan view containing the racks at which the cable is to start and end. 

 

 

2. Select ISP > Add > Multi-Fiber Cable from the drop-down menu to open the Multi-Fiber Cable 
Creation panel. 
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3. Complete the fields in the Multi-Fiber Creation panel using the following guidelines: 

Field Description 
Autoselect newly created entity Check if the newly-created cable should be the selected entity when the 

operation is complete. 

Cable Type Choose the cable type from the list of available values configured in the Riser 
Cable dictionary. 

Number of Fibers Select the number of fibers in the selected cable type. 

Cable Name Input the name to be assigned to the new cable. 

Check for duplicates Check if spatialNET should display a warning if the value supplied for the 
name currently exists in the database. 

Auto increment Check if spatialNET should automatically increment the numerical part of the 
value in the Name field as each new cable is added. 

Plant Owner Choose the plant owner from the list of available values configured in the 
Plant Owner dictionary. 

Lease Agreement Allows the cable to be associated with an existing lease agreement. 

Reel ID Input the identification of the reel from which the cable was placed. 

Cable Design Length Input the estimated design length of the cable. 
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Cable Sag Factor Input the assumed sag/helix factor of the cable. 

Add Slack Length Input the length of any additional slack to be added to the overall cable 
length. 

Design Length Control Select one: 
•     Estimate From Strand: Length will be determined by the length of the 
associated support structures. Not applicable for ISP cables. 
•     Estimate From Model: Measures the length of the drafted linework 
representing the cable and uses it to estimate the cable length. Only 
appropriate if the ISP floorplan drawing is on the same scale as the OSP maps. 
•     Manual Override: Length will be manually entered. 

As Built Lengths Displays the As Built Lengths panel. Edit as necessary. 

 

Installation Date Input the date the cable was installed. 

Account Code Input any unique ID applied to the cable. 

Miscellaneous Text Input any miscellaneous text associated with the cable. 

Create Default Work Units Check if the default work units (WU) configured in the Fiber Cable dictionary 
should be associated with the cable when it is created. 

4. Select the rack within the Rack Elevation view at which the cable will start and click Add on the Multi-
Fiber Creation panel. 

5. When the Line Capture Controls panel opens, you can begin to digitize the path of the cable on the 
floorplan view. 

• Left-click to place vertices. 

• Right-click on a targeted rack to associate the cable to that rack. 
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6. Click Done on the Line Capture Controls panel when finished. 

7. As with OSP cables, the ISP multi-fiber cable must terminate at a splice in the chosen rack. When the 
OPS splice panel opens, expand the OSP branch and select an existing fiber splice in the chosen rack, 
OR create a new one. 

 

Creating a Cable Run List Report 
The Cable Run List report lists all of the inside plant connections, disconnections, and re-connections that 
are made in the current job and stores them in a .csv or html format. 

To create a Cable Run List report for the current job: 

1. From the drop-down menu, select ISP > Reports > Generate a Cable Run List. 

2. In the Save Report dialog box, input the name of the file in the Output Path field, OR click the  
button and browse to the location of the report. 
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3. Type .csv or .html at the end of the file name to specify the report format. 

 

4. In the Save Report dialog box, click Save List. 

5. If the report does not automatically open, navigate to the location where the file is saved and double-
click on it to open it. 
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Thematic Mapping 

Thematic mapping is a way of changing how an object displays on the map based on certain attributes. For 
example, fiber cables that have a total fiber count of >144 could display on the map in a different color. 

In spatialNET, thematic mapping functions are provided by Thematic Presentations. A Thematic 
Presentation is a collection of color-by-attribute rules, that is, a collection of themes. A single theme 
identifies: 

• A class of entity (e.g., pole, cable, or splice). 

• A color and CAD layer to display that entity. 

• A set of one or more conditions under which entities should be displayed that color (for example, color 
fiber cables red if the fiber count >144). 

Using thematic mapping involves the following sequence of steps: 

1. Create a Thematic Presentation (or open an existing Thematic Presentation). 

2. Add one or more Themes to the Thematic Presentation by choosing a class of entity, display color, and 
display layer. 

3. For each theme, specify the conditions under which that theme is to be used. 

Once created in this way, a Thematic Presentation can be used during view creation, or disabled, as desired. 

spatialNET also provides an Auto-Theme function. Once a class of entity and attribute has been specified, 
spatialNET can automatically assign colors based on the distribution of values for that attribute in the view. 

Creating a Thematic Presentation 
To create a thematic presentation: 

1. Select the option spatialNET > View > Thematic Mapping to open the All Thematic Presentations 
dialog box. 
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2. Click New to open the Thematic Presentation Creation dialog box. 

3. Enter the new thematic presentation name, and click Add. 

 
The new thematic presentation should now be visible in the All Thematic Presentations dialog box. 

 

Defining a Theme with Specific Conditions 
After a thematic presentation has been created, the thematic features associated with that thematic 
presentation must be defined. 

To define a theme:  
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1. Highlight the relevant thematic presentation in the All thematic presentations dialog box, and click the 
Details button. 

 

2. The Thematic Presentation Details dialog box opens. Highlight the relevant thematic presentation, and 
click the Add button. 

 

3. The Theme Creation dialog box opens. Auto Theming will automatically set the color of each attribute. 
To “auto theme”, select the Auto Theme check box, and then select the Auto Theming attribute from 
the Class drop-down menu. 

Note: When Auto Theme is selected, the Colour and Layer fields will be grayed out. 
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4. spatialNET gives the user the option of either “auto theming” or manually selecting the theme attibute. 
If you wish to control the way the colors and layers associated with a theme are applied to different 
values of the attribute being themed, DO NOT select Auto Theme when creating the theme. Complete 
the Colour and Layer fields, and click Add. The newly created theme should now be visible in the 
Thematic Presentation Details dialog box. 

Note: The color in the Colour field must be an AutoCAD named color. 

AutoCAD Color Value 

Red 1 

Yellow 2 

Green 3 

Cyan 4 

Blue 5 

Magenta 6 

Black 7 

Gray 8 
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You can now see the new Presentation Details under the Themes.  

Specifying Theme Conditions 

1. To specify the conditions that must be satisfied to apply the theme, select the theme in the Thematic 
Presentation Details panel and click Edit Conditions. 

 

2. The Add/Edit/Delete Theme Queries panel opens. This lets you select an attribute you wish to test, a 
test operator, and a test value. Select the test you wish to perform and click Add. This adds the query to 
the set of conditions that an entity must satisfy to become a member of the theme. 

3. In the following example, we set the attribute Size of Cable with the logical operator of >= and an 
operator of 144. Using this condition, only cables that are greater than or equal to a fiber count of 144 
will meet the new condition. 

Note: The Attributes that appear as choices will vary depending upon which Object Class you chose 
earlier. It will take some practice to learn which classes contain certain attributes. 
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4. Click Add and then click Save. 

 

5. You can add as many tests as you wish to define the conditions of the theme. If multiple conditions are 
specified, they are combined using the logical AND operator. When you have configured the conditions 
you require, click Save (if you do not do this, the conditions will not be saved). 

6. Click Close to close the panel. 

 
When conditions have been added to a theme, they are displayed in the Thematic Presentation Details 
dialog box, as shown below. 
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Using or Disabling a Thematic Presentation 

Using a Theme 
To use a theme (that is, apply its coloring settings in a spatialNET view), click the Use Theme button on 
any of the Thematic Presentation panels. The next time a spatialNET OSP view is created, the theme will be 
applied (note that thematic mapping does not apply to inside plant views in the current release). 

 

Removing a Theme 
To remove the theme from the view, click the Disable Theme button on any of the Thematic Presentation 
panels. The next time a spatialNET OSP view is created, the theme will be applied. 

Note: You must explicitly refresh the spatialNET view, or create a new view, for the theme to be applied. It 
will not automatically apply to the currently active view until it is refreshed. 

Editing a Thematic Presentation 

1. To edit a thematic presentation, select spatialNET > View > Thematic Mapping from the menu. This 
opens the All thematic presentations dialog box. 

2. Highlight the thematic presentation to be edited, and click Edit. 
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The Thematic Presentation Modification dialog box opens, allowing you to only change the name of the 
Thematic Presentation. 

3. Make the required changes, and click the Apply button. Click the Close button to close the Thematic 
Presentation Modification dialog box. 

 
The modification should now be visible in the All thematic presentations dialog box. 

Note: To change the colors or conditions in which the thematic presentation appears, open the Details 
and Edit the Theme. 

Editing a Theme 

1. To edit a theme, select spatialNET > View > Thematic Mapping from the menu. The All thematic 
Presentations dialog box opens. 

2. Highlight the thematic presentation associated with the theme you wish to edit, and click Details. 

 
The Thematic Presentation Details dialog box opens. 

3. Highlight the theme you wish to edit, and click Edit . 
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The Theme Modification dialog box opens. 

4. Make the required changes, and click Apply.  

5. Click Close to close the Theme Modification dialog box. 

 

Editing or Deleting Specific Conditions 

1. To edit or delete specific conditions associated with a theme, select spatialNET > View > Thematic 
Mapping from the menu. The All thematic presentations dialog box opens. 

2. Highlight the thematic presentation associated with the specific conditions you wish to edit, and click 
Details. 
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3. The Thematic Presentation Details panel opens. Expand the Themes branch to display the 
Conditions. The process of changing (or editing) a condition involves adding a new condition, and 
then deleting the old one. 

4. To edit a condition, highlight Conditions, and click on Edit Conditions. 

 
The Add/Edit/Delete Theme Queries dialog box opens. 

5. To change the existing condition, click once on it to select it, then change the parameters. Press Save 
when finished. 

 

6. You can also add new conditions. Enter the new condition, and click Add. Click the Save button to 
close the panel. The new condition should now be visible in the Thematic Presentation Details dialog 
box. 

7. To delete a condition, highlight the condition to be deleted in the Thematic Presentation Details dialog 
box, and click Delete. 

 
The condition should now no longer be visible in the Thematic Presentation Details dialog box. 
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Deleting a Thematic Presentation 

1. To delete a thematic presentation, select spatialNET > View > Thematic Mapping from the menu. 
The All thematic Presentations dialog box opens. 

2. Highlight the entity to be deleted, and click Delete. 

 

3. Click the Confirm button. The deleted thematic presentation should no longer be visible in the All 
thematic presentations dialog box. 

 

4. Alternatively, thematic presentations can also be deleted from the Thematic Presentation Details dialog 
box by highlighting the relevant thematic presentation, and clicking Delete. 
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Note: When you delete a thematic presentation, you also delete the themes associated with the thematic 
presentation. If you just wish to delete the theme associated with a thematic presentation, see Deleting a 
Theme. 

Deleting a Theme 

1. To delete a theme (without deleting the thematic presentation associated with that theme) select 
spatialNET > View > Thematic Mapping from the menu. The All Thematic Presentations dialog box 
opens. 

2. Highlight the relevant thematic presentation associated with the theme, and click Details. 

 
The Thematic Presentation Details dialog box opens. 

3. Highlight the theme to be deleted, and click Delete. The Entities being deleted dialog box opens. 
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4. Click Confirm. 

 
The deleted theme should no longer be visible in the Thematic Presentation Details dialog box. 
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User Management Logon and 
Security 

Logging In to spatialNET 
To start a spatialNET session: 

1. Double-click the spatialNET icon on the desktop. The availability and appearance of this icon will 
depend on how spatialNET was installed on the system, but normally looks like this: 

 
Notes: 

• Do not select spatialNET Desktop, Job Administrator or Batch Queue. These will not give you access 
to the map data and are used only for administrative purposes. 

• Alternatively, you can start a session by locating the command to run spatialNET under the Start > 
Programs menu. 

• Although it is possible to run more than one session at a time on any given machine, this is not 
recommended. It uses up system resources and each new spatialNET session will use a spatialNET 
license. 

2. When the login window opens, Username is filled in. Be sure to change this to your current username. 
If you do not have a username, contact your system administrator. 
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3. Enter your password. 

4. In the database field, use the drop down to open the list of all available databases. This list is generated 
from *.ini files in the dbms folder of your local spatialNET installation. 

5. Press Logon to start spatialNET. 

• If your username and password are correct, spatialNET starts and the Job Selection window opens. 

• If your username or password are not correct, a "No Such User" message is displayed. You can then 
re-type your username and password. 

Logging Off spatialNET 
To exit spatialNET, select File > Close or just press the X in the upper right corner of the program. If 
prompted to save your changes for each drawing, choose No unless you have CAD objects that have been 
created or modified. All spatialNET modeled entities have already been saved to the database. 

Changing Your Password 
Once you have logged into the program, select spatialNET >Administration > List Users from the menu. 
A window listing all users opens. 

1. Locate your username and click once to select it. 

2. Click Edit and then select Password. 
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3. Enter your old password, then enter your new password twice. Press OK.  
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Creating a User 

Once you have logged into the program, select spatialNET > Administration > List Users from the menu. 
A window listing all users opens. 

1. To add a new user, click the New button.

 
The User Creation window opens.

 

2. Complete the following fields: 

• User name – This is commonly created with the first initial followed by the last name. 

• Password – Enter this twice. 

• Real Name – Enter full name of the user. 

• Tools Access – There are four preset toolbars and menu configuration files that come with 
spatialNET: Query Only, Read/Write, Supervisor and Administrator. Each is set up to match a 
specific preset Security Group level of access. For instance, the Query Only security group does not 
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have the right to create, edit, or delete any objects, so the Query Only Tools Access will leave off all 
menu commands and buttons for creating, editing, or deleting. 

• User Type – This is only a label and does not impact security rights. You can leave this field at the 
default entry. 

• Security Group – There are four preset Security Groups within spatialNET that correspond to the 
four levels of Tools Access. You can create more if necessary. Even if a user is given full access to the 
menus and buttons, the Security Group will override these rights and restrict the user as specified. 

• Plant Owner – If plant owners have been created, you can add up to three owners to this user. ISP 
entities can be restricted to plant owners only. If you are not using this restriction in the Security 
Group, leave this as No Owner. 

• Active Account – Set all new accounts to Active Account –Yes. When the user leaves the company, 
you can switch it to Active Account- No. If a user has created jobs, you should not attempt to delete 
the user because that information is removed from the Job History, making it impossible to tell who 
created the job. 

3. Click Apply when finished. The new user will appear in the All Users list. 

Deleting a User 
When a user no longer requires access to spatialNET, their account should be deactivated. User accounts 
are rarely deleted from the system. If the user has created and posted jobs, when his user account is deleted 
the job will lose this information. Instead, user accounts should just be changed to inactive so this history is 
not lost. 

1. Once you have logged in, select spatialNET > Administration > List Users from the menu. A window 
listing all users opens. 

 

2. Click the Edit button and select User. 

3. Select the No option in the Active Account section. 
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4. Click Apply and then Close. 

User Security 
There are multiple ways to limit access to spatialNET. You can limit access to certain tools and functions, 
and then further limit access to different entity types in spatialNET. 

Security Groups 
Security Groups can be used to restrict access to menus and entities within spatialNET. It is recommended 
to spend some time analyzing your current user groups and allocating rights as necessary. 

Note: This feature can also be accessed from the spatialNET Job Administrator. 

Select spatialNET > Administration > List Security Groups. If you don’t see the List Security Groups 
option, contact your system, administrator. 

 
There are four preset Security Groups within spatialNET: 

• Administrator – Users may perform all functions within the system. 

• Query Only – User may retrieve data within the system but may not change any records. This is ideal 
for a quality role. 
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• Read/Write – User may retrieve, create, modify, and delete records within the system but cannot 
change the system configuration. 

• Supervisor – User has read/write permissions and can change the system configuration. 

Each of these groups have preset menu configurations so the user will not see menu options that they don’t 
have access to. 

It is recommended that you review these security groups and compare them to your current users and 
security policy. 

Creating a Security Group 

1. Select spatialNET > Administration >List Security Groups from the menu. If you don’t see the List 
Security Groups option, contact your system, administrator. 

2. Click New. 

 
The Security Group Creation window opens. 

3. In the Security Group field, enter a name for the new group of users. 
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There are three tabs of options. 

4. On the General tab, select the appropriate check boxes for each entity, as follows: 

• You can choose to allow Add, Edit, Delete, or View options for each of the entity types by selecting 
the appropriate check boxes. 

• If you want all rights for an entity, select the All check box to the left of the entity. 

For example: 
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5. Select the Specific tab to open it, and select the appropriate check boxes to modify the user rights that 
manage workflow, as described below. 

 
• Create – Allow the user to create new jobs. 

• Verify – Allow users to verify whether a job will have conflicts if you try to post it. 

• Publish – Allow the user to publish jobs at any time. 

• Queue Publish – Allow a user to send a job to the queue to be published after hours. 

• Post – Allow a user to post jobs at any time. 

• Queue Post – Allow a user to send a job to the queue for posting after hours. 

• Cancel – Allow a user to cancel a job at any time. 

• Queue Cancel –: Allow a user to send a job to the queue for cancelling at any time. 

• Reset – Allow a user to reset a job. This is an important function if the program does not close 
properly. 

• Re-assign – Allows a user to assign the job to a different user. This requires the use of the Job 
Administrator. 

• Undo for Entity – Allows a user to undo their actions. 

• JMS Cleanup – Allows a user to permanently delete items that have been set for Removed in other 
jobs This requires the Job Administrator to complete. 

• Edit – Allows the user to use the Job Administrator to edit the details of a job. 

• Query – This allows a user to query all jobs in the database. 

• Resolve Conflicts – This allows a user to use the Job Administrator to resolve conflicts between 
jobs. 
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• Batch Queue – This allows the user to modify the batch queue (when jobs should run). 

• Pessimistic Locking – This allows the user to change from pessimistic locking to optimistic locking 
on a job. 

• CAD Scrape or View – This allows a user to scrape CAD entities into the database or simply view 
the CAD entities. 

6. Select the ISP tab of the Security Group Creation. This tab changes the access to ISP entities within 
spatialNET. 

 
• Select check boxes as appropriate, or 

• You can select the Inside Plant check box at the top to modify all of these rights as one. 

7. Once the rights are assigned, click Apply. 
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Tools Access 
There are four preset .cui files in spatialNET for menu and toolbar configuration. Each is shown below. 

Query Only 

 

Query Only is a scaled-down version of the regular toolbars. The buttons that allow access to create, edit, or 
delete objects are gone. In addition, the Add option is removed from all the menus. 

Read/Write 

 

Read/Write allows access to create and edit any object in spatialNET. Only the administrative functions are 
not present. 

Supervisor 

 

Supervisor access is very similar to Administrator, the only exception is that Supervisor access does not 
include the full ability to configure the system. 

Administrative 

 

All tools and menus are present in the Administrator Tools Access option. 

  

To create your own *.cui file, see Creating Shortcut Keys. 
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Creating a User Type Definition 
The User Type definition works only as a label for the type of user. It does not have any features to restrict 
or allow access to buttons or menus. To change user access, refer to Security Groups. 

To create a new User Type Definition, use the following steps: 

1. Select spatialNET > Dictionaries > Other Definitions > User Definitions from the menu. The User 
Definitions dialog box opens. 

2. Click Add to add a new User Type. 

 

3. Complete the following: 

• Select the Definition Status option, Available or Obsolete. Select Obsolete when that user type is 
no longer to be used. 

• Enter a User Type and a Description. 

 

4. Click Add. 

You can return to the User Definitions page and Edit or Delete the entry. 
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Miscellaneous 

Dictionaries 
The dictionaries in spatialNET are set up and maintained by the administrator, and are accessible from the 
spatialNET menu. They are also used when drafting the network to select equipment, building types, etc. 

 

References 

Document References 
spatialNET provides the capability for attaching references to files, programs, websites, URLs, etc., to any 
object in the system. This can be useful for making all the information associated with an object or job 
easily accessible from one place. 

Important: The spatialNET database only stores a reference to the document, and not the document 
itself. If the filename or path changes, the reference will no longer be valid. 

Attaching a Document Reference 
To attach a reference to an object: 

1. Click on an object to select it. 
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2. Click the Details  button on the General toolbar. 

 

3. Click Ref Docs and select Add Document from the shortcut menu. 

 

4. Enter a Document Title and then browse for the Document File Name. 

5. Click Add; then click Close. 

The document reference should now be visible in the Site (OSP) Details dialog box. 

 
 

Deleting a Document Reference 
To delete a reference to an object: 

1. Select the object by clicking on it. 
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2. Click the Details  button on the General toolbar. 

 

3. Highlight the reference to be deleted and click on the Delete button. This displays the Entities Being 
Deleted dialog box, shown below. 

 

4. Click Confirm. The deleted document should now no longer be visible in the Site (OSP) Details dialog 
box. 

Line Capture Controls 
For linear features, you can change the Cable Segment Type and the Segment Strand Length values You 
can also change the offset capture mode (refer to Offset) or undo the line capture (click Back). Click Done 
when finished. 
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Shows/Hides the Create dialog box. Hiding this panel during graphical drafting operations 
makes more of the map window visible. 

 
(Vertex on 

command line) 

Vertex Mode. This allows direct drafting of each vertex of the fiber line. Normal AutoCAD 
precision drafting aids (ORTHO, SNAP, POLAR, TRACK, etc.) can be used. 

 
(Offset on 

command line) 

Offset Mode. This will automatically add segments to the line which are offset from 
existing linework. To use: 

Click on the line to offset from. It will change color when selected. 

1. Click on the side of the line to offset to, at the offset distance. 

2. Move the mouse to track along the linework. The system will offset the line as you move 
the mouse. It will automatically continue to offset along abutting line segments. 

3. If the original linework ends, or reaches an intersection where more than 2 lines abut, 
select the line to continue offsetting along by clicking on it. 

 
(Gcopy on 

command line) 

Graphics Copy mode. This will automatically add vertices to the line you are capturing by 
copying all the vertices and bulges (arc segments) from existing linework. In Gcopy mode, 
click on an existing line or polyline to append its entire geometry to the line being created. 

 
(Back on command 

line) 

Back button. This undoes capture of pervious vertex. 

 

 
(LClose on 

command line) 

Close or Done button. 
Close applies to closing a polygon by adding the last vertex at an identical position to the first 
vertex, and completes capture of the polygon. 
Done applies to linear features, and completes capture of the line. 

 
(Cancel on 

command line) 

Cancel button. This button terminates capture and cancels creation of new cable. 
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Linear Edit Modes 
Manipulators provide many different ways of editing linear geometry. Linear manipulators are controlled by 
the Manipulator Edit Modes dialog box. 

To open the Manipulator Edit Modes dialog box: 

1. Select the spatialNET > Linear Edit Modes from the menu. 

 

5. You can select the Manipulator Edit Mode from the following options: 

• No Manipulators – Selecting this option removes the manipulators from the map view. 

 
• Default Mode – This option displays the manipulators on the map view. 

 
• Edit bulges – Selecting this option places an additional manipulator (displayed in red) in between 

the default manipulators. Clicking and dragging a red manipulator “bulges” a line segment allowing 
polylines to include curved arcs. 

Edit a bulge as follows: 
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i. Click and drag a red manipulator. 

ii. When the desired curvature is achieved, left-click the mouse, and then click on the pop-up, as 
shown below. 

          
• Edit Vertices – Selecting this option places an additional manipulator (displayed in blue) in 

between the default manipulators. Clicking and dragging a blue manipulator inserts a vertex into an 
existing line segment. 

To insert a vertex into an existing line segment: 

i. Click and drag a blue manipulator. 

ii. When the desired line shape is achieved, left-click the mouse, and then click on the pop-up, as 
shown below. 

    

 
• Rotate Entity – Selecting this option enables the user to rotate the boundary about its centroid. 

The user can either manually rotate the boundary, or else specify the rotation angle by typing in the 
desired number. 
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To rotate an entity, do ONE of the following: 

• Click and drag a manipulator. When the desired rotation is achieved, left-click the mouse, and 
then click on the pop-up, as shown below; or 

• Click on a manipulator and left-click. A pop-up appears. Type in the desired angle of rotation 
(in degrees), and press Enter. Click on the pop-up, as shown below. 

     

• Translate Entity – Selecting this option enables the user to move the entire boundary to a new 
location without changing its shape, scale, or rotation. 

To translate an entity: 

i. Click and drag a manipulator.  

ii. When the desired location is achieved, left-click the mouse; then click on the pop-up. 

   
• Reshape Entity – Selecting this option places an additional manipulator (displayed in red) in 

between the default manipulators, enabling the user to reshape the boundary. When a red 
manipulator is clicked and dragged, the Line Capture Controls dialog box opens, allowing the line 
segment to be replaced by a new set of segments captured using the tools on the line capture dialog 
box. 

To reshape an entity: 

i. Click and drag a red manipulator. 

ii. Enter the desired data into the Line Capture Controls dialog box. 
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• Orthogonal Line – Orthogonal lines are not used in spatialNET design. 

Nodal Placement 
This feature is used to align structures with an existing line. For instance, when drafting support structures, 
there is often a rule that they must be placed a certain distance from a street edge. The Nodal Placement 
feature allows you to place objects at a pre-set distance form a chosen entity. 

Note: Set the Placement type before you begin to place structures. 

1. Select spatialNET > Nodal Placement from the menu. 

 

2. Select the appropriate Placement Type option, as follows: 

• Direct – Default setting. The object will be placed wherever you click on the map. 

• Direct Aligned – Places the object in the direct location that you select and the alignment is the 
rotation of the object. For example, if you wish to align all support structures with the road edge, 
you would choose the support structure to add. One click would pinpoint the XY coordinate for the 
object, the command prompt would then prompt you for input for an object to align with. Click on 
the object on the map (such as a road edge) and the object will have the same angle as the line. 

 
• Direct Aligned with – Adds the object directly where you enter it and aligns with a line or 

boundary (any selected linework). The procedure to add the object is the same as Direct Aligned. 

• Aligned – This will place an object directly on the chosen line and align the object with the line. 

• Aligned with Displacement – Same as Aligned, except the Offset feature allows you to select a 
pre-set distance from an object. There are six preset levels: 0-6. The example below shows six poles 
created using each different offset level, 0-5 from left to right. 
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• Aligned Bisecting Corner – Aligns the splice case at an actual or implied intersection, based on two 
different boundaries (linework) you select. 

Note: Be sure to set this back to Direct when you are done placing objects. 

Offset 
When drafting, you may wish to have your fiber cables mimic pre-existing structures on the map, such as a 
road edge. spatialNET can automatically trace an arc at a specified offset, using the offset mode on the Line 
Capture Control dialog box. To start this process, let’s add a fiber cable (or any line type). 

1. Once the line has started left-click once to place the first vertex. 

 

2. Change to Offset capture mode by clicking on the Offset button on the Line Capture Controls dialog 
box. 

3. Click on the line you will be offsetting from (in this case, the road edge). The color changes to cyan. In 
the figure below, the cross hair is placed on the road edge. The road edge is cyan to designate that it has 
been selected while the cross hair is red. 
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4. Click on a point to establish an offset side and distance for the offset segment. This is best achieved by 
clicking on the last point you captured in the line segment (i.e., move the cross hair back to the point 
where you left-clicked to place the vertex). 

5. The system now allows you to smoothly track around the arc drawing a curved segment at the specified 
offset distance. In the figure below, the cyan line is the road edge you are copying and the black line to 
the right of it is the fiber we are placing. When you reach the position where you will begin entering 
straight segments again, left-click to add the end vertex of the curved segment, as shown below: 

 

6. To exit Offset Tracing mode, click the cross-hair button on the Line Capture Control dialog box. Now 
you can continue your line by placing vertices with left-clicks. If you wish to restart the offset, repeat 
the previous steps. 
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Updated RF Cable Documentation 
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RF Overview 

RF functionality in spatialNET encompasses network design, maintenance, tracing and reporting.  

• RF networks can be drafted manually or by using spatialNET's automated design functionality. See 
Designing an RF Network. 

• RF equipment can be added, annotated, edited, replaced, and deleted.  
• RF equipment can be attached to or detached from support structures.  
• Numerous network reports are available, including device counts for power supplies, active devices, and 

passive devices; a Bill of Materials report; equipment details; and connectivity reports.  
• RF tools provide information on power levels and display alerts regarding signal levels, power levels and 

equipment profiles.  
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RF Design 

The RF Toolbar 
RF tools are available in the spatialNET menu options or in the RF toolbar, shown below.  

  

Button Name Function 

 

Add Node Adds an RF node. 

 

Add Active Device Adds an RF active device (e.g., amplifier). 

 

Add Passive Device Adds an RF passive device (e.g., splitter). 

 

Add Tap Adds an RF tap box. 

 

Add Device 
Component 

Adds an RF component to a device (e.g., 
equalizers, pads). 

 

Add Power Supply Adds an RF power supply. 

 

Add RF Cable Adds an RF cable. 

 

RF Level Tool Runs the RF Leveling tool. 

 

RF Power Tool Runs the RF Power tool. 

 

RF Network Tool Runs the RF Network report. 

 

RF Power Report  Runs the RF Power Report for a selected 
power supply. 
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RF Multi Edit Displays the RF multi-edit panel. 

 

RF Auto Alert Runs the RF Auto-Alert tool. 

 

RF Replace 
Increase 

Replaces the selected device with the next 
available device. 

 

RF Replace 
Decrease 

Replaces the selected device with the 
previously available device. 

 Designing an RF Network 
spatialNET offers two ways to design an RF network:  

• As-built: A reflection of the current state of network construction allowing updates to be made 
directly to the map. When designing an as-built network, users select the starting piece of 
equipment and associated port, then manually select each piece of equipment to be added to the 
network. See Adding an RF Cable. 

• Automated design: First-time design of a network utilizing spatialNET's functionality to determine 
tap values and amplifier locations; allows for quick designing and easy power calculations. 
Generally, this method of designing can begin at any RF device on the map. See Adding an RF Cable. 

Using either method, complete the following tasks before adding an RF cable to the map: 

• Compile and add landbase information to the map. 
• Design the support structure system. 
• Associate support structures to addresses. See Associating RF Support Structures to Addresses 
• Ensure that the RF dictionary and design profiles have been created. 
• Associate an RF design profile to the job. See Changing the RF Profile of the Current Job. 

In addition, for optimal design results, SPATIALinfo recommends that your spatialNET workspace include a 
large viewable design area. 

Designing an RF network includes the following tasks: 

• Adding an RF Node 
• Adding an RF Cable 
• Adding an RF Active Device 
• Adding an RF Passive Device 
• Adding an RF Power Supply 
• Adding an RF Tap 
• Associating Taps to Addresses 
• Editing Signal Levels 

Changing a Design Profile 
All RF design is based on an RF design profile. An RF design profile is linked to a specific frequency set; 
equipment is assigned at those frequencies, and losses are documented for each piece of equipment at those 
frequencies. The frequency sets specify the forward and return frequencies allowed.  
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Using the correct design profile is critical when designing a network: 

• The design profile in use lists only those devices associated to it. Devices not associated to the 
profile will be unavailable during the design process. 

• RF alerts are set in the design profile. 

If devices are added to the map under the wrong design profile, the design profile must be changed and the 
design profile for those devices must be changed. Use the following procedures to perform these tasks. 

To change the RF profile of a current job: 

1. On the spatialNET menu, click Administration. 

2. Click Change Profile of Current Job. 

3. Select the appropriate design profile from the RF Design Profile list. 

 

4. Click Apply to apply the new design profile to the job, or click Close to cancel the process if the design 
profile is already correct. 

Note: All devices added under the previous design profile remain part of that design profile unless they are 
added to the new profile. Any newly added devices will use the new design profile. A job can contain 
multiple design profiles. 

To change the RF design profile for a single device: 

1. Select the device. 

2. Click on the Details   button. 

3. Select the Edit; the select Edit from the next menu. 

4. Select the appropriate design profile. 

5. Click Apply. 

Simultaneously changing the design profile of multiple devices 
 To simultaneously change the design profile of multiples devices, follow steps 1-8. 

 To change the design profile of a node, first select the node boundary; then follow steps 3-8. 

1. On the General toolbar, click the single selection  button to switch to multiple selection  mode.  

2. On the map, select all appropriate objects. 

3. In the RF toolbar, click on the Multi Edit  button. 
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4. In the Multiple RF Device Modification dialog box, review the devices in the RF Devices to update 
list. 

 

5. (Optional) To view the details of a particular device, select it in the list and click the   button. 

6. (Optional) To delete a device that should not be included in the list, select it and click the  button. 
The Device Counts by Type value for that device type will lower accordingly.  

7. When all devices are correctly listed, select the new RF design profile. 

8. Click Apply. 

Adding Equipment 

Adding a Component to an RF Active Device 
Components used in the RF network include pads, equalizers, and splitters. Pads and equalizers are used 
for signal unity gain; splitters add additional Out ports to an RF active device. 

Generally, RF active devices are configured with one In and one Out port. When another component is 
added to the device, additional ports can become available. 

See Defining RF Device Components and Defining RF Device Component Ports. 

To add a component to an RF active device: 

1. Select the appropriate RF active device on the map. 

2. Click the Details   button. 

3. In the RF Active Device Details dialog box, click Add; then click Add Component. 
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4. Complete the fields in the RF Device Component Creation dialog box as outlined in the table below. 

Field Entry/Description 
Component Class Select the appropriate component class.  

Component Type Available selections are based on the component class. 

Component Name Automatically populated based on the selected component type. Update if 
necessary. 

Check for duplicates Select the checkbox to have spatialNET search for duplicates of the component 
name.  

Auto increment Select the checkbox to have spatialNET automatically increase the number 
associated to the name field.  

Component Signal Path Select the signal path direction. 

5. Click Add. 

6. Perform updates to the RF levels as needed and click Update, or click Close if updates are not 
necessary. 

 

Adding an Equalizer to a Tap 
An equalizer is added to a tap to adjust the return signal. All components must be set up in the dictionary 
before these procedures can be completed. 
To add an equalizer to a tap: 

1. Select the tap and click on the Details   button. 

2. In the RF Tap Device Details dialog box, click Add; then click Add Component. 

3. Complete the fields in the RF Device Component Creation dialog box as outlined in the table below. 

Field Entry/Description 
Component Class Select Equalizer. 

Component Type Select the required equalizer value. 

Component Name The name is populated from the dictionary. 

Component Signal Path Select Return since the tap equalizer adjusts the return signal. 

4. Click Add; then click Close. 
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5. In the RF Tap Device Details dialog box, expand Components to view the equalizer. 

 

6. Repeat steps 1-5 to add additional equalizers. 

Tap equalizers are counted in the Bill of Materials Report. 

Adding an RF Active Device 
Active devices add signal to the network and include: 

• Amplifiers 
• Line extenders 

Active devices can be added directly on the map or inserted into an existing RF cable. 

To add an active device directly on the map: 

1. Click the Clear Selection  button to ensure nothing is selected on the map. 

2. On the RF toolbar, click the Add Active  button. 

3. In the RF Active Device Creation dialog box, complete the fields as outlined in the table below. 

Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF active types 

listed in the current RF design profile are included in this list. 

Number of Ports 
Automatically populated per the dictionary and cannot be edited.  

Equipment Name Enter the name of the equipment.  

Check for duplicates Select the checkbox to have spatialNET search for duplicates of the equipment 
name.  

Auto increment Select the checkbox to have spatialNET automatically increase the number 
associated to the name field.  
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Field Entry/Description 
Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels in 
the connected network.  

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. 
Can be adjusted to resize the device in a congested area of  the map. For 
example, enter .5 to decrease the symbol by half or enter 2 to double the symbol 
size. 

4. Configure optional fields in the RF tab. 

Field Entry/Description 
RF System Type Select the system type.  

Construction Type Options are populated from dictionary entries.  

Construction Status Select the appropriate construction status, which determines the layer, color, 
line type, and other display attributes for the active device. 

Cascade Number Enter the number in downstream device sequence from the node. 

Node Id Enter the ID of the associated node for this active device. 

Power Supply ID Enter if known. Will be automatically populated after power calculations. 

5. Values for each field in the Device have been established in the dictionary. You can change these values 
for a one-time load level test. See Using the RF Power Tool. 

6. Click Add (making sure you are in placement mode). 

7. Left-click on the map to activate the map view to show the placement cursor. 

8. Position the placement cursor on the location for the active device; then click to add the device to the 
map. 

 

9. After the device appears, click Close on the RF Active Device Creation dialog box.  
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To insert an active device into an existing cable: 

1. In the map view, click on the desired RF cable to select it. 

2. Click the Details   button. 

3. In the RF Cable Details dialog box, click Edit.  

4. Click Insert, then Active. 

5. Complete the fields in the RF Active Device Insertion dialog box as outlined below: 

 Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF active types listed in 

the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the equipment.  

Check for duplicates Select the checkbox to have spatialNET search the entire database, including any 
current jobs, for duplicates of the component name. 

Auto increment Select the checkbox to have spatialNET automatically increase the number 
associated to the name field.  

Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels in the 
connected network.  

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. 
Symbol scale can be adjusted to resize the device in a congested area of  the map. For 
example, entering .5  decreases the symbol by half and entering 2 doubles the size. 

6. Configure the optional fields in the RF tab. 

Field Entry/Description 
RF System Type Select the system type.  

Construction Type Options are based on dictionary entries. Usually underground or aerial.  

Construction Status Select the appropriate construction status (Planned, Approved, Built), which 
determines the layer, color, line type, and other display attributes for the active 
device. 

Cascade Number Enter the number in downstream device sequence from the node. 

Node Id Enter the ID of the associated node for this active device. 

Power Supply ID Enter if known. Will be automatically populated after power calculations have been 
completed. 

7. The values for each field In the Device tab have been established in the dictionary. You can change 
these values for a one-time load level test. See Using the RF Power Tool. 

8. Click Select Pos. The map view activates and the cursor appears. 
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9. On the map, click where the active device is to be inserted. 

 

10. Use the regular cursor to control the location of the scissors cursor. The scissors cursor will snap to the 
RF cable. 

11. When the insertion point is positioned correctly, click to place the device. 

 

When using the automated design function to design RF cable, right-click to add an active device. 

To add an RF active device with the automated design function: 

1. Draft the RF cable. 

2. Right-click the map where the active device is to be placed. 

 

3. In the device menu, click Active. 
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4. Select the desired type of active device. 

 
If a warning message (shown in red, below) appears, use the information to make required adjustments 
to your design. (Manual adjustments may be necessary,) 

 

5. Continue drafting required equipment. 

6. When all drafting is complete, click Done to close the Line Capture Controls window. 

7. Edit the attributes to update the equipment name and other details of the device. See Editing an RF 
Active Device.  
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Adding an RF Cable 
See Designing an RF Network for details on the as-built and the automated design methods of network 
design.  

When using the as-built or automated design method of network design, complete the following tasks 
before adding RF cable to the map: 

• Compile and add landbase information to the map. 
• Design the support structure system. 
• Associate structures to addresses. See Associating RF Support Structures to Addresses 
• Create RF dictionary and design profiles. See Defining a Design Profile. 
• Associate an RF design profile to the job. See Changing the RF Profile of the Current Job. 

In addition, for optimal design results, SPATIALinfo recommends that your spatialNET workspace include a 
large viewable design area. 

Adding cable using the as-built method 

When drafting an as-built network, select the starting piece of equipment and associated port, then 
manually select each piece of equipment to be added to the network. 

 To select the cable starting point: 

1. Click once on the node (or other RF device) to select it. 

2. Click on the yellow circle indicating the correct port. 

 
The selected port turns orange, as shown below (port B). 
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Note: If the node is selected but a port has not been specified, you will be prompted to select a starting 
port. 

 

3. In the RF Cable Creation dialog box, select Estimate from Strand in the Design Length Control 
section.  

 

4. In the Line Capture Controls dialog box, be sure the Auto Tap box is not checked. (The assumption is 
that the as-built support footages have already been updated.) 
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5. Use right-click menu options to add RF network devices. For details, see: 

• Adding an RF Active Device 
• Adding an RF Passive Device 
• Adding an RF Tap 
• Adding an RF Power Supply and Power Inserter 
• Adding an RF Cable 

 To add an RF cable using the automated design function: 

1. Select the port on the starting device to begin drafting. 

2. Click the Add RF Cable  button. 

3. Complete the fields In the RF Cable Creation dialog box as outlined in the table below. 

Field Entry/Description 
Close add panel after line 
capture 

Select to close the Add RF Cable window after drafting.  

Cable Type Select the cable type from the list. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. 
Symbol scale can be adjusted to resize the device in a congested area of  the 
map. For example, entering .5 decreases the symbol by half and entering 2 
doubles the size. 

RF System Type Select the system type. 

Construction Type Options are based on dictionary entries. 

Identifier Type Codes Click the Edit button to open a list of various types of codes contained in the 
dictionary (e.g., bar codes, SKU numbers) for inventory tracking. Select the 
appropriate code and click Done in that list box. The selected code will appear 
in Details. 

Design Length Control Estimate From Strand: Select if footages are already part of the support 
structure in place. 
Estimate From Model: Select if support structures are present but footages are 
not included, or for a quick test with no route present. 
Manual Override: Select to change footage when all structures are in place. 

Prompt for ducts Select the checkbox to assign the cable to an existing duct. A popup window 
allows you to select the specific duct. 
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4. Click Add. 

5. In the Line Capture Controls dialog box, check the Auto Tap box. 

 
Areas indicated by the circled letters in the above illustration provide additional information as 
described below: 

a. Output levels of the starting device 

b. Graphic display of forward slope crossover calculations 

c. Running display of forward levels 

d. Running display of return levels 

6. Right-click on the footage or strand to begin placing the cable. 
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7. To continue the automated design process, see also: 

• Adding an RF Node 
• Adding an RF Active Device 
• Adding an RF Passive Device 
• Adding an RF Tap 
• Adding an RF Power Supply and Power Inserter 

Adding an RF Node 
An RF node can be added to the map or to an existing optical node. Both RF and fiber nodes are contained 
inside a node site that is defined separately from the RF and fiber nodes. In spatialNET, the RF node is a 
separate piece of equipment from the fiber portion of the node.  

To add an RF node to a map: 

1. Click the Clear Selection  button to clear any selections from the map. 

2. Click the Add RF Node button, or from the RF menu, click Add and then Node. 

3. Complete the fields in the General tab of the RF Node Creation dialog box as outlined in the table 
below. 

Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF node types listed in 

the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited. 

Equipment Name Enter the name of the node. 

Check for duplicates Select the checkbox to have spatialNET search the entire database, including any 
current jobs, for duplicates of the equipment name. 

Auto increment Select the checkbox to have the system automatically increase the number associated 
to the name field.  

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in the 
connected network.  

Construction Status (for 
containing Site) 

Select the appropriate construction status, which determines the layer, color, line 
type, and other display attributes for the active device. 

Symbol Scale (for containing 
Site) 

If this field is left blank, the default value configured in the dictionary is used. Symbol 
scale can be adjusted to resize the device in a congested area of  the map. For 
example, entering .5  decreases the symbol by half and entering 2 doubles the size. 

4. The fields In the RF tab are optional.  

Field Entry/Description 
RF System Type Select the system type.  

Construction Type Options are based on dictionary entries.  

Power Supply ID Enter if known. Will be automatically populated after power calculations. 
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5. The values in Device tab are established in the dictionary. You can change these values for a one-time 
load level test. See Using the RF Power Tool. 

6. Click the Placement mode button if it is not already highlighted.  

 

7. Left-click on the map to activate the map view. 

8. Position the placement cursor on the location for the node; then click to add the node to the map. 

 

9. After the node appears on the map, click Close on the RF Node Creation dialog box.  

Adding an RF node to an existing optical node 

spatialNET manages a node as single location (OSP site) containing two separate devices: an RF node and 
an optical node. The RF and optical nodes are joined to connect the RF buss ports with the optical ports.  

To add an RF node to an existing optical node: 

1. On the map, highlight the appropriate optical node site. 

 

2. Click the Add RF Node button, or on the RF menu, click Add and then Node. 

3. Complete the fields in the RF Node Creation dialog box (shown below the following table) as follows: 

Field Entry/Description 

Equipment Type Select the appropriate type of equipment from the list. Only RF node types 
listed in the current RF design profile are included in this list. 

Number of Ports Automatically populated and cannot be edited. 

Equipment Name Enter the name of the node, which must be identical to the name of the 
fiber node. 

Check for duplicates Select the checkbox to have spatialNET search the entire database, 
including any current jobs, for duplicates of the equipment name. 

Auto increment Select the checkbox to have the system automatically increase the number 
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Field Entry/Description 
associated to the name field.  

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels 
in the connected network.  

Construction Status (for containing Site) Select the appropriate construction status, which determines the layer, 
color, line type, and other display attributes for the active device. 

Symbol Scale (for containing Site) 

If this field is left blank, the default value configured in the dictionary is 
used. Symbol scale can be adjusted to resize the device in a congested area 
of  the map. For example, entering .5  decreases the symbol by half and 
entering 2 doubles the size. 

4. The fields In the RF tab are optional.  

Field Entry/Description 
RF System Type Select the  system type.  

Construction Type Options are based on dictionary entries.  

Power Supply ID Enter if known. Will be automatically populated after power calculations. 

5. The values in the Device tab are established in the dictionary. You can change these values for a one-
time load level test. See Using the RF Power Tool. 

 

6. Click the Placement mode button if it is not already highlighted.  

 

7. Click Add. 
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8. When prompted to add the RF node, confirm that the details are correct and click Yes. 

 

9. Click the Details   button to verify that both the fiber and RF nodes are listed under the Equipment 
heading in the Site Details window. 

 

10. Click Close. 

Adding an RF Passive Device 
Passive devices do not add signal to the network. They include: 

• Couplers 
• Power inserters 
• Power blocks 
• Terminators 

Passive devices can be added directly on the map or inserted into an existing RF cable. 

To add an active device directly on the map: 

1. Click on the Clear Selection  button to clear any selected objects on the map. 

2. On the RF toolbar, click the Add Passive  button. 
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3. Complete the fields in the RF Passive Device Creation dialog box (shown below the following table) 
as follows: 

Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF passive types listed in 

the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the equipment.  

Check for duplicates 
Select the checkbox to have spatialNET search the entire database, including any 
current jobs, for duplicates of the equipment name. 

Auto increment Select the checkbox to have the system automatically increase the number associated 
to the name field.  

Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels in the 
connected network.  

Construction Status 
Select the appropriate construction status, which determines the layer, color, line 
type, and other display attributes for the active device. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. Symbol 
scale can be adjusted to resize the device in a congested area of  the map. For 
example, entering .5  decreases the symbol by half and entering 2 doubles the size. 

RF System Type Select the system type.  

Through Current Not required. Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

Voltage at Device Not required. Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

4. Left-click on the map to activate the map view. 

5. Position the placement cursor on the location for the passive device; then left-click to add the device to 
the map. 

 

6. After the device appears on the map, click Close on the RF Passive Device Creation dialog box.  

To insert a passive device into an existing cable: 

1. In the map view, click on the RF cable to select it. 

2. Click the Details   button. 

3. In the RF Cable Details dialog box, click Edit.  
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4. Click Insert, then Passive. 

5. Complete the fields in the RF Passive Device Insertion dialog box as outlined in the table below. 

 Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF passive types listed in 

the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the equipment.  

Check for duplicates Select the checkbox to have spatialNET search the entire database, including any 
current jobs, for duplicates of the equipment name. 

Auto increment Select the checkbox to have the system automatically increase the number associated 
to the name field.  

Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels in the 
connected network.  

RF System Type Select the system type.  

Through Current Not required. Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

Voltage at Device Not required. Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

6. On the map, click where the passive device is to be inserted. 

 

7. Use the main cursor to control the location of the scissors cursor. The scissors cursor will snap to the 
RF cable. 

8. When the position is correct in the RF cable run, left-click to place the device. 
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When designing RF cable with the automated design function, you can add a passive device using right-
click functionality. 

To add an RF passive device using the automated design function: 

1. Draft the RF cable. 

2. Right-click on the map where the passive device is to be placed. 

3. In the shortcut menu, click Passive; then select the appropriate type of passive.  

 
The Out port signal levels appear in the Line Capture Controls dialog box. 

 
Note: If you are adding a coupler or device with multiple Out ports, design automatically begins with 
Out port 1 (through port). 
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4. To design from port 2 (tap port) click Done, click on the port, and add the cable. 

5. When drafting is complete, click Done to save all work and close the Line Capture Controls window. 

6. Edit the attributes to update the equipment name and other device details. See Editing an RF Passive 
Device. 

Adding an RF Power Block 
Although spatialNET provides several ways to add a passive device to the map, an RF power block is most 
commonly connected directly to the In port or Out port of the device that must be blocked. (A power block 
can also be inserted mid-span.) 

To add an RF power block to a device: 

1. Select the device. 

 

2. Click on the port where the power block is to be placed. 

 

3. On the RF toolbar, click the Add Passive  button. 
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4. Complete the fields in the RF Passive Device Creation dialog box as outlined in the table below. 

Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF power block types listed in 

the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the equipment.  

Check for duplicates Select the checkbox to have spatialNET search for duplicates of the equipment name.  

Auto increment Select the checkbox to have the system automatically increase the number associated to 
the name field.  

Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels in the 
connected network.  

Construction Status Select the appropriate construction status, which determines the layer, color, line type, and 
other display attributes for the active device. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. Symbol scale 
can be adjusted to resize the device in a congested area of  the map. For example, entering 
.5  decreases the symbol by half and entering 2 doubles the size. 

RF System Type Select the system type.  

Through Current Not required. Default value is defined in the dictionary. A value entered here will override 
the dictionary value. 

Voltage at Device Not required. Default value is defined in the dictionary. A value entered here will override 
the dictionary value. 

5. Click Add.  

6. Click Close before changing the rotation of the power block; otherwise, another power block will be 
added to the map.  

 

Adding an RF Power Supply and Power Inserter 
An RF cable network requires electrical power to run some of the network equipment. To connect an RF 
power supply into a cable network, an RF power inserter must be added first. A power inserter can be added 
to an active port on a node, coupler, amplifier/line extender, or cable.   

Nodes may already include a power port that allows a power supply to be attached directly to the node port 
without a power inserter.  
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To add an RF power supply 

1. Click the Add Power Supply  button.   

2. In the RF Power Supply Creation window: 

• Select the equipment from the Equipment Type list. 
• Select the status from the Construction Status list. 
• Select the system type from the RF System Type list. 

 

3. Click on the map to activate the map view. 

4. Click again to place the power supply on the map. 

Inserting an RF power inserter into an existing cable 

1. In the map view, click the RF cable to select it. 

2. Click the Details  button. 

3. Click Edit, then click Insert. 
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4. Click Passive. 

5. In the RF Passive Device Insertion dialog box: 

• Select Power Inserter in the Equipment Type list. 
• Enter the Equipment Name. 
• Select the RF System Type. 
• Click Select Pos. 

 

6. Click on the map to add the power inserter. The scissors cursor appears on the cable. 

 

7. Move the scissors cursor to the insertion point on the cable or to the port of the passive or active 
device. 

8. To begin placing the power cable, select the power supply and click the Add RF Cable button. 

9. In the RF Cable Creation dialog box: 

• Select the Cable Type. 
• Select the RF System Type.   
• Update the Cable Sag Factor and Slack Length as needed.  
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• Select the Design Length Control.  

• Estimate from Strand: Model and design lengths for each segment of RF cable will be 
determined by the associated support structure. 

• Estimate from Model: Model length will be based on the length of the segment on the map. 
• Manual Override: Length for the RF cable segment is manually defined. 

 

10. Click Add.   

11. Draft an RF cable from the power supply to the power inserter. 

Adding an RF power inserter onto a port 

1. Select the port on the network element.  

2. On the RF toolbar, click the Add Passive  button. 

3. In the RF Passive Device Creation dialog box: 

• Select Power Inserter from the Equipment Type list.  
• Select the status in the Construction Status list. 
• Select the system type from the RF System Type list. 
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4. Click Add to place the power inserter on the device. 

Adding an RF Tap 
RF taps are devices that connect the cable network to the premise. 

Taps can be defined in the dictionary using several naming conventions, two of which are shown below: 

 

(Under most circumstances, the manufacturer's naming convention is used.) 

The spigot number and tap faceplate value are important components of the naming convention.  

The terminating tap most commonly has the lowest tap value for a given spigot count.  

To add a tap directly on the map: 

1. If you are adding a tap to an existing device, go to step 2. 

If you are NOT adding a tap to an existing device, click on the map where the tap is to be placed and go 
to step 3. 
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2. To add a tap to an existing device, select the device onto which the tap will be placed. 

Note: If the device has multiple Out ports, you will be prompted to select a port. 

3. On the RF toolbar, click the Add RF Tap  button. 

4. Complete the fields in the RF Tap Device Creation dialog box as outlined in the table below. 

Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF tap types listed 

in the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the tap.  

Check for duplicates Select the checkbox to have spatialNET search the entire database, including 
any current jobs, for duplicates of the equipment name. 

Auto increment Select the checkbox to have spatialNET automatically increase the number 
associated to the name field.  

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in 
the connected network.  

Construction Status Select the appropriate construction status, which determines the layer, color, 
line type, and other display attributes for the active device. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. 
Symbol scale can be adjusted to resize the device in a congested area of  the 
map. For example, entering .5  decreases the symbol by half and entering 2 
doubles the size. 

RF System Type Select the system type.  

Number of Spigots Automatically populated from the dictionary and cannot be edited. 

Tap Value Automatically populated from the dictionary and cannot be edited. 

Through Current Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

Voltage at Device Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

5. Left-click on the map to activate the map view. 

6. Position the resulting placement cursor on the location for the tap; then click to add the tap to the 
map. 

 

7. After the tap appears, repeat steps 2-4 as needed to add additional taps, or click Close on the RF Tap 
Device Creation dialog box to finish. 
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To add a tap to an existing cable: 

1. On the map, select the cable. 

2. Click the Details   button. 

3. In the RF Cable Details dialog box, click Edit; then click Insert and Tap in the resulting menu lists. 

4. Complete the fields in the RF Tap Device Insertion dialog box as outlined in the table below. 

FIELD ENTRY/DESCRIPTION 
Equipment Type Select the appropriate type of equipment from the list. Only RF tap types listed in the 

current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the tap.  

Check for duplicates Select the checkbox to have spatialNET search for duplicates of the equipment name.  

Auto increment Select the checkbox to have spatialNET automatically increase the number associated 
to the name field.  

Update Connected 
Network 

Select the checkbox to automatically update anything associated to this tap name.  

RF System Type Select the  system type.  

Number of Spigots Automatically populated from the dictionary and cannot be edited. 

Tap Value Automatically populated from the dictionary and cannot be edited. 

Through Current Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

Voltage at Device Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

5. Click Select Pos. 

6. Position the placement cursor on the location for the tap; then click to add the tap to the map. 

 

7. After the tap appears, click Close on the RF Tap Device Insertion dialog box.  
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To add a tap while using the automated design function: 

1. Draft the RF cable. See Adding an RF Cable for instructions. 

2. Right-click on the map location where the tap will be placed. 

3. To select the tap: 

• Click Auto Suggest Tap (recommended) in the menu list and click on the tap, or  
• Click All Taps in the menu list. 

Important note: If Auto Suggest Tap is selected, spatialNET performs calculations to ensure that 
levels are within the parameters of the design profile in use.  

4. Select the correct tap from the menu list.  

5. After the design is complete, edit the tap information. See Editing an RF Tap. 

Annotating Equipment 

Adding an End-of-Line Annotation 
End-of-line annotations provide information on the signal at the end of an RF run and are based on the 
attributes defined in the dictionary for an end of line annotation block. An example of attribute definitions 
for an end-of-line annotation block is shown below: 

 

These attributes are then associated to the symbol block for the end-of-line annotation. 
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spatialNET calculates end-of-line values at the termination of the RF cable run. Those values appear on the 
map view, as set in the dictionary.  

 

To add an end of line annotation: 

1. Select the terminator of the RF network device that terminates the RF cable run. 

 

2. Click the Annotate Selected Entity   button. 

3. Complete the fields in the Annotation dialog box, as outlined: 

Field Entry/Description 
Manual Annotations Options are based on dictionary entries. 

Place remotely with marker Select the checkbox to place a numbered marker on the map and place the 
annotation elsewhere for neatness. 

Marker Number If a remote marker is used, increment this number. 

Annotation Scale Leave blank to use the default scale or enter a specific annotation height. 

Block Type Select the block type. 

4. Click on the appropriate map location to place the end-of-line annotation. 
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The end-of-line annotation appears on the map view. 

 
Note: Do not click Done. Clicking Done cancels the annotation and closes the window. 

Annotating an RF Active Device 
To annotate an RF active device: 

1. Select the RF active device. 

2. Update the attributes of the device if necessary. See Editing an RF Active Device. 

3. Click the Annotate Selected Entity   button. 

4. Complete the fields in the Annotation dialog box as outlined in the table below. 

  

Field Entry/Description 
Manual Annotations Options are populated from dictionary entries. 

Place remotely with marker Select the checkbox to place a numbered marker on the map and place the annotation 
elsewhere for neatness. 

Marker Number If a remote marker is used, increment this number. 

Annotation Scale Leave blank unless you wish to resize the block from the original drawing size (e.g., 
entering .5 renders the block to half the original size). 

Block Type Select the appropriate block type from the list. 

5. Click on the desired map location to place the annotation. 
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The annotation appears on the map view. 

 
Note: Do not click Done. Clicking Done cancels the annotation and closes the Annotation window. 

Annotating an RF Node 
To annotate an RF node: 

1. Select the RF node. 

 

2. Click the Annotate Selected Entity  button. 

3. From the entity list, select the entity to be annotated and click Select.  

Note: The Select Entity to Annotate dialog box appears if the site contains multiple entities. 
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4. Complete the fields in the Annotation dialog box as outlined in the table below. 

Field Entry/Description 
Manual Annotations Options are populated from dictionary entries. 

Place remotely with marker Select the checkbox to place a numbered marker on the map and place the 
annotation elsewhere for neatness. 

Marker Number If a remote marker is used, increment this number. 

Annotation buttons Select to use default or individual height. 

Annotation Height Specify actual individual height if the default is not selected, above. 

5. Click on the appropriate map location to place the node annotation. 

 
The annotation appears on the map view. 

 
Note: Do not click Done. Clicking Done cancels the annotation and closes the window. 
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Annotating an RF Power Supply 
To annotate an RF power supply: 

1. Select the RF power supply. 

2. Update the attributes of the device if necessary. See Editing an RF Power Supply. 

3. Click the Annotate Selected Entity   button. 

4. Complete the fields in the Annotation dialog box as outlined in the table below. 

  

Field Entry/Description 
Manual Annotations Options are populated from dictionary entries. 

Place remotely with marker Select the checkbox to place a numbered marker on the map and place the annotation 
elsewhere for neatness. 

Marker Number If a remote marker is used, increment this number. 

Block Type Select the appropriate block type from the list. Annotation blocks are customizable. 

5. Click on the desired map location to place the annotation. 

The annotation appears on the map view. 

 
Note: Do not click Done. Clicking Done cancels the annotation and closes the Annotation window. 
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Detaching RF Attributes 
During the design process, an annotation may overlap another object on the map. If the annotation is part 
of a symbol block, it cannot be moved unless it is first detached from the symbol.  

 

Only attributes that are defined in the dictionary and on the symbol for the entity appear in the Detach 
Attribute dialog box. The dictionary definition of the above amplifier and the attribute defined to the 
amplifier are shown below: 

 

In this instance, only one attribute can be detached and relocated. 

To detach an RF attribute from a symbol: 

1. Select the RF device on the map. 

2. Click the Details   button. 

3. In the RF Active Device Details dialog box, click Edit; then click Detach Attributes on the menu list. 

4. In the Continue? dialog box, click Yes to enable the attribute selection. 
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5. Select the check box for the attribute to be detached; then click Apply. 

 

6. Position the cursor on the red grip and drag the annotation to the new location. 

 

7. Click on the new location for the attribute on the map. 

8. Click Move to location … 

 
Note: To rotate the detached attribute: 

1. Click on the red circle. 

2. Drag the circle to the new rotation angle and release. 

3. Click the Rotate button. 
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Associating Support Structures 

Associating RF Support Structures to Addresses 
To associate an RF support structure to an address: 

1. Select a support structure on the map. 

2. On the Network toolbar, click the Drop Tool  button.  

3. In the Drop Tool, select the Drop Type. (The Drop Start value is automatically populated.) 

4. Type the drop cable length. 

5. In the House Counts section, select the appropriate button: 

• No Change: house count on map remains current. 
• Auto Increment: as addresses are selected, the house count automatically increases. 
• Auto Recount: populates the number of addresses selected on the map. 
• Manual Update: allows you to manually enter the house count number. 

The house counts value automatically populates the appropriate field (Residential, Commercial, MDU 
or Miscellaneous). 

6. On the map, click once on each address to be associated to the support structure. Addresses appear in a 
list on the Drop Tool. The plus (+) sign appearing next to an address indicates that it is not yet 
associated but will be associated when you click Apply. 

 

7. Click Apply to complete the association process. The equal (=) sign appearing next to an address 
indicates the association has been made. 

8. Repeat steps 1-7 for additional support structures. The Drop Tool remains open and values clear as each 
subsequent support structure is selected.  
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9. Click Close when all addresses and support structures have been associated. 

Associating RF Taps to Addresses 
To associate a tap to an address: 

1. Select a tap on the map. 

2. On the Network toolbar, click the Drop Tool  button.  

Note: The Drop Tool operates on a single tap. It will not operate if multiple taps are selected. 

3. In the RF Drop Tool dialog box: 

• Click on each address to associate it to the tap. 
• Click on any support structure to connect it to the address it serves. 

 

4. Click Apply.  

5. Repeat steps 3-4 as necessary. 
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Detaching RF Entities from Support Structures 
You can detach RF entities from support structures using the Detach Selected Equipment button. 

To use the Detach Selected Equipment button: 

1. Select the entity to be detached. 

2. On the Construction toolbar, click the Detach Selected Equipment button. 

3. In the Entities being detached dialog box, confirm that the correct entity is listed and click Confirm. 

 

Attaching an RF Network to Support Structures 
spatialNET enables users to easily attach RF network entities to support structures during the design 
process. If an attachment is missed during the design process, RF network devices can be associated to 
support structures after the design is complete. 

To attach RF cable or devices to support structures during the design process: 

1. Add RF cable. 

2. Left-click on the map to add a vertex for drafting the RF cable route. 
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3. Right-click on the footage or the route to associate it to the RF cable. The cable and support structure 
are now attached. 

 
To attach RF taps and other RF devices, see Attaching RF devices to support structures after network is 
designed (next). 

To attach RF devices to support structures after the network is designed: 

1. On the General toolbar, click the single selection  button to switch to multiple selection  mode.  

2. On the map, select the RF device and the support structure. 

 

3. Click the Attach Selected Equipment to Selected Support Network   button to process the 
attachment. 

4. In the Auto Attach results dialog box, verify that the device attached to the correct support structure. 
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5. If the device is a tap: 

a. Turn off the Multiple Select mode if necessary. 

b. Select the RF tap. 

c. Click the Drop Tool  button. 

d. Confirm the Tap Address List has updated, based on the house drops. 

 

e. Select Attach tap box to current support structure. 
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9. Click Apply. The RF tap now has addresses associated to it, based on the link with the drops from the 
support structure. 

10. Click Close. 

11. (Optional/recommended) On the General toolbar, click the multiple selection  button to return it 

to single selection   mode if this was not done in step 5a. 

To attach RF cable to support structures after the network is designed: 

1. On the General toolbar, click the single selection  button to switch to multiple selection  mode.  

2. On the map, select the RF cable segment and the support structure to be associated. 

Note: Only one cable segment and one support structure can be associated at a time. 

. 

3. On the Construction toolbar, click the Attach Selected Equipment to Selected Support Network 

 button to associate the two objects. 

4. In the Auto attach results dialog box, verify that the device and support structure are correctly 
associated. 
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5. Click Close. 

6. (Optional/recommended) On the General toolbar, click the multiple selection  button to return to 

single selection  mode.  

 

Multiple devices can be simultaneously attached to an individual support structure. Multiple devices, 
however, cannot be simultaneously attached to multiple support structures. 

To attach RF devices to support structures after the network is designed: 

1. On the General toolbar, click the single selection  button to switch to multiple selection  mode.  

2. On the map, select the RF device and the support structure. 

 

3. On the Construction toolbar, click the Attach Selected Equipment to Selected Support Network 

 button to associate the two objects. 

4. In the Auto attach results dialog box, verify that the device and support structure are correctly 
associated. 
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5. If the device is a tap: 

a. Turn off the multiple selection mode if necessary. 

b. Select the RF tap. 

c. Click the Drop   Tool  button. 

d. Confirm the Tap Address List has updated, based on the house drops. 

e. Select the Attach tap box to current support structure checkbox. 

6. Click Apply to associate the addresses to the RF tap. 

7. Click Close. 

8. (Optional/recommended) On the General toolbar, click the multiple selection  button to return to 

single selection  mode. 
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Using the RF Connectivity Tool 
The RF Connectivity Tool reports connectivity errors and unconnected Out ports within a selected 
boundary. It is an important part of the quality control process during RF network drafting and data 
migration. 

To use the RF Connectivity Tool: 

1. Select the appropriate boundary. 

 

2. On the RF menu, click Tools; then click RF Connectivity Tool. 

3. In the RF Connectivity Report dialog box, select the options and parameters to be included in the 
report. 

Note: The default value in the Maximum distance between connections (%) field is recommended. 
If this percentage is increased, visible gaps between cables and RF equipment may appear on the map. 

 

4. Click Display/Update Alerts. 

5. Click Connectivity Report to display the report. 

• The Connectivity errors section reports gaps between cables and equipment, based on the 
percentage set in step 3. 
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• The Unconnected out-ports section lists ports that are unconnected or have not been terminated. 

 

6. Click on the flashlight icon to view the associated piece of equipment on the map. 

7. Save, print or close the report. 

RF in MDUs 

Adding an RF DMark in an MDU View 
An RF DMark in an MDU (multiple dwelling unit) represents the connection between the outside and 
inside RF cables. A DMark must be added to the building and internal floor plan before RF can be placed 
inside an MDU. 

To add an RF DMark in an MDU view: 

1. On the MDU Drawings toolbar, click the Add MDU Drawing DMark  button. 

The Add DMark dialog box opens. 

 

2. On the map view, click on the building symbol where the DMark will be placed. 
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The coordinates of that location appear in the Add DMark dialog box. 

 

3. Click Next. 

4. On the floor plan view, click where the DMark will be placed. 

The coordinates of that location appear in the Add DMark dialog box. 

5. Click Done. 

The DMarks appear in both views. 

 
DMarks can be rotated or moved after initial placement if necessary. 

Adding RF in an MDU 
To add RF to an MDU, you can place a node or active device within the MDU and draft the RF inside the 
MDU. See Adding an RF Node and Adding an RF Active Device.  

 A DMark must be in place to have connectivity to the outside plant network. See Adding an RF DMark in 
an MDU View. 

To add RF in an MDU using DMark functionality: 

1. Right-click on the piece of RF equipment that will serve as the starting point for the design. 

2. On the RF Tools toolbar, click the Add Cable  button. 

3. Complete the fields in the Cable Creation dialog box (see Adding an RF Cable); then click Add.  

The Line Capture Controls dialog box opens. 

4. Right-click on the footage or route.  

The route will highlight. 

5. Right-click on the DMark to open the menu list and click DMark Display to OSP View. 
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The design function closes, and the cable is automatically drafted to the DMark. 

6. Open the Contained MDU view. 

7. Select the DMark; then select the yellow port. 

 

8. Add the RF cable to the MDU. See Adding an RF Cable for details. 

9. After the cable is added, click on the Window menu; then click Tile Horizontally to open both the 
map view and the Contained MDU view simultaneously.  

10. On the map view, select the piece of equipment where you began designing the RF to the MDU. 

11. Click the RF Leveling Tool button; then click Re-Level in the RF Re-Level dialog box. 

Running the RF Leveling Tool runs a trace to ensure continuity from outside the MDU to inside and 
also updates the network. See RF Leveling Tool for details. 
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Note: If the trace does not continue through the DMark into the floor plan view, the port on the DMark 
was not properly selected.  

1. In the floor plan view, delete the RF cable. 

2. Repeat steps 7-11, above, until the trace runs correctly. 

Editing Equipment 

Editing an RF Active Device 
Attributes you can edit for an active device include: 

• Symbol scale 
• Construction status 
• Equipment name 
• RF system type 

See also: 

• Adding an RF Active Device 
• Replacing an RF Active Device 
• Deleting Equipment 
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To edit an RF active device: 

1. Select the active device on the map. 

 

2. Click on the Details   button. 

3. In the RF Active Device Details dialog box, click Edit; then click Edit on the menu list. 

4. Edit fields in the General tab of RF Active Device Modification dialog box as outlined in the table 
below. 

Field Entry/Description 
Number of Ports Automatically populated from the dictionary and cannot be edited. 

Equipment Name Enter the name of the equipment. 

Check for duplicates Select the checkbox to have spatialNET search the entire database, including 
any current jobs, for duplicates of the equipment name. 

Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels in 
the connected network.  

Update Downstream 
Connected Graphics 

No change to downstream graphics: Downstream graphics will remain in their 
current positions. 
Slide downstream graphics: Forces change to downstream connected devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. 
Symbol scale can be adjusted to resize the device in a congested area of  the 
map. For example, entering .5 decreases the symbol by half and entering 2 
doubles the size. 

5. Click Apply to save any edits made on this tab. 

6. Edit fields in the Location tab as outlined in the table below. 

Field Entry/Description 
Address fields Update the address here. 

Node Auto-populated from Service Area Manager, or select the boundary from the 
map database.  

Service Area 2/3 Service area information must be in place on the map; otherwise, no selections 
will be available in the list. See Using the Service Area Manager. 

7. Click Apply to save any edits made on this tab. 
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8. Edit fields in the RF tab as outlined in the table below. 

Field Entry/Description 
RF Design Profile Select the appropriate RF design profile. 

RF System Type Select the system type. 

Construction Type Select the construction type. Options are based on dictionary entries. 

Construction Status Select the appropriate construction status, which determines the layer, 
color, line type, and other display attributes for the active device. 

Cascade Number Enter the number in downstream device sequence from the node. 

Lockdown Status Permits/prohibits changes to the active device. 

Node Id Enter the ID of the node associated with this active device. 

Power Supply ID Enter if known. Will be automatically populated after power calculations 
are complete. 

Distance to Previous 
Active 

Enter the distance from the upstream active in feet or meters. 

9. Click Apply to save any edits made on the RF tab. 

10. Values in the Device tab are established in the dictionary. You can change these values for a one-time 
load level test. See RF Power Tool. 

11. Click Apply to save any edits made on the Device tab. 

Editing an RF Cable 
Attributes you can edit for RF cable include: 

• Cable as-built length 
• RF design profile 
• RF system type 
• Construction type 

It is important to verity that RF cable lengths have been modeled and accounted for correctly in spatialNET. 
When RF cable is drafted, it is typically associated to a support structure. When several segments of RF 
cable are associated with common support structures, the cable length is defined by these support structure 
lengths. 
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The RF Cable Details window displays the P3-500 segment as 208 feet, based on the associated aerial 
support segments listed under Cable Support: 

 

You can edit cable lengths directly on the cable or on the lengths of the associated support structures. Both 
methods are provided. 

To change the cable length directly on the cable: 

1. Click on the cable strand to be edited. 

 

2. Click the Details   button. 

3. In the RF Cable Details dialog box, click Edit; then click Edit from the resulting list menu. 

4. In the RF Cable Modification dialog box, enter the correct value in the Cable Asbuilt Length field. 

 

5. Click Apply. The length will appear in any annotation associated to the Cable Asbuilt Length. 



RELEASE 5.9  SPATIALNET USER MANUAL – RF MODULE 

©SPATIALINFO PTY LIMITED, 1998-2011. ALL RIGHTS RESERVED 57 OF 100 

Use these procedures to change cable lengths for both aerial and underground support structures. 

 To change a cable length using the support structure process: 

1.  Select the support structure strand or trench. 

 

2. Click the Details  button. 

3. In the Strand Details dialog box, click Edit; then click Edit from the list menu. 

 

4. In the Strand Modification dialog box, enter the updated value in the Length field. 
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5. Click Apply. Lengths for the support structure and any associated cables are updated.  

Note: For these updates to be reflected in the design levels, you must perform a recalculation. See RF 
Leveling Tool. 

To edit RF cable attributes: 

1. Click on the RF cable segment. 

 

2. Click on the Details   button. 

3. In the RF Cable Details dialog box, click Edit; then click Edit in the menu list. 

 

4. Edit the information in the RF Cable Modification dialog box. 

 
See also: 

• Replacing RF Cable 
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• Changing the RF Design Profile for an RF Cable 

5. Click Apply to save the changes. 

Editing an RF Node 
Since a node contains both RF and optical equipment, you must choose which entity to edit. 

The site is a container for the two pieces of equipment. If you select the graphic on the map, and click Edit, 
you will be editing only the site attributes.  

To edit site attributes: 

1. Highlight the node on the map. 

 

2. Click the Details   button. 

3. In the Site (in OSP View) Details dialog box, click Edit; then click Edit in the menu list. 
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4. Complete the fields in the Site (in OSP View) Modifications dialog box as outlined in the table below. 

Field Entry/Description 
Site Type Select the appropriate site type from the list. Only site types that have been defined in 

the dictionary are included in this list. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. Symbol 
scale can be adjusted to resize the device in a congested area of  the map. For example, 
entering .5  decreases the symbol by half and entering 2 doubles the size. 

Site Code Enter a site code. 

Designation Update the name of the site if needed. 

Check for duplicates Select the checkbox to have spatialNET search the entire database, including any 
current jobs, for duplicates of the equipment name. 

Owner Enter owner information. This information is helpful for sites leased from a third party. 

Contact Enter contact information. 

Address fields Enter owner address, if applicable. Alternately, enter the address of the node site. 

Location Enter a description of the site location. 

Construction Status Select the appropriate construction status, which determines the layer, color, line type, 
and other display attributes for the active device. 

Annotation Select to use default height or individual height. 

Annotation Height Enter annotation height if Use individual height is selected.. 

5. Click Apply. 

  

Use the following procedures to edit the equipment within the RF node: 

To edit node attributes, including nodes attached to optical nodes: 

1. Highlight the node on the map. 

 

2. Click the Details   button. 

3. In the Site (in OSP View) Details dialog box, highlight the RF node under the Equipment listing and 
click Select. 
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4. Click Edit; then click Edit in the resulting menu list. 

5. Edit fields in the General tab of the RF Node Modification dialog box as outlined in the table below. 

Field Entry/Description 
Number of Ports Automatically populated from the dictionary and cannot be 

edited. 

Equipment Name Enter the name of the node. 

Check for duplicates Select the checkbox to have spatialNET search the entire 
database, including any current jobs, for duplicates of the 
equipment name. 

Update Connected Network (Default is checked) Select the checkbox to automatically 
update the levels in the connected network.   

Update Downstream Connected 
Graphics 

No change to downstream graphics: Downstream graphics 
will remain in their current positions. 
Slide downstream graphics: Forces change to downstream 
connected devices 
Snap downstream graphics to connected port: Changes 
orientation of downstream graphics snapped to a connected 
port. 

Symbol Scale (for containing 
Site) 

If this field is left blank, the default value configured in the 
dictionary is used. Symbol scale can be adjusted to resize 
the device in a congested area of  the map. For example, 
entering .5 decreases the symbol by half and entering 2 
doubles the size.  

6. Click Apply. 
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7. Edit fields in the Location tab as outlined in the table below. 

FIELD ENTRY/DESCRIPTION 
Node Select the name or number of the node. 

Service Area 2/3 If service area information has been defined on the map, selections for specific 
service areas will be available in the list. See Service Area Manager. 

8. Edit fields in the RF tab as outlined in the table below. 

FIELD ENTRY/DESCRIPTION 

RF Design Profile Select the design profile from the list. 

RF System Type Select the RF system type.  

Construction Type Select the construction type as defined in the RF data dictionary.  

Lockdown Status Unlocked: Permits changes to the node. 
Locked: Prohibits changes to the node. 

Power Supply ID Enter if known. Will be automatically populated after power calculations 
are complete. 

Carrier Type If wavelength division multiplexing or specific RF carrier frequencies are 
being used at this location, select the carrier type.   

Interface Used to change current port mapping interface. 

9. Click Apply to save changes in the RF tab. 

10. Values in the Device tab are established in the dictionary. You can change these values for a one-time 
load level test. See RF Power Tool. 

11. Click Apply to save changes in the Device tab. 

Editing an RF Passive Device 
The following attributes of an RF passive device can be edited: 

• Symbol scale 
• Construction status 
• Equipment name 
• RF system type 

See also: 

• Adding an RF Passive Device 
• Replacing an RF Power Supply, Passive Device, or Tap 
• Deleting Equipment 

To edit a passive device: 

1. Highlight the passive device. 

2. Click the Details   button. 

3. On the RF Passive Device Details dialog box, click Edit; then click Edit on the menu list. 
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4. Edit the fields in the RF Passive Device Modification dialog box as outlined in the table below. 

Field Entry/Description 
Equipment Type Automatically populated from the RF dictionary. Cannot be edited. 

Number of Ports Automatically populated from the RF dictionary. Cannot be edited. 

Equipment Name Enter the correct equipment name 

Check for duplicates Select the checkbox to have spatialNET search the entire database, 
including any current jobs, for duplicates of the equipment name. 

Update Connected Network (Default is checked) Select the checkbox to automatically update the 
levels in the connected network.  

Update Downstream 
Connected Graphics 

No change to downstream graphics: Downstream graphics will remain 
in their current positions. 
Slide downstream graphics: Forces change to downstream connected 
devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

Symbol Scale If this field is left blank, the default value configured in the dictionary 
is used. Symbol scale can be adjusted to resize the device in a 
congested area of  the map. For example, entering .5 decreases the 
symbol by half and entering 2 doubles the size. 

Construction Status Select the appropriate construction status , which determines the 
layer, color, line type, and other display attributes for the active 
device. 

RF Design Profile Select the appropriate design profile. 

RF System Type Select the appropriate system type. 
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Field Entry/Description 

Through Current Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

Voltage at Device Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

Distance to Previous Active Manually overrides the distance to the previous active device. 

Annotation Scale Update the annotation scale as necessary.  

5. Click Apply to complete the updates. 

Editing an RF Power Supply 
Attributes you can edit for an RF power supply include: 

• Symbol scale 
• Construction status 
• Equipment name 
• RF system type 

See also: 

• Replacing an RF Power Supply, Passive Device, or Tap 
• Deleting an RF Power Supply 

To edit an RF power supply: 

1. Highlight the RF power supply. 

2. Click the Details   button. 

3. On the RF Power Supply Details dialog box, click Edit; then click Edit on the resulting menu list. 

4. Update the fields in the RF Power Supply Modification dialog box as outlined in the table below. 

Field Entry/Description 
Equipment Type Automatically populated from the dictionary and cannot be edited. 

Number of Ports Automatically populated from the dictionary and cannot be edited. 

Equipment Name Enter the updated name of equipment. 

Check for duplicates Select the checkbox to have spatialNET search the entire database, including 
any current jobs, for duplicates of the equipment name. 

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in 
the connected network. 

Update Downstream Connected 
Graphics 

No change to downstream graphics: Downstream graphics will remain in their 
current positions. 
Slide downstream graphics: Forces change to downstream connected devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is used. 
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Field Entry/Description 
Symbol scale can be adjusted to resize the device in a congested area of  the 
map. For example, entering .5  decreases the symbol by half and entering 2 
doubles the size. 

Construction Status Select the appropriate construction status, which determines the layer, color, 
line type, and other display attributes for the power supply 

RF Design Profile Select the appropriate design profile. 

RF System Type Select the system type. 

Node Edit the node number being fed by the power supply. 

Service Area 2/3 Enter the Service Area name(s). 

Maximum Amps Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

Amps at Device Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

Voltage at Device Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

Power Consumption (Watts) Default value is defined in the dictionary. A value entered here will override the 
dictionary value. 

5. Click Apply to save the updates. 

Editing an RF Tap 
Attributes you can edit for an RF tap include: 

• Symbol scale 
• Construction status 
• Equipment name 
• RF system type 

See also: 

• Adding an RF Tap 
• Replacing an RF Power Supply, Passive Device, or Tap 
• Deleting Equipment 

To edit an RF tap: 

1. Select the tap. 

2. Click on the Details button. 

3. In the RF Tap Device Details dialog box, click Edit; then click Edit in the menu list. 

4. Edit fields in the RF Tap Device Modification dialog box as outlined in the table below. 
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Field Entry/Description 
Equipment Type Select the appropriate type of equipment from the list. Only RF tap types 

listed in the current RF design profile are included in this list. 

Number of Ports Automatically populated from the dictionary and cannot be edited.  

Equipment Name Enter the name of the tap.  

Check for duplicates Select the checkbox to have spatialNET search the entire database, 
including any current jobs, for duplicates of the equipment name. 

Update Connected 
Network 

(Default is checked) Select the checkbox to automatically update the levels 
in the connected network.  

Update Downstream 
Connected Graphics 

No change to downstream graphics: Downstream graphics will remain in 
their current positions. 
Slide downstream graphics: Forces change to downstream connected 
devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

Symbol Scale If this field is left blank, the default value configured in the dictionary is 
used. Symbol scale can be adjusted to resize the device in a congested area 
of  the map. For example, entering .5  decreases the symbol by half and 
entering 2 doubles the size. 

Construction Status Select the appropriate construction status, which determines the layer, 
color, line type, and other display attributes for the tap. 

RF Design Profile Select the appropriate design profile. 

RF System Type Select the appropriate system type. 

Lockdown Status Unlocked: Permits changes to the tap. 
Locked: Prohibits changes to the tap. 

Number of Spigots Automatically populated from the dictionary and cannot be edited. 

Tap Value Automatically populated from the dictionary and cannot be edited. 

Through Current Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

Voltage at Device Default value is defined in the dictionary. A value entered here will 
override the dictionary value. 

Distance to Previous 
Active 

Populated by the RF update code. Can be updated if necessary. 

Annotation Scale Update the annotation scale as necessary.  

5. Click Apply to save the edits. 
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Editing RF Signal Levels 
To edit signal levels on an RF device: 

1. Select the RF device on the map and click the Details   button on the General toolbar. 

2. In the Details dialog box, click Edit; then click Levels. 

 

3. To change any levels at any of the ports, double-click on the associated cell and change the value. 

 

4. Click Update to save the changes. 

Using the RF Amplifiers Rename Tool 
Use this tool to rename multiple amplifiers within a selected boundary (e.g., when downstream amplifiers 
must be renamed to reflect a node name change). Values can be customized or selected from the following 
predefined list: 

• Nothing 
• User Defined Field 1 
• User Defined Field 2 
• Node Name 
• Port Node Name 
• Node Sequence by Device Order 
• Port Node Sequence by Device Order 
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• Node Sequence by distance to node 
• Port Node Sequence by distance to node 

To use the RF Amplifiers Rename tool: 

1. Highlight the boundary on the map. 

2. On the RF menu, click Tools; then click RF Amplifiers Rename Tool. 

3. In the Re-naming tool, select the desired values in fields 0-4. 

4. If User Defined Field 1 or User Defined Field 2 is chosen from the predefined values, define the value in 
the related field at the bottom of the tool. See the example, below. 

 

5. Click OK. 

Example  

To rename amplifiers according to the naming convention: Node Name.Device Sequence Order.Node 
Sequence by distance to Node  

The amplifier names should be formatted as follows: Node01.01.0153   

Values in the Re-naming Tool should be:  

 ` 
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Replacing Equipment 

Replacing a Component in an RF Active Device 
In RF active devices, components consist of internal couplers, pads and equalizers. You can manually 
replace the auto-selected pad and equalizer or change the coupler to add ports to the active device. 

To replace a component on an RF active device:  

1. Select the RF active device. 

2. Click the Details   button. 

3. Expand the Components list if it is not already expanded. 

4. Click on the name of the component to be replaced.  

5. Click Edit; then click Replace. 

 

6. Edit the fields in the RF Device Component Replacement dialog box as outlined in the table below. 

Field Entry/Description 
Component Class Select the component class.  

Component Type Select the component type. The list is populated from the dictionary definitions 
available for the component class. 

Component Name Populates based on the selected component type. Update if necessary. 

Check for duplicates Select the checkbox to have spatialNET search the entire database, including any 
current jobs, for duplicates of the equipment name. 

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in the 
connected network.  
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7. Click Apply. 

8. Update RF levels as needed. 

Replacing an RF Active Device 
When replacing an active device, you must also remove all components included with the device being 
replaced. A component with multiple Out ports must be replaced with a component containing at least the 
same number of Out ports; otherwise, an error message similar to the following appears: 

 

  

Internal components are used to add Out ports to active devices. Below are some typical RF active 
arrangements: 

Active with no 
components: one In 
port and one Out port 

   
  

Active with jumper: 
one In port and two 
Out ports 

   
  

Active with internal 
splitter: one In port and 
three Out ports 

 

An RF cable connected to an Out port of a splitter or jumper must be disconnected before the active device 
can be replaced. 
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To replace an RF active device: 

1. Select the active device on the map. 

 

2. Click the Details   button. 

3. Expand the Components list to view associated components.  
An RF cable connected to an Out port of a splitter or jumper must be disconnected before the active 
device can be replaced. 

 

4. To disconnect an RF cable from an Out port: 

a. Select the cable. 

 

b. Click on the end of the cable where it connects to the active device.  
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c. Drag the  end of the cable away from the port and click on the map. 

 

d. Select Disconnect and move to location …   

 
On the map, a terminator appears at the end of the cable. 

5. Select the RF active device. 

6. Click the Details   button. 

7. On the RF Active Device Details dialog box, click Edit; then click Replace in the menu list. 

8. Edit the fields in the RF Active Device Replacement dialog box as outlined in the table below. 

Field Entry/Description 
Select Design Profile for 
Equipment 
  

No change: Select to use auto-populated profile shown in the Existing Profile 
field. 
Use job profile: Current job profile for this device auto-populates the Job 
Profile field.  
Use other profile: Select to choose another profile in the Other Profile field. 

Equipment Type Select the new entity from the list. Review any warning messages that appear 
as a result of your selection. In the warning box, click Confirm to continue 
with the selected device, or click Cancel to select another device. 

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in 
the connected network. 

Auto-update Tap Faceplate 
Values 

Select to have the system automatically change tap values downstream of the 
device. 
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Update Downstream 
Connected Graphics 

No change to downstream graphics: Downstream graphics will remain in their 
current positions. 
Slide downstream graphics: Forces change to downstream connected devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

9. Click Apply to replace the device. 

10. Add the components back to the RF active device. See Adding Additional Ports to an RF Active Device. 

11. Reconnect the RF cables as needed. 

a. Select the disconnected RF cable. 

 

b. Drag the end of the cable to the Out port on the RF active.  
Note: The port symbol and cable end symbol must intersect without crossing the RF active symbol 
block. Zoom out slightly to view the connection more clearly. 

 

c. Select Reconnect to [device], port OUT[number]. 
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The terminator is automatically removed. 

  

Replacing an RF Cable 
Replacing the RF cable type for an RF network can impact signal loss, electrical resistance, material costs, 
and change how the cable displays on the map, based on the definition in the RF dictionary. Since 
spatialNET does not automatically replace tap faceplates or add/remove pads or equalizers from connected 
devices, always run the RF Leveling Tool after replacing a cable to ensure signals are properly adjusted in 
the system. 

You can replace RF cable in one of two ways: 

• By modifying the cable (recommended) 
• By deleting the cable and then adding it back to the map. 

 

To modify the cable: 

1. Select the cable segment to be replaced. 

 

2. Click the Details   button. 

3. On the resulting RF Cable Details dialog box, click the Edit button; then click Replace on the 
resulting list. 

4. Complete the fields in the resulting RF Cable Modification dialog box (shown below the following 
table) as follows: 
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Field Entry/Description 
Cable Type Select the new type of cable from the list. 

Cable Asbuilt Length Enter the actual as-built cable length. 

RF Design Profile Select the design profile from the list. 

RF System Type Select the RF system type. 

Construction Type Options are based on dictionary entries.  

Through Current The value for this field is established in the dictionary. You can change the value 
for a one-time load level test. Voltage at Device 

Cable Resistance 

5. Click Apply to update the cable. 

6. Run the RF Leveling Tool. (See RF Leveling Tool.) 

Replacing an RF Node 
In spatialNET, an RF node can be a combination of two or more different devices or equipment at a 
network site, as illustrated below: 

 
Because spatialNET treats RF nodes as equipment rather than sites, RF nodes are replaced at the Equipment 
level. As a result, the port mapping and interface remain at the Connectivity level when an RF node is 
replaced with a node having the same basic port definitions. 
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Example: An RF node containing Out ports A, B, C, and D is replaced with another node containing the 
same Out ports A, B, C, and D. Because the node is being replaced with a similar node, port mapping 
remains in place. If the new node contains additional ports, however, the additional ports must be mapped.  

Note: When RF nodes are deleted and then replaced, port mapping and interfaces are also deleted and 
must be re-created. As a result, SPATIALinfo recommends replacing a node rather than deleting it to avoid 
the necessity of re-mapping the ports. 

To replace an RF node: 

1. Select the RF node site. 

 

2. Click the Details   button. 

3. In the Site Details dialog box, highlight the RF node in the Equipment list and click Select. 

4. Click Edit; then click Replace. 
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5. Complete the fields in the RF Node Replacement dialog box as outlined in the table below. 

Field Entry/Description 
Select Design Profile for 
Equipment 
  

No change: Select to use auto-populated profile shown in the Existing Profile 
field. 
Use job profile: Current job profile for this device auto-populates the Job 
Profile field.  
Use other profile: Select to choose another profile in the Other Profile field. 

Equipment Type Select the new entity from the list. Review any warning messages that appear 
as a result of your selection. In the warning box, click Confirm to continue 
with the selected device, or click Cancel to select another device. 

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in 
the connected network.  

Auto-update Tap Faceplate 
Values 

Select the checkbox to have the system automatically change tap values 
downstream of the device. 

Update Downstream 
Connected Graphics 

No change to downstream graphics: Downstream graphics will remain in their 
current positions. 
Slide downstream graphics: Forces change to downstream connected devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

6. Click Apply. 

7. If necessary, correct port mapping or map additional ports.   

Replacing an RF Power Supply, Passive Device, or Tap 
New passive devices must have at least the same number of defined In and Out ports as the device being 
replaced; otherwise the system will not allow the device to be replaced and an error message similar to the 
following will appear: 

 

The replacement device must be the same class as the one being replaced (for example, a coupler replacing 
a coupler, or a tap replacing a tap); otherwise, spatialNET will not allow replacement until the downstream 
RF devices have been disconnected. 
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To replace an RF power supply, passive device, or tap: 

1. Select the power supply, passive device, or tap. 

2. Click the Details   button. 

3. Click Edit. 

4. In the Device Details dialog box for the entity, click Replace. 

5. Complete the fields in the appropriate Replacement dialog box as follows: 

Field Entry/Description 
Select Design Profile for Equipment 
  

No change: Select to use auto-populated profile shown in the Existing Profile 
field. 
Use job profile: Current job profile for this device auto-populates the Job 
Profile field.  
Use other profile: Select to choose another profile in the Other Profile field. 

Equipment Type Select the new entity from the list. Review any warning messages that appear as 
a result of your selection. In the warning box, click Confirm to continue with 
the selected device, or click Cancel to select another device. 

Update Connected Network (Default is checked) Select the checkbox to automatically update the levels in 
the connected network.  

Auto-update Tap Faceplate Values Select to have the system automatically change tap values downstream of the 
device. 

Update Downstream Connected 
Graphics 

No change to downstream graphics: Downstream graphics will remain in their 
current positions. 
Slide downstream graphics: Forces change to downstream connected devices 
Snap downstream graphics to connected port: Changes orientation of 
downstream graphics snapped to a connected port. 

6. Click Apply. 

7. If a tap or passive is replaced, run the RF Leveling Tool to account for the new values, losses, and other 
signal-related readings. 

Note: When a tap is replaced, support structures and other address/parcel associations remain with the 
tap. If a tap is deleted and replaced, the associations must be re-established. 

8. If a power supply is replaced, run the RF Power Tool  to account for the new power data. 
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Deleting Equipment 
Before a node can be deleted, all network entities connected to it must be disconnected or deleted. 
A message appears if anything is attached to a node that is being deleted. 

 

Click OK to view the entities attached to the node. 

 

RF nodes are typically associated with optical nodes at sites.  

 
When an RF node is deleted, the port mapping is also deleted, and disconnected RF cables cannot be 
reconnected to the site until a new RF node is added. 

To delete an RF node associated with an optical node: 
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1. Select an RF cable segment connected to the RF node and move the end of the cable away from the 
node. 

 

2. Select Disconnect and move to location ...  

 
A terminator is automatically connected to the RF cable. 

 

3. Repeat steps 1-2 for all connected RF cable segments. 
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4. Select the node. 

5. Click the Details   button. 

6. In the Site Details dialog box, expand the Equipment list and highlight the RF node. 

 

7. Verify that the correct entity is selected and click Select; then click Delete. 

8. Click Confirm to complete the deletion process. 
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If an RF node is not attached to an optical node, deleting the node deletes the entire site.  

To delete the node and the site: 

1. Select an RF cable segment connected to the RF node and move the end of the cable away from the 
node. 

 

2. Select Disconnect and move to location ... 

 
A terminator is automatically connected to the RF cable. 

 

3. Repeat steps 1-2 for all connected RF cable segments. 
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4. Select the node. 

5. Click the Details   button. 

6. In the Site Details window, click Delete. 

 

7. In the Deletion options window, click Delete. 

 
Note:  

• Delete removes the node from the database and map.  
• Remove removes the node from the map but retains it in the database. 
• Abandon retains the site on the map but disables it. The site can be changed to "in use" at a later 

date. 

8. Verify that the correct node is selected and click Confirm. 
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To delete an individual entity: 

1. Select the entity to be deleted. 

 

2. Ensure that no RF cable is connected to the entity.  

3. Right-click on the entity. 

4. Click on spatialNET in the menu list; then click Delete.  

5. In the next menu list, click Delete. 

6. In the Entities being deleted list, verify that the correct entity appears. Click Confirm.  

 

To delete an entity and all downstream devices: 

1. Select the RF device. 

2. Click the Details   button. 

3. Click Delete; then click Downstream Delete. 

4. On the map, verify that the highlighted entities are the ones to be deleted. 
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5. Click Confirm. 

Note: If these procedures are used to delete a power supply, the node will not be removed. 

Viewing RF Details 
Use the Details dialog box to view detailed information on a selected device and make modifications to it. 
This dialog box enables you to: 

• View and modify the RF signal and the length of RF cable. 
• View and modify In and Out ports and the port mapping. 
• View the tap value settings. 
• View connected addresses. 
• Add components. 
• Modify a device. 

Information displayed in Details is specific to the type of device, dictionary definitions for that device, and 
information contained in the attributes fields associated with the device. 

To access Details for a device on the map: 

1. Select the device on the map. (An active device is used in the following example.) 

 

2. Click the Details   button to open the Details dialog box. 

3. Expand the list to view detailed information about the device. 
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Viewing RF Levels 
To view RF signal levels on a device: 

1. Select the device on the map and click on the Details   button.  

2. Click on Edit; then click Levels to display input and output levels in the Edit Levels window. 
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To view a summary of RF levels of a device while in the map view: 

1. Ensure that the balloon tooltips feature is active. Click the Toggle Balloon Tips  button on the 
View toolbar if balloon tooltips do not appear on the map. 

2. Position the placement cursor over the selected device to highlight it. (Clicking on the device is not 
necessary but will produce the same result.) A list similar to the one shown below displays the RF levels 
for the device. 

  

 
See also Editing RF Levels. 
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RF Tracing, Reports and Tools 

Network Tracing 

Distance Tool 
Use the Distance Tool to select a point of RF cable that is a specific distance from a designated object on the 
map. You can then select that point and view the area using Google View modes.  

To use the Distance Tool: 

1. Highlight an object close to the section of cable on the map. 

2. On the RF menu, select Network Tracing; then Distance Tool. 

3. Complete the fields in the Distance Tool as outlined: 

Field Entry/Description 
Cable Segment Populates with the cable segment attached to the selected object. 

Start Channel Select the start channel. 

Distance Type the distance to measure from the starting point in feet or meters. 

Length Cable Length: Uses the actual cable length entered during the drafting process. More 
accurate.  
Model Length: Uses the cable length as drawn on the map, which may not accurately 
reflect the actual layout of the cable in the network. 

Length multiplier Use to calculate the sag factor for aerial cable. Leave at the default (1.0) if sag factor is not 
applicable. 

Trace Direction Select the direction of the trace. 

Zoom To Don't Zoom: Retains the current map size during the trace.  
Traced Extent: Displays the entire length of the traced cable. The map may refresh at a 
different size to accommodate the entire trace. 
Results: Zooms to the trace point on the cable and does not display the entire length of the 
trace. Using this selection, you can open Google Views to display the trace point in various 
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Field Entry/Description 
modes.  

1. Highlight the trace point. 

2. Click the Details  button; then Display. 

3. Click Google View; then click the View menu and select your preferred 
viewing mode. 

Highlight Mode None: Only the trace point is highlighted. 
Add to Highlight: Highlights the trace point and all network objects in the trace. 
New Highlight: Clears previously highlighted objects in the trace and displays the trace 
point.  

Highlight Color Select the color of the highlighted trace. 

Highlight Width Select the width of the line highlighting the trace.  

 

4. Click Trace to display the trace and trace point. 

RF Cable Traces 
To trace objects connected to an RF cable: 

1. Select an object on the map as the starting point for the trace. 

Note: To select a node as the starting point for the trace, select the node and open the Details window. 
Under Equipment, click the name of the node; then click Select. The name of the node will appear in 
bold type. Continue to step 2. 

2. On the Trace toolbar, click the Trace Cable  button, or on the RF menu, click RF Tracing; then 
Trace Cable. 

3. Complete the fields in the Sheath Trace Configuration dialog box as outlined in the table below. 
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Field Entry/Description 
Trace Type Select the type of trace to run from the list provided. 

Zoom view to 
contain results 

Select the checkbox to display the entire length of the traced cable. The map may refresh at a 
different size to accommodate the entire trace. 

Show entity list of 
results 

Select the checkbox to open a list box of connected network entities. 

Highlight Color Select the color of the highlighted trace. 

Highlight Width Select the width of the highlighted trace.  

Highlight traced 
entity(s) 

Select the checkbox to highlight all traced network entities. If this box is not selected, the 
system will automatically select it when the Trace button is clicked . 

4. Click Trace.  

5. To clear the highlights after the trace, click the Clear Highlight button, which is located on the 
Tracing and General toolbars. 

RF Highlight Cluster Tool 
Devices drafted in Cluster mode have no cable segments connecting them. Use the RF Highlight Cluster 
tool to verify that all objects in a cluster are connected properly. The following example illustrates these 
"port to port" connections.  

  

  

Note: Cable mode, illustrated below, is the system default.  

 

  

To use the RF Highlight Cluster tool: 

1. Select an RF network device. 
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2. On the RF menu, click Network Tracing, then Highlight Cluster. 

 
Devices connected to the selected device in Cluster mode will be highlighted as shown below. 

 

3. Click the Clear Highlight  button to remove the highlight. 

RF Reports and Tools 

Bill of Materials Report 
The Bill of Materials report provides a bill of materials spreadsheet for a selected boundary. 

To run a bill of materials report: 

1. Select the boundary defining the Bill of Materials. 

2. In the spatialNET menu, select Reports; then select BOM within Boundary. 

3. In the Bill of Materials within Selected Area dialog box: 
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a. Select the file location for the report. Use the browse button provided for your convenience. 

b. Click Write to generate the report. 

 
An example of a default BOM report is shown below. This report also can be sent to a customized Excel 
report. 

 

Device Count 
Use the Count function to view the quantity of a specific RF device type within a selected boundary. 

To use the Count function: 

1. Select the appropriate boundary on the map. 

2. In the RF menu, select Count; then select the type of equipment from the menu list (Node, Active, 
Passive, Power Supply, Tap, RF Cable) .  

A Device Count list box similar to the one below displays the number of each type of the  device within 
the boundary. 
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3. (Optional) Click List to view a list of the individual devices in the master list.  

Select an individual device to activate the Select, Display, Edit and Delete buttons and access additional 
functionality.  
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RF Auto Alert Tool 
Use the RF Auto Alert Tool to specify the type(s) of alerts that will appear during a trace or when the RF 
Leveling Tool is run. The actual warning levels, indicated by green, yellow, or red map symbols and red 
warning text, are set in the design profile for the equipment.  

To change the settings in the RF Auto Alert Tool: 

1. In the RF menu, select Tools; then click RF Auto Alert. 

2. Select the type(s) of alerts to appear. 

• Alert Signal Levels: Displays alerts regarding levels coming in or out of a device. Places a green 
symbol on the map if signals are within specifications. Places a yellow symbol on the map if signals 
reach the minimum or maximum warning levels as set in the dictionary. Places a red symbol on the 
map if signals exceed the maximum warning level as set in the dictionary. 

• Alert Power Levels: Places a yellow symbol on the map when the amount of current flowing 
through the power supply is above the warning limit. Places a red symbol on the map when the 
amount of current flowing through the power supply is above the maximum limit. 

• Alert for Equipment in Different Profile: Displays alerts if connected equipment does not share 
the same design profile. 

• Add Text Alerts: In reports, adds text alerts when equipment nears or exceeds maximum signal 
levels. 

3. Use the default for the symbol scale or change if a different scale is necessary. 

 

4. Click Display/Update Alerts to show any warnings. 

5. Click Alert List Report to run the Alerts Report. 
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RF Leveling Tool 
Use the RF Leveling Tool to validate signal levels on a specific RF cable run and verify that all taps, passives 
and actives have been designed within the signal levels configured in the associated design profile. The tool 
runs both forward and return calculations. 

Because it also analyzes the impact of adding devices on an RF run, you can run the RF Leveling Tool after 
completing an RF design to review signal levels on the new network.  

Important: For changes to an existing RF network to take effect, you must run the RF Leveling Tool 
after making any changes. 

To use the RF leveling tool: 

1. Select a cable segment or network element on the map.  

2. Click the RF Leveling Tool button on the RF toolbar. 

3. In the RF Re-Level dialog box, complete the fields as outlined in the table below. 

Check Box Description 
Highlight traced entity(s) Highlights all included elements when the tool runs. 

Auto-update Tap Faceplate values Select the checkbox to adjust all tap faceplate values within design 
specifications. 
Note: When recalculating signal levels on an "as-built" network, do not select 
this option. 

Auto-update Pads and Equalizers Select the checkbox to update pads and equalizers within design 
specifications. 
Note: When recalculating signal levels an "as-built" network, do not select 
this option. 

Terminate at Next Active Select the checkbox to limit the run from the selected element to the next 
active device downstream. 

4.  Click Re-Level. 

• All entities in the trace appear in the RF Level Check - Results dialog box. 

 
• Network devices whose signal levels fall within RF design profile specifications are highlighted in 

green on the map: 
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• Network devices whose signal levels fall outside RF design profile specifications are highlighted in 
yellow or red on the map: 

  

 

  

5. Scroll through the Results list to review components whose signal levels fall outside RF design profile 
specifications. Click Update to recalculate signal levels on all devices. 

Note: If spatialNET is unable to make updates, a warning similar to the following appears, and manual 
updates will be necessary: 

 

See also RF Auto Alert Tool. 
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RF Network Report 
The RF Network Report provides details about the state of the network and displays equipment details. 
Links related to specific types of equipment provide access to other functions (e.g., browse, edit, replace, 
select, zoom to). 

To access the RF Network report: 

1. Click the RF Network Reporting   button on the RF toolbar. 

2. View the report and expand items on the list as desired for further detail. 

 

3. (Optional) Use equipment-related links to directly activate additional functionality that allows for 
editing, replacing and other changes. 
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RF Power Report 
The RF Power Report provides power level information on a selected power supply and associated active 
devices. This report can be saved to a selected file destination and/or printed for future reference. 

To access the RF Power Report: 

1. Select the power supply on the map. 

2. Click the RF Power Report   button on the RF toolbar. 

You can click on the flashlight icon next to a Device type to access additional functionality (select, edit, 
details, browse, zoom to). 

 

3. Click the appropriate button to Save, Print, or Close the report. 
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RF Power Tool 
The RF Power Tool runs a trace on a selected power supply, displays all equipment powered by that power 
supply and lists devices accompanied by warning messages. The RF Power Tool requires a power supply and 
a power inserter joined by an RF cable. See Adding an RF Power Supply and Power Inserter. 

To use the RF Power Tool: 

1. Select the power supply to be traced. 

2. Click the RF Power Tool  button on the RF toolbar. 

3. In the RF Re-Power dialog box, click Re-Power. 

An RF Power Check - Results list opens. 

 

4. Click Update to update the listed entities or click Close to leave power levels as is. 
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Service Area Manager 
Use the Service Area Manager to assign nodes, RF active devices, or RF power supplies to a node boundary. 

To assign a node, RF active device or RF power supply to a node boundary: 

1. Select the boundary on the map. 

2. In the spatialNET menu, click List; then click Service Area Manager. 

3. In the Service Area Manager, select: 

• The Service Area Type 
• The Service Area (options are based on the type of service area chosen above) 
• The class of entities to list or assign 

 

4. Click the following button(s) as necessary:  

• Details to view the boundary details and access additional functionality (Add, Display, Edit, Delete, 
etc.) 

• List to view entities assigned to the boundary, located within the boundary, or not assigned to the 
boundary, or 

• Assign to select and assign entities to the boundary, or 
• Close to close the Service Area Manager. 
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